summaryrefslogtreecommitdiff
path: root/dev-ros/ament_pep257
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-ros/ament_pep257
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-ros/ament_pep257')
-rw-r--r--dev-ros/ament_pep257/Manifest2
-rw-r--r--dev-ros/ament_pep257/ament_pep257-0.10.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ros/ament_pep257/Manifest b/dev-ros/ament_pep257/Manifest
index 28b681bb9237..5f21f12db00f 100644
--- a/dev-ros/ament_pep257/Manifest
+++ b/dev-ros/ament_pep257/Manifest
@@ -1,4 +1,6 @@
DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
+DIST ament_lint-0.10.1.tar.gz 221215 BLAKE2B 47ffa7dfd892b05f345ba962c7c08dcf1627c4653cc75e1a1d1cad28971974ef5ca9c09d3989b3fdbfacd7f94dace9651c44911cd7747f39c5c59083f0195443 SHA512 1dd996d86cfb7488bd6bf57510eb5b7531fe4fe21d25203a4801046ec719ba19afdb89eb7ba9d862317d2e041e7139fadde27d114614d96741a177e8ec2a2ba3
EBUILD ament_pep257-0.10.0.ebuild 1014 BLAKE2B 5a81703962a92ac21544e12395287773fe970456841c1042ef2d655dc4597d86240a990ae322e3406026dd5f921776ef2e310699f7daf92ae402af9b24f01822 SHA512 ff765b32ff0a7e4ec81a55b9590cd66841daafbee029d62343281ef1ecc9887e5ad963fe2f7a51fad838a881fa42463b574e6923385b3dfc8b9d6859e213834d
+EBUILD ament_pep257-0.10.1.ebuild 1014 BLAKE2B 8f4b833434ab1bb56b7920298b1631678fcc906c03164b5a6768c3926f832c401d30394a245cea458a641d5c0549f3d6dcdbfd3728e4d0a3ef247fe67632018a SHA512 8782acb7ad825140abd83f6f674066cb7225dd7166ae6617b33c9edef65258a21f459e7cfe149b8bddb2696f78ccf0af19e6066c3719f0eb7c32e938b18b2830
EBUILD ament_pep257-9999.ebuild 1014 BLAKE2B 5a81703962a92ac21544e12395287773fe970456841c1042ef2d655dc4597d86240a990ae322e3406026dd5f921776ef2e310699f7daf92ae402af9b24f01822 SHA512 ff765b32ff0a7e4ec81a55b9590cd66841daafbee029d62343281ef1ecc9887e5ad963fe2f7a51fad838a881fa42463b574e6923385b3dfc8b9d6859e213834d
MISC metadata.xml 330 BLAKE2B 6b820c3189393a7216b0c5681a814e8fbbae006e285bd0673cb6e4ef05e10c7db229b4759fb6911aab2ad4222f823e8b5495f17f7032317949d0374df6c56e81 SHA512 f9aa499007ca33a8e21ab871f868f4e8cbdf5fa27acb6195bf41d8d3de185f344517eace9b7e91a7da26ba0bfacb00ae054ef8e240e235e734e86160f49c941b
diff --git a/dev-ros/ament_pep257/ament_pep257-0.10.1.ebuild b/dev-ros/ament_pep257/ament_pep257-0.10.1.ebuild
new file mode 100644
index 000000000000..08b1b6af9f30
--- /dev/null
+++ b/dev-ros/ament_pep257/ament_pep257-0.10.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Checks code against style conventions in PEP 8 and generate test result files"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-python/pydocstyle[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest