summaryrefslogtreecommitdiff
path: root/dev-ros/ament_lint_auto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-ros/ament_lint_auto
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-ros/ament_lint_auto')
-rw-r--r--dev-ros/ament_lint_auto/Manifest2
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ros/ament_lint_auto/Manifest b/dev-ros/ament_lint_auto/Manifest
index dcb0095131ec..430439d1bb38 100644
--- a/dev-ros/ament_lint_auto/Manifest
+++ b/dev-ros/ament_lint_auto/Manifest
@@ -1,4 +1,6 @@
+DIST ament_lint-0.10.0.tar.gz 219525 BLAKE2B 6ba7a32d0678e545c24b74ed187991140c34a363ad855e469f0e20f8a088b7cc939bbd187566233e099576e4c2b899d7d75edf311d3026234222078968be7ce6 SHA512 565413fa325317e6f00ce18051eb13556d1d50144d2c8f62368e5505455ef7f9fae3a69e8d723a3949e44b1f9e638741ae6d9b87687df81a661eb804365200f8
DIST ament_lint-0.9.5.tar.gz 218077 BLAKE2B bc49fdb517bcdab815cfd4c945e9d61a9b53d4b600361ced9161b6186bfb74fdb3d5ed5f14a48f22a91fd0737333dc76cc7d55044c204ea864b53dd68e32254b SHA512 1c5b3acb31a07f4613e13fe69f6dad1981df0dc596e46a07651322a4da1c5f3db40befb775aa42aabc1f6808132c950c9f37950f64b4196e3c1b40871e25a384
+EBUILD ament_lint_auto-0.10.0.ebuild 1172 BLAKE2B ac440b1fb55484c7d9f85dfe512af394474333ec6233ebc0cf54dc2383b5a14285693f6db4ffc1bd1f6631b6c4e7dc48b569e5e79e86dca6dab412e01e1af744 SHA512 aaa135a58122470a3ff8e86c2aecc3e5f09af378abf3bf85af575b692f79ad96ad7fad7b038289319c756bd8f0d179a0e6135aa6ccafaaeb595e22c1430162f1
EBUILD ament_lint_auto-0.9.5.ebuild 1172 BLAKE2B ac440b1fb55484c7d9f85dfe512af394474333ec6233ebc0cf54dc2383b5a14285693f6db4ffc1bd1f6631b6c4e7dc48b569e5e79e86dca6dab412e01e1af744 SHA512 aaa135a58122470a3ff8e86c2aecc3e5f09af378abf3bf85af575b692f79ad96ad7fad7b038289319c756bd8f0d179a0e6135aa6ccafaaeb595e22c1430162f1
EBUILD ament_lint_auto-9999.ebuild 1172 BLAKE2B ac440b1fb55484c7d9f85dfe512af394474333ec6233ebc0cf54dc2383b5a14285693f6db4ffc1bd1f6631b6c4e7dc48b569e5e79e86dca6dab412e01e1af744 SHA512 aaa135a58122470a3ff8e86c2aecc3e5f09af378abf3bf85af575b692f79ad96ad7fad7b038289319c756bd8f0d179a0e6135aa6ccafaaeb595e22c1430162f1
MISC metadata.xml 330 BLAKE2B 6b820c3189393a7216b0c5681a814e8fbbae006e285bd0673cb6e4ef05e10c7db229b4759fb6911aab2ad4222f823e8b5495f17f7032317949d0374df6c56e81 SHA512 f9aa499007ca33a8e21ab871f868f4e8cbdf5fa27acb6195bf41d8d3de185f344517eace9b7e91a7da26ba0bfacb00ae054ef8e240e235e734e86160f49c941b
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild
new file mode 100644
index 000000000000..120c90db0dd4
--- /dev/null
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-0.10.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The auto-magic functions for ease to use of the ament linters"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+ dev-ros/ament_cmake_test
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+
+python_check_deps() {
+ has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+ has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}