summaryrefslogtreecommitdiff
path: root/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-05 01:18:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-05 01:18:42 +0100
commit5b84ef1b7530528af1eda8310641c6396df8143c (patch)
tree1dd8187ec16709816078d4b474e15257409a25db /dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
parent07b0c0005f55e652101816d9f4cfe73403bf0906 (diff)
gentoo auto-resync : 05:10:2022 - 01:18:42
Diffstat (limited to 'dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild')
-rw-r--r--dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild b/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
index 7c0ae86f0a35..f4bba4298b4b 100644
--- a/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
+++ b/dev-ros/ament_lint_auto/ament_lint_auto-0.11.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,14 +30,13 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
# Deps here are transitive from ament_cmake_core to have matching python support
-BDEPEND="
+BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep '
dev-python/ament_package[${PYTHON_USEDEP}]
dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
"
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}