summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cpplint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/ament_cpplint
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/ament_cpplint')
-rw-r--r--dev-ros/ament_cpplint/Manifest4
-rw-r--r--dev-ros/ament_cpplint/ament_cpplint-0.9.5.ebuild45
-rw-r--r--dev-ros/ament_cpplint/ament_cpplint-9999.ebuild45
-rw-r--r--dev-ros/ament_cpplint/metadata.xml11
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-ros/ament_cpplint/Manifest b/dev-ros/ament_cpplint/Manifest
new file mode 100644
index 000000000000..04779351cabc
--- /dev/null
+++ b/dev-ros/ament_cpplint/Manifest
@@ -0,0 +1,4 @@
+DIST ament_lint-0.9.5.tar.gz 218077 BLAKE2B bc49fdb517bcdab815cfd4c945e9d61a9b53d4b600361ced9161b6186bfb74fdb3d5ed5f14a48f22a91fd0737333dc76cc7d55044c204ea864b53dd68e32254b SHA512 1c5b3acb31a07f4613e13fe69f6dad1981df0dc596e46a07651322a4da1c5f3db40befb775aa42aabc1f6808132c950c9f37950f64b4196e3c1b40871e25a384
+EBUILD ament_cpplint-0.9.5.ebuild 986 BLAKE2B 9905865e8c4138fd906c704461de13087fb8f211d0e8969e63014344f750003d3225339affa9767d25c8b3ce933728323d964997a9f8992eef24d3cd9f61456a SHA512 d2c675161d3b76deee6286b32fd5ecc6e2b521f21a893c0f611b55472548a30c26f64912fa63094bf875fde8406d484ff143e4991a7627f2abc5345abc9138de
+EBUILD ament_cpplint-9999.ebuild 986 BLAKE2B 9905865e8c4138fd906c704461de13087fb8f211d0e8969e63014344f750003d3225339affa9767d25c8b3ce933728323d964997a9f8992eef24d3cd9f61456a SHA512 d2c675161d3b76deee6286b32fd5ecc6e2b521f21a893c0f611b55472548a30c26f64912fa63094bf875fde8406d484ff143e4991a7627f2abc5345abc9138de
+MISC metadata.xml 330 BLAKE2B 6b820c3189393a7216b0c5681a814e8fbbae006e285bd0673cb6e4ef05e10c7db229b4759fb6911aab2ad4222f823e8b5495f17f7032317949d0374df6c56e81 SHA512 f9aa499007ca33a8e21ab871f868f4e8cbdf5fa27acb6195bf41d8d3de185f344517eace9b7e91a7da26ba0bfacb00ae054ef8e240e235e734e86160f49c941b
diff --git a/dev-ros/ament_cpplint/ament_cpplint-0.9.5.ebuild b/dev-ros/ament_cpplint/ament_cpplint-0.9.5.ebuild
new file mode 100644
index 000000000000..429c4f07a46d
--- /dev/null
+++ b/dev-ros/ament_cpplint/ament_cpplint-0.9.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check code against the Google style conventions using cpplint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild b/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild
new file mode 100644
index 000000000000..429c4f07a46d
--- /dev/null
+++ b/dev-ros/ament_cpplint/ament_cpplint-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to check code against the Google style conventions using cpplint"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_copyright[${PYTHON_USEDEP}]
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-ros/ament_pep257[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest
diff --git a/dev-ros/ament_cpplint/metadata.xml b/dev-ros/ament_cpplint/metadata.xml
new file mode 100644
index 000000000000..d5919f1304a0
--- /dev/null
+++ b/dev-ros/ament_cpplint/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ament/ament_lint</remote-id>
+ </upstream>
+</pkgmetadata>