summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild')
-rw-r--r--dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild b/dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild
deleted file mode 100644
index 7a2b556580d5..000000000000
--- a/dev-ros/ament_cppcheck/ament_cppcheck-0.11.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2019-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_9,3_10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-ROS_PN="ament_lint"
-if [ "${PV#9999}" != "${PV}" ] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
-else
- SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
- S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
-fi
-
-DESCRIPTION="The ability to perform static code analysis on C/C++ code using Cppcheck"
-HOMEPAGE="https://github.com/ament/ament_lint"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE=""
-
-RDEPEND="
- dev-util/cppcheck
-"
-DEPEND=""
-BDEPEND=""
-
-# pytest.ini is there but no tests are ran causing it to fail
-RESTRICT="test"
-
-distutils_enable_tests pytest