summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild')
-rw-r--r--dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
index ba3ee494af1c..826f45045e89 100644
--- a/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
+++ b/dev-ros/ament_cmake_uncrustify/ament_cmake_uncrustify-0.11.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit cmake python-any-r1
@@ -11,11 +11,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="The CMake API for ament_uncrustify to check code against styleconventions"
@@ -23,11 +23,6 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
IUSE="test"
RESTRICT="!test? ( test )"
@@ -35,9 +30,10 @@ RDEPEND="
dev-ros/ament_cmake_test
dev-ros/ament_uncrustify
"
-DEPEND=""
BDEPEND="
- $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep '
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]')
dev-ros/ament_cmake_test
dev-ros/ament_cmake_core
test? (