summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_test
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ros/ament_cmake_test
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ros/ament_cmake_test')
-rw-r--r--dev-ros/ament_cmake_test/Manifest4
-rw-r--r--dev-ros/ament_cmake_test/ament_cmake_test-0.8.1.ebuild59
-rw-r--r--dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild59
-rw-r--r--dev-ros/ament_cmake_test/metadata.xml11
4 files changed, 133 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_test/Manifest b/dev-ros/ament_cmake_test/Manifest
new file mode 100644
index 000000000000..fab74a4dab92
--- /dev/null
+++ b/dev-ros/ament_cmake_test/Manifest
@@ -0,0 +1,4 @@
+DIST ament_cmake-0.8.1.tar.gz 57078 BLAKE2B 4c6d5c821ffef6288cdd400aa9b084fcbfb33d6c9accddd1349bd656d3b3de9e779603bdad256e3f74a292e3805f06e00ba85719f09fe441f6eecdbd236cc878 SHA512 ae6bfe95585a331055ae159f8b4363f237602ece929877766a8c8bd5bfc0b423379dee38e9fe2707f92ed9753564281be13af1202ec4e9b545d293485884f35e
+EBUILD ament_cmake_test-0.8.1.ebuild 1265 BLAKE2B 4adc20d086fba6223df474bc8164c576e66f97a982cb5833c4bcc324436501f71c7775c4ebde40a407b117a6fc13a62d8264cc618075baedb8dabc672e49d6e3 SHA512 3133d5f3fec6035fd0e7c43207d76648b9dd10b3ee92f50949189e4e98ee0bbd47f6a62d5dd79a1806d6af52b3e68cfa4385adb302cf4adb19c78edd44356df7
+EBUILD ament_cmake_test-9999.ebuild 1265 BLAKE2B 4adc20d086fba6223df474bc8164c576e66f97a982cb5833c4bcc324436501f71c7775c4ebde40a407b117a6fc13a62d8264cc618075baedb8dabc672e49d6e3 SHA512 3133d5f3fec6035fd0e7c43207d76648b9dd10b3ee92f50949189e4e98ee0bbd47f6a62d5dd79a1806d6af52b3e68cfa4385adb302cf4adb19c78edd44356df7
+MISC metadata.xml 331 BLAKE2B 57a4aabab6c138bc97c67d610a56eed290c8da0c1f81fa44ab734d1a932ae0f93e0a826431eaccbd6c512fbcdc4a3b5840e6971e145a92b0c6fc87e0edbb3a92 SHA512 ba55ade8e610e2bcc2c4d54b68422045d0110a3975c6893997a92185ea256edf96d815eaeacfd4193f8dfd8706052142b30b3f546f5806b5809478342a01f394
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-0.8.1.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-0.8.1.ebuild
new file mode 100644
index 000000000000..fc08c8b4c3ee
--- /dev/null
+++ b/dev-ros/ament_cmake_test/ament_cmake_test-0.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1 python-utils-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_python
+ ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_foreach_impl cmake-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+ python_foreach_impl python_optimize
+}
diff --git a/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild b/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
new file mode 100644
index 000000000000..fc08c8b4c3ee
--- /dev/null
+++ b/dev-ros/ament_cmake_test/ament_cmake_test-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1 python-utils-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to add tests in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-ros/ament_cmake_core
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-ros/ament_cmake_python
+ ${PYTHON_DEPS}
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_foreach_impl cmake-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl cmake-utils_src_compile
+}
+
+src_test() {
+ python_foreach_impl cmake-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl cmake-utils_src_install
+ python_foreach_impl python_optimize
+}
diff --git a/dev-ros/ament_cmake_test/metadata.xml b/dev-ros/ament_cmake_test/metadata.xml
new file mode 100644
index 000000000000..d1baaf5c70f1
--- /dev/null
+++ b/dev-ros/ament_cmake_test/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ament/ament_cmake</remote-id>
+ </upstream>
+</pkgmetadata>