summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ros/ament_cmake_python
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ros/ament_cmake_python')
-rw-r--r--dev-ros/ament_cmake_python/Manifest5
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild42
-rw-r--r--dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild42
-rw-r--r--dev-ros/ament_cmake_python/files/destdir.patch26
-rw-r--r--dev-ros/ament_cmake_python/metadata.xml11
5 files changed, 126 insertions, 0 deletions
diff --git a/dev-ros/ament_cmake_python/Manifest b/dev-ros/ament_cmake_python/Manifest
new file mode 100644
index 000000000000..060074eec0b6
--- /dev/null
+++ b/dev-ros/ament_cmake_python/Manifest
@@ -0,0 +1,5 @@
+AUX destdir.patch 1203 BLAKE2B fe4e783ea9d4802752d79d489e5b05d0ca9688a76d678521af41f232005da611c0286f594d15045dcae5610362ccc1bb878d29bddbeb86a9452b0289af347d67 SHA512 85e196c9777a6cc8b8b693e3825d5027c7a5db0a74008ad34d9be3714a088a9e651bb99ce53ee2bd95c47b2c1f8c2c657fa18cce0f13b11e4ea437cdd03ef0b3
+DIST ament_cmake-0.8.1.tar.gz 57078 BLAKE2B 4c6d5c821ffef6288cdd400aa9b084fcbfb33d6c9accddd1349bd656d3b3de9e779603bdad256e3f74a292e3805f06e00ba85719f09fe441f6eecdbd236cc878 SHA512 ae6bfe95585a331055ae159f8b4363f237602ece929877766a8c8bd5bfc0b423379dee38e9fe2707f92ed9753564281be13af1202ec4e9b545d293485884f35e
+EBUILD ament_cmake_python-0.8.1-r1.ebuild 1032 BLAKE2B 8113b0daaed54dba1b76fcf18ee95f335591037d6ad83a5b0f9e7c6665c270a6fcbc8b27bbe28e63957c93d53b49d9fcbcebabc7db7ede8ce2358c85e12308dc SHA512 ebb58bf8f4b1e7f7afbad4f5d9bd5ae56dab68307e6c58361ecce66dbc98b70bb959e9d3db97aa83bcd11184be3cf0551c4477233417be7a646b4e22dfe163c1
+EBUILD ament_cmake_python-9999.ebuild 1032 BLAKE2B 8113b0daaed54dba1b76fcf18ee95f335591037d6ad83a5b0f9e7c6665c270a6fcbc8b27bbe28e63957c93d53b49d9fcbcebabc7db7ede8ce2358c85e12308dc SHA512 ebb58bf8f4b1e7f7afbad4f5d9bd5ae56dab68307e6c58361ecce66dbc98b70bb959e9d3db97aa83bcd11184be3cf0551c4477233417be7a646b4e22dfe163c1
+MISC metadata.xml 331 BLAKE2B 57a4aabab6c138bc97c67d610a56eed290c8da0c1f81fa44ab734d1a932ae0f93e0a826431eaccbd6c512fbcdc4a3b5840e6971e145a92b0c6fc87e0edbb3a92 SHA512 ba55ade8e610e2bcc2c4d54b68422045d0110a3975c6893997a92185ea256edf96d815eaeacfd4193f8dfd8706052142b30b3f546f5806b5809478342a01f394
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..fba573262bf6
--- /dev/null
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-0.8.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to use Python in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+PATCHES=( "${FILESDIR}/destdir.patch" )
diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
new file mode 100644
index 000000000000..fba573262bf6
--- /dev/null
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to use Python in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
+PATCHES=( "${FILESDIR}/destdir.patch" )
diff --git a/dev-ros/ament_cmake_python/files/destdir.patch b/dev-ros/ament_cmake_python/files/destdir.patch
new file mode 100644
index 000000000000..8e8f628afaf3
--- /dev/null
+++ b/dev-ros/ament_cmake_python/files/destdir.patch
@@ -0,0 +1,26 @@
+Index: ament_cmake_python/cmake/ament_python_install_module.cmake
+===================================================================
+--- ament_cmake_python.orig/cmake/ament_python_install_module.cmake
++++ ament_cmake_python/cmake/ament_python_install_module.cmake
+@@ -64,7 +64,7 @@ function(_ament_cmake_python_install_mod
+ "execute_process(
+ COMMAND
+ \"${PYTHON_EXECUTABLE}\" \"-m\" \"compileall\"
+- \"${CMAKE_INSTALL_PREFIX}/${destination}/${module_file}\"
++ \"\$ENV{DESTDIR}/${CMAKE_INSTALL_PREFIX}/${destination}/${module_file}\"
+ )"
+ )
+ endif()
+Index: ament_cmake_python/cmake/ament_python_install_package.cmake
+===================================================================
+--- ament_cmake_python.orig/cmake/ament_python_install_package.cmake
++++ ament_cmake_python/cmake/ament_python_install_package.cmake
+@@ -65,7 +65,7 @@ function(_ament_cmake_python_install_pac
+ "execute_process(
+ COMMAND
+ \"${PYTHON_EXECUTABLE}\" \"-m\" \"compileall\"
+- \"${CMAKE_INSTALL_PREFIX}/${PYTHON_INSTALL_DIR}/${package_name}\"
++ \"\$ENV{DESTDIR}/${CMAKE_INSTALL_PREFIX}/${PYTHON_INSTALL_DIR}/${package_name}\"
+ )"
+ )
+ endif()
diff --git a/dev-ros/ament_cmake_python/metadata.xml b/dev-ros/ament_cmake_python/metadata.xml
new file mode 100644
index 000000000000..d1baaf5c70f1
--- /dev/null
+++ b/dev-ros/ament_cmake_python/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ament/ament_cmake</remote-id>
+ </upstream>
+</pkgmetadata>