summaryrefslogtreecommitdiff
path: root/dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-04 13:17:38 +0100
commit78754950ffa3aaba0f48b1ca1d505caa4a3dfbfa (patch)
tree285997f09f32d26633ba2beffd30c972a4ec87a2 /dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild
parentbf99f8024d68382f76665735c70ae912331bc2ca (diff)
gentoo auto-resync : 04:10:2022 - 13:17:38
Diffstat (limited to 'dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild')
-rw-r--r--dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild b/dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild
index 102deab4e5c7..b015998c0bf2 100644
--- a/dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild
+++ b/dev-ros/ament_cmake_core/ament_cmake_core-1.3.0.ebuild
@@ -11,7 +11,6 @@ ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_cmake"
- SRC_URI=""
S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
@@ -28,19 +27,19 @@ if [ "${PV#9999}" != "${PV}" ] ; then
else
KEYWORDS="~amd64"
fi
-IUSE=""
RDEPEND="
dev-python/ament_package
dev-python/catkin_pkg
"
DEPEND="${RDEPEND}"
-BDEPEND="
- $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
- ${PYTHON_DEPS}
+BDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/ament_package[${PYTHON_USEDEP}]
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]')
"
python_check_deps() {
- has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
- has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/ament_package[${PYTHON_USEDEP}]" \
+ "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
}