summaryrefslogtreecommitdiff
path: root/dev-ros/actionlib/actionlib-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-ros/actionlib/actionlib-9999.ebuild
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-ros/actionlib/actionlib-9999.ebuild')
-rw-r--r--dev-ros/actionlib/actionlib-9999.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-ros/actionlib/actionlib-9999.ebuild b/dev-ros/actionlib/actionlib-9999.ebuild
deleted file mode 100644
index 2249140310b3..000000000000
--- a/dev-ros/actionlib/actionlib-9999.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-CATKIN_HAS_MESSAGES=yes
-ROS_REPO_URI="https://github.com/ros/actionlib"
-KEYWORDS="~amd64 ~arm"
-CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="dev-libs/boost:=
- dev-ros/roscpp
- dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
- "
-DEPEND="${RDEPEND}
- dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
- test? (
- dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
- dev-ros/rosnode[${PYTHON_SINGLE_USEDEP}]
- dev-cpp/gtest
- )"
-RDEPEND="${RDEPEND}
- dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
- dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
-"
-
-src_test() {
- export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- ros-catkin_src_test
-}