summaryrefslogtreecommitdiff
path: root/dev-qt/qtxml/qtxml-5.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-qt/qtxml/qtxml-5.15.2.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-qt/qtxml/qtxml-5.15.2.ebuild')
-rw-r--r--dev-qt/qtxml/qtxml-5.15.2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-qt/qtxml/qtxml-5.15.2.ebuild b/dev-qt/qtxml/qtxml-5.15.2.ebuild
index 57acaeaa59ae..140dd50a8a60 100644
--- a/dev-qt/qtxml/qtxml-5.15.2.ebuild
+++ b/dev-qt/qtxml/qtxml-5.15.2.ebuild
@@ -2,10 +2,12 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
QT5_MODULE="qtbase"
inherit qt5-build
DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
@@ -27,3 +29,5 @@ QT5_TARGET_SUBDIRS=(
QT5_GENTOO_PRIVATE_CONFIG=(
:xml
)
+
+PATCHES=( "${WORKDIR}/qtbase-${PV}-gcc11.patch" ) # bug 752012