summaryrefslogtreecommitdiff
path: root/dev-qt/qtxml/qtxml-5.12.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:45:37 +0100
commita1392efe64137262023d92492396ca9156d22396 (patch)
treede438b2711c7697c4597fb04f07e988586f34233 /dev-qt/qtxml/qtxml-5.12.5.ebuild
parente3cf2c86fca1750343c1885311f857f185ee4f2d (diff)
gentoo resync : 13.09.2019
Diffstat (limited to 'dev-qt/qtxml/qtxml-5.12.5.ebuild')
-rw-r--r--dev-qt/qtxml/qtxml-5.12.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-qt/qtxml/qtxml-5.12.5.ebuild b/dev-qt/qtxml/qtxml-5.12.5.ebuild
new file mode 100644
index 000000000000..a7668e1ef6ca
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.12.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtnetwork-${PV} )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :xml
+)