summaryrefslogtreecommitdiff
path: root/dev-qt/qtwebkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-qt/qtwebkit
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-qt/qtwebkit')
-rw-r--r--dev-qt/qtwebkit/Manifest3
-rw-r--r--dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20200309-icu-68.patch120
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.212.0_pre20200309-r1.ebuild5
3 files changed, 126 insertions, 2 deletions
diff --git a/dev-qt/qtwebkit/Manifest b/dev-qt/qtwebkit/Manifest
index d7e6769db468..f1b0248ed0d6 100644
--- a/dev-qt/qtwebkit/Manifest
+++ b/dev-qt/qtwebkit/Manifest
@@ -1,4 +1,5 @@
AUX qtwebkit-5.212.0_pre20200309-bison-3.7.patch 1613 BLAKE2B 0d2d173b5575ed5e1c52a07c5ceb14210bfb0a91e50a064df1e293451d64708822eb54d65947413efb13711d4c0c8e01441869248a4461446bd2bc122f07746b SHA512 cf21eff51e1026f4e506724a512b9925d4619909f5924bf01055244817ec9594e9d3ce105b510cd28ecce4772d122d1393fb7273501e20e16749f43282a3200b
+AUX qtwebkit-5.212.0_pre20200309-icu-68.patch 4981 BLAKE2B c031aa8ec816749fa35e3876d007a02d60a3a5ff0fc57a2774a13fc23559b39cc5bfeec6fedd96cb36d7eed5d1b388049d190673afbe5b0fd2f0343f8afd5344 SHA512 b1cf2a5c07e4876e74913687417ffd751e6dcb3fa783c545ba50064d31c9a4bb1515ce9c26b399f2b9b53b588791e4e6f571ad7cfe631087ecd3709bce675a9e
DIST qtwebkit-5.212.0-alpha4.tar.xz 12528508 BLAKE2B 72d7444f270f47b62044cf683ed306803660bfbafe1450440ea29e43e3c0e6e841b6e860dfa8affc1b32b7c539448f04e22a7ae38cce055d37905dfb3240aab0 SHA512 33f11270bd030599beff9c1983a6c5ff2d61f407cc8a6825f7f405d46f9184c720fc7f60c7359f08f828db96a2170092875066a0d5c0a21ff09bc48a2603fbf6
-EBUILD qtwebkit-5.212.0_pre20200309-r1.ebuild 3934 BLAKE2B b94f1d729667fa6e2abd67951b09dcfb856c38f6e28cfafdeeacac4bc1970db4521ada4c42557ceb1b69815e9491ef8177fae9f4919381acff498a3b22b7428d SHA512 231f042c6f2b258bc908e117f395e02477dfc1f45587e055c26538a31df74a198e61f37cbec0d5eb356b724d75c0a1b9352b3b91a4c0f53314fd9984f771b296
+EBUILD qtwebkit-5.212.0_pre20200309-r1.ebuild 3981 BLAKE2B 80fde8478337ea3d2bc557761836b14c3876fffc5134858e739a53cf48a5f1a335710c59410048ab9e9ceddc92a322f829eb6486e32730dbf0d9fb6f207dec70 SHA512 7ffab643e6e078cbf6f968f7aaad8849c888da8f7117098275b66b09e2b0bf5eb3516af25fe548a6a841a6a48bcfd595ae569d0f5beaba1b5ee50bca8112e1f6
MISC metadata.xml 1152 BLAKE2B 6291c4643d29dd68af56e6054c4db1ebb307fdf2097012182dc77a2754e51bca84c1f53ae7c9f6305ead35cc47334a9e0ca605871aac899ce06482d983c8406f SHA512 28146a11931ab5b106d7bfa08dd3cb38ed3ae1fec003ca27f3f3234887bc9d65a82c76e5ab50334e94de02c3b6455a228acec2574c551e218e53e2005becc6c6
diff --git a/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20200309-icu-68.patch b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20200309-icu-68.patch
new file mode 100644
index 000000000000..7de72ea61aff
--- /dev/null
+++ b/dev-qt/qtwebkit/files/qtwebkit-5.212.0_pre20200309-icu-68.patch
@@ -0,0 +1,120 @@
+--- a/Source/WebCore/platform/text/icu/UTextProvider.h
++++ b/Source/WebCore/platform/text/icu/UTextProvider.h
+@@ -80,12 +80,12 @@
+ // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
+ ASSERT(offset < std::numeric_limits<int32_t>::max());
+ text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
+- isAccessible = TRUE;
++ isAccessible = true;
+ return true;
+ }
+ if (nativeIndex >= nativeLength && text->chunkNativeLimit == nativeLength) {
+ text->chunkOffset = text->chunkLength;
+- isAccessible = FALSE;
++ isAccessible = false;
+ return true;
+ }
+ } else {
+@@ -94,12 +94,12 @@
+ // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
+ ASSERT(offset < std::numeric_limits<int32_t>::max());
+ text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
+- isAccessible = TRUE;
++ isAccessible = true;
+ return true;
+ }
+ if (nativeIndex <= 0 && !text->chunkNativeStart) {
+ text->chunkOffset = 0;
+- isAccessible = FALSE;
++ isAccessible = false;
+ return true;
+ }
+ }
+--- a/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
++++ b/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
+@@ -100,23 +100,23 @@
+ if (index < uText->chunkNativeLimit && index >= uText->chunkNativeStart) {
+ // Already inside the buffer. Set the new offset.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return TRUE;
++ return true;
+ }
+ if (index >= length && uText->chunkNativeLimit == length) {
+ // Off the end of the buffer, but we can't get it.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return FALSE;
++ return false;
+ }
+ } else {
+ if (index <= uText->chunkNativeLimit && index > uText->chunkNativeStart) {
+ // Already inside the buffer. Set the new offset.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return TRUE;
++ return true;
+ }
+ if (!index && !uText->chunkNativeStart) {
+ // Already at the beginning; can't go any farther.
+ uText->chunkOffset = 0;
+- return FALSE;
++ return false;
+ }
+ }
+
+@@ -144,7 +144,7 @@
+
+ uText->nativeIndexingLimit = uText->chunkLength;
+
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextLatin1Extract(UText* uText, int64_t start, int64_t limit, UChar* dest, int32_t destCapacity, UErrorCode* status)
+@@ -336,7 +336,7 @@
+ static UBool uTextLatin1ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
+ {
+ if (!text->context)
+- return FALSE;
++ return false;
+ int64_t nativeLength = uTextLatin1ContextAwareNativeLength(text);
+ UBool isAccessible;
+ if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
+@@ -356,7 +356,7 @@
+ ASSERT(newContext == UTextProviderContext::PriorContext);
+ textLatin1ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
+ }
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextLatin1ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)
+--- a/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
++++ b/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
+@@ -125,7 +125,7 @@
+ static UBool uTextUTF16ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
+ {
+ if (!text->context)
+- return FALSE;
++ return false;
+ int64_t nativeLength = uTextUTF16ContextAwareNativeLength(text);
+ UBool isAccessible;
+ if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
+@@ -145,7 +145,7 @@
+ ASSERT(newContext == UTextProviderContext::PriorContext);
+ textUTF16ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
+ }
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextUTF16ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)
+--- a/Source/WebCore/platform/text/TextCodecICU.cpp
++++ b/Source/WebCore/platform/text/TextCodecICU.cpp
+@@ -308,7 +308,7 @@
+ m_converterICU = ucnv_open(m_canonicalConverterName, &err);
+ ASSERT(U_SUCCESS(err));
+ if (m_converterICU)
+- ucnv_setFallback(m_converterICU, TRUE);
++ ucnv_setFallback(m_converterICU, true);
+ }
+
+ int TextCodecICU::decodeToBuffer(UChar* target, UChar* targetLimit, const char*& source, const char* sourceLimit, int32_t* offsets, bool flush, UErrorCode& err)
diff --git a/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20200309-r1.ebuild b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20200309-r1.ebuild
index f7f37face2cb..0643a363a478 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20200309-r1.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.212.0_pre20200309-r1.ebuild
@@ -83,7 +83,10 @@ RDEPEND="${DEPEND}"
CHECKREQS_DISK_BUILD="16G" # bug 417307
-PATCHES=( "${FILESDIR}/${P}-bison-3.7.patch" ) # bug 736499
+PATCHES=(
+ "${FILESDIR}/${P}-bison-3.7.patch" # bug 736499
+ "${FILESDIR}/${P}-icu-68.patch" # bug 753260
+)
_check_reqs() {
if [[ ${MERGE_TYPE} != binary ]] && is-flagq "-g*" && ! is-flagq "-g*0"; then