summaryrefslogtreecommitdiff
path: root/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 01:22:10 +0000
commitf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (patch)
tree66ba5228853030737ae2dd9c9894b96266213246 /dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.7.ebuild
parent1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (diff)
gentoo auto-resync : 30:11:2022 - 01:22:10
Diffstat (limited to 'dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.7.ebuild')
-rw-r--r--dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.7.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.7.ebuild b/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.7.ebuild
new file mode 100644
index 000000000000..7d5383f04ba0
--- /dev/null
+++ b/dev-qt/qtwaylandscanner/qtwaylandscanner-5.15.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QT5_MODULE="qtwayland"
+inherit qt5-build
+
+DESCRIPTION="Tool that generates certain boilerplate C++ code from Wayland protocol xml spec"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DEPEND="=dev-qt/qtcore-${QT5_PV}*:5="
+RDEPEND="${DEPEND}
+ !<dev-qt/qtwayland-5.15.3:5
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/qtwaylandscanner
+)