summaryrefslogtreecommitdiff
path: root/dev-qt/qtwayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-qt/qtwayland
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest2
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index de06a596571d..e2c1acdd3bbf 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,3 +1,5 @@
DIST qtwayland-everywhere-src-5.15.1.tar.xz 563508 BLAKE2B 507e8612a35c6439fab0637edfcae95d712daf19c0a8b97110b57b8a8ffd70374addc3ef19f210eedc9493d84ec441f18bd0fd5a25af5394fde40ee55573eb09 SHA512 d6619f35b3ab163372a0d49a2221c487d5936b6d9ebeb92a7fd41521c424d550eea7c5c584e07f15bde1ec5ece1bd5774845eb9956ce793e546197ffdb28d594
+DIST qtwayland-everywhere-src-5.15.2.tar.xz 564884 BLAKE2B 472effd3e9f3fd5470e0449703a52d45f2fd823770880b5ad15d8bf99196eee5d8511ca2bc9e23df6e27c933551d1853928ba79b4b1e5fa6e53334c54c04a463 SHA512 e8657ed676873da7b949e6a1605d025918a03336af9c68f32741945ec3c71a604def55bb00737ba4d97b91c00d0e2df1a83cdcedcf5795c6b2a1ef2caa21c91c
EBUILD qtwayland-5.15.1.ebuild 830 BLAKE2B c4c4d0bdf3f694158e36f4f4d5ddf6190efb5c45a7aa4d8d65f12ddeb0adc777d8a01cdb667b9f08f4ab72dd9c6d0038ee5bced396ac90b16013af28369cfb6c SHA512 378a00c2d6ce25b4abbfb08bbaddb1361c0d79090239ff6de2408aaceb27cb8268f991c29f69b7de9db44ebfea166813ac996cc0339f2b2e4cd2ec5097af0d50
+EBUILD qtwayland-5.15.2.ebuild 836 BLAKE2B 1a24a6ae4ffcd8a3e87b43dc21f6e465b0c83a4dc00d24cb2bf76f0124d29cd2caecb1d367d3d10eeed6cad9f44db4b520d3a25ed226bad783c607c99ddf28e2 SHA512 3a1eae3e8b807816c5ea20a8afd3db7906d39f0ff7906c352598c405cb458dda8c7c9c67e3bd0890eb0276f87d4133a651f1bb2ef569acd1fa9c81259b440c57
MISC metadata.xml 583 BLAKE2B 2f04d6e39831120e7a38de5172b26f29bdb19e4677588595e5281000b14dc5ebcc0984fde5e99330807f8c400b7abb3c0cfbdaa7f131c815d60680259532cd3a SHA512 3b76305c692c7e9b2f0d82862ced25a4a306fc23611f7c22dfed3b19d55072373cca7bf2d4e6bfc14276986082cebfe19e7637c780acde1f421bb1baaf95f27a
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2.ebuild
new file mode 100644
index 000000000000..e292407158a9
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.15.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="vulkan X"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
+ X? (
+ ~dev-qt/qtgui-${PV}[-gles2-only]
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myqmakeargs=(
+ --
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ $(qt_use X feature-xcomposite-egl)
+ $(qt_use X feature-xcomposite-glx)
+ )
+ qt5-build_src_configure
+}