summaryrefslogtreecommitdiff
path: root/dev-qt/qtwayland
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-qt/qtwayland
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest2
-rw-r--r--dev-qt/qtwayland/qtwayland-5.12.4.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 60b6feed5ccb..b21c6cf8b6ff 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,3 +1,5 @@
DIST qtwayland-everywhere-src-5.12.3.tar.xz 432304 BLAKE2B eb2ba520c651467c8ed5f0d870a69c9b07047cb4c05a0c889b36abeab30149861b83ca693efb0bb93dce4f5da5913afc3c8b61933ef0e8307d22b64fce530d87 SHA512 e66f9f41c15cf84165e559a1ff09e20ec21bb3f909b57fab08b0e3f8f9eeacf75d49541b499b1a6514a34d1ba5dd426ec1ce77719910588afa12cb3a7980dc90
+DIST qtwayland-everywhere-src-5.12.4.tar.xz 434076 BLAKE2B f034080ec3ad8281c10edcdaa56bf2bcac2ea0002bb2b4780fce40cc28bcf30db713c736916f3382aa7ad0418f5ac424064d675c7001968378487d9cb40c619f SHA512 f3fd6644d7fa21ef042ecda807f6ede7853944de8908f8d390f0ebec258406ff4a4f3bfbb382b57a7a4684e19906b79b43c920f55c5fda75bacfc9a96fafa301
EBUILD qtwayland-5.12.3.ebuild 1137 BLAKE2B 91803151e658e54b23668c5ae4d387a2510d26ae42fb204cd6b5e3fc9649293ea90da44cb4243c0df686d42ba29f5b4875b9c2fc193e87a3e53f9bb1d5373996 SHA512 83d2ae87f67d4937bfbe1d24ac621afe0134c307479660e35aa4a4195b8879b6e891432c7e4a93e8822ea7b44c7a024c6cf38504526dba3ed9d4bcaa33b2ac48
+EBUILD qtwayland-5.12.4.ebuild 1142 BLAKE2B c8c396f29cddee68c7612898769452304f3887c2c8d6037a321156fcf145c9d179eb5fc15bcb0012454a2235cfded99f0fb00ede1b8436ce699c692924b280af SHA512 26335eab9d60c8612d79d4462f3512e9b98607b756be06130fbd9d6c0b3eddb46372bc50fe410f5354d205ca33b73a5b12b1a186f8d1b03960adf1a1a3f02c1e
MISC metadata.xml 593 BLAKE2B a6af5855403e860ee4a4900cef3019fea4552e8c9edc02ada1de5edc467ae9a8f9d86aff6bc656c4154ddb8018c8c8599b75f92d7b766c48e05e56e37999a009 SHA512 2603bc1d30993bf0d0b94784c7dca7c2cd2d15ff5fce4ca4bbdad4b2dc65a8ab7b7bb8cf207649ca4717ca6e4caaa8c75e079db81f0598511a1355c0f325a00d
diff --git a/dev-qt/qtwayland/qtwayland-5.12.4.ebuild b/dev-qt/qtwayland/qtwayland-5.12.4.ebuild
new file mode 100644
index 000000000000..ac4fdc112362
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.12.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput=]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ src/plugins/shellintegration/wl-shell/wl-shell.pro \
+ src/plugins/shellintegration/xdg-shell/xdg-shell.pro \
+ src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro \
+ src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}