summaryrefslogtreecommitdiff
path: root/dev-qt/qttools/qttools-6.9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
commit490ef2c2dc8b4e808f37add1adee21a754efd9a9 (patch)
treee235cdf15550b3d2f644b6fc4a8aa726971416f5 /dev-qt/qttools/qttools-6.9999.ebuild
parentda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (diff)
gentoo auto-resync : 21:04:2024 - 12:05:28
Diffstat (limited to 'dev-qt/qttools/qttools-6.9999.ebuild')
-rw-r--r--dev-qt/qttools/qttools-6.9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-qt/qttools/qttools-6.9999.ebuild b/dev-qt/qttools/qttools-6.9999.ebuild
index 6156f4c02a83..fd8e80ea6380 100644
--- a/dev-qt/qttools/qttools-6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.9999.ebuild
@@ -5,6 +5,12 @@ EAPI=8
LLVM_COMPAT=( {15..18} ) # see .cmake.conf for minimum
LLVM_OPTIONAL=1
+
+# behaves very badly when qttools is not already installed, also
+# other issues to handle (clang tests flaky depending on version,
+# and 3rdparty/ tries to FetchContent gtest)
+QT6_RESTRICT_TESTS=1
+
inherit desktop llvm-r1 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
@@ -29,11 +35,6 @@ REQUIRED_USE="
qdoc? ( clang qml )
"
-# behaves very badly when qttools is not already installed, also
-# other more minor issues (clang tests flaky depending on version,
-# and 3rdparty/ tries to FetchContent gtest)
-RESTRICT="test"
-
RDEPEND="
~dev-qt/qtbase-${PV}:6[network,widgets?]
assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )