summaryrefslogtreecommitdiff
path: root/dev-qt/qtstyleplugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-10-01 23:05:41 +0100
commit2e34d110f164bf74d55fced27fe0000201b3eec5 (patch)
treef00ae60197c58f84ad51f60b210738d9b70f555b /dev-qt/qtstyleplugins
parentf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (diff)
gentoo resync : 01.10.2020
Diffstat (limited to 'dev-qt/qtstyleplugins')
-rw-r--r--dev-qt/qtstyleplugins/Manifest4
-rw-r--r--dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch47
-rw-r--r--dev-qt/qtstyleplugins/metadata.xml11
-rw-r--r--dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311.ebuild46
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-qt/qtstyleplugins/Manifest b/dev-qt/qtstyleplugins/Manifest
new file mode 100644
index 000000000000..cd8d50d97864
--- /dev/null
+++ b/dev-qt/qtstyleplugins/Manifest
@@ -0,0 +1,4 @@
+AUX fix-build-qt5.15.patch 2651 BLAKE2B d4b058715e76f2721bd39c6499289b959daabc1ec765af1a87d0796eb934a49bfd589816dbfba6e374c5cd61a3d3b2526f25de21108fe6a0a7f352f57e899e5a SHA512 181bf85ad054ed5788f1bd4c32116729d57f83b8a4fdfcab3d3185ccd1e557b9492468c11c53a8a54c858967bf8298c3bd1a29bc100a8ffc6561ec543361f8b5
+DIST qtstyleplugins-5.0.0_p20170311.tar.gz 306394 BLAKE2B a59343602062ec1d0f215acf568322a5be874552b0c03dec75f268cec2123b1baa30bee524e36c9d522a8c935a58f204b5362feaf028df87ca10ea01dd29b3fb SHA512 e8c2d0e9c6b0a47cab04ffd2e9384606638905b63a7c1580f9b629bbcc84ebff19743363ffee3dbd31c3de1dcda684211ad3052932b5aa0081e529afd9cbb14d
+EBUILD qtstyleplugins-5.0.0_p20170311.ebuild 872 BLAKE2B 27908a1ea8fd57125848ef5d00ae64e2f7dfa3808bb11ac9b7978a558b0b0b374161f09a0b4226d2c19ca7a00584c3baef9e2904350e919452c3a937f3d03676 SHA512 2a65d2b594c62f7e5c65a7393da920ac942a1c281092b01310b0f6d0ff6454ebcbd4a4a426b86a732492001e0573e9a0d7b7f119193c617d45b410b63c3a1adb
+MISC metadata.xml 329 BLAKE2B 0b6512d88b304129461ebe5d0bd6c138528a7d0379a7407736b1d82de2266c265adcfee0ef077a6d2fdf0a5588d6758f2af4c31d6c5a4369b437dee302b14c8e SHA512 be6bd88cfb8875c8c07782b217f4701b2b325199d51e928ea9c4fa45a09dd7e69e04a1f314fc8c0301c5efa1a2ee8e2cda8d276108b5ff3c6de46ec5e3bb5ba0
diff --git a/dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch b/dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch
new file mode 100644
index 000000000000..caedd05baa83
--- /dev/null
+++ b/dev-qt/qtstyleplugins/files/fix-build-qt5.15.patch
@@ -0,0 +1,47 @@
+From: Fabian Vogt <fvogt@suse.de>
+Subject: Fix build against Qt 5.15
+
+With 0a93db4d82c051164923a10e4382b12de9049b45
+("Unify application palette handling between QGuiApplication and QApplication")
+QApplicationPrivate::setSystemPalette does no longer exist.
+
+This style does explictly not support "system colors" defined by the platform
+theme, which have priority over the style provided palette. To prevent the
+theme from overriding the colors, it previously used the system palette
+mechanism (which has priority over the theme), but that way does not work
+anymore. Instead, simply use QApplication::setPalette. While that has
+different behaviour and might break in some applications, it's better than
+having a completely messed up palette with certain themes.
+This is the same change as suggested by gamezelda on
+https://aur.archlinux.org/packages/qt5-styleplugins/#comment-749190.
+
+Index: qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle.cpp
+===================================================================
+--- qtstyleplugins-opensource-src-5.0.0+git20170311.orig/src/plugins/styles/gtk2/qgtkstyle.cpp
++++ qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle.cpp
+@@ -440,7 +440,11 @@ void QGtkStyle::polish(QApplication *app
+ // not supported as these should be entirely determined by
+ // current Gtk settings
+ if (app->desktopSettingsAware() && d->isThemeAvailable()) {
++#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
+ QApplicationPrivate::setSystemPalette(standardPalette());
++#else
++ QApplication::setPalette(standardPalette());
++#endif
+ QApplicationPrivate::setSystemFont(d->getThemeFont());
+ d->applyCustomPaletteHash();
+ if (!d->isKDE4Session())
+Index: qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle_p.cpp
+===================================================================
+--- qtstyleplugins-opensource-src-5.0.0+git20170311.orig/src/plugins/styles/gtk2/qgtkstyle_p.cpp
++++ qtstyleplugins-opensource-src-5.0.0+git20170311/src/plugins/styles/gtk2/qgtkstyle_p.cpp
+@@ -508,7 +508,9 @@ void QGtkStyleUpdateScheduler::updateThe
+ if (oldTheme != QGtkStylePrivate::getThemeName()) {
+ oldTheme = QGtkStylePrivate::getThemeName();
+ QPalette newPalette = qApp->style()->standardPalette();
++#if QT_VERSION < QT_VERSION_CHECK(5, 15, 0)
+ QApplicationPrivate::setSystemPalette(newPalette);
++#endif
+ QApplication::setPalette(newPalette);
+ if (!QGtkStylePrivate::instances.isEmpty()) {
+ QGtkStylePrivate::instances.last()->initGtkWidgets();
diff --git a/dev-qt/qtstyleplugins/metadata.xml b/dev-qt/qtstyleplugins/metadata.xml
new file mode 100644
index 000000000000..dc9c7c4c678b
--- /dev/null
+++ b/dev-qt/qtstyleplugins/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">qt/qtstyleplugins</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311.ebuild b/dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311.ebuild
new file mode 100644
index 000000000000..24e7e83cdc2f
--- /dev/null
+++ b/dev-qt/qtstyleplugins/qtstyleplugins-5.0.0_p20170311.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit qmake-utils
+
+COMMIT="335dbece103e2cbf6c7cf819ab6672c2956b17b3"
+DESCRIPTION="Additional style plugins for Qt5 (gtk2, cleanlook, plastic, motif)"
+HOMEPAGE="https://github.com/qt/qtstyleplugins"
+SRC_URI="https://github.com/qt/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-qt/qtcore:5=
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5=
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+
+RDEPEND="
+ ${DEPEND}
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/fix-build-qt5.15.patch
+)
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+}
+
+pkg_postinst() {
+ elog "To make Qt5 use the gtk2 style, set this in your environment:"
+ elog " QT_QPA_PLATFORMTHEME=gtk2"
+}