summaryrefslogtreecommitdiff
path: root/dev-qt/qtsql/qtsql-5.15.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-24 12:57:16 +0000
commit1f23f671d001ca7a0073e504f5ae0184eb5d024d (patch)
tree6747e05170df64a1585f36519a780db2d90f2a11 /dev-qt/qtsql/qtsql-5.15.7.ebuild
parent98bd6c82c526d2c4239d3d194fa1a1a818784552 (diff)
gentoo auto-resync : 24:01:2023 - 12:57:16
Diffstat (limited to 'dev-qt/qtsql/qtsql-5.15.7.ebuild')
-rw-r--r--dev-qt/qtsql/qtsql-5.15.7.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-qt/qtsql/qtsql-5.15.7.ebuild b/dev-qt/qtsql/qtsql-5.15.7.ebuild
deleted file mode 100644
index 398b6399049c..000000000000
--- a/dev-qt/qtsql/qtsql-5.15.7.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} != *9999* ]]; then
- QT5_KDEPATCHSET_REV=1
- KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
-fi
-
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="SQL abstraction library for the Qt5 framework"
-
-SLOT=5/${QT5_PV} # bug 639140
-IUSE="freetds mysql oci8 odbc postgres +sqlite"
-REQUIRED_USE="
- || ( freetds mysql oci8 odbc postgres sqlite )
-"
-
-DEPEND="
- =dev-qt/qtcore-${QT5_PV}*:5=
- freetds? ( dev-db/freetds )
- mysql? ( dev-db/mysql-connector-c:= )
- oci8? ( dev-db/oracle-instantclient:=[sdk] )
- odbc? ( dev-db/unixODBC )
- postgres? ( dev-db/postgresql:* )
- sqlite? ( dev-db/sqlite:3 )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/sql
- src/plugins/sqldrivers
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :sql
-)
-
-src_configure() {
- local myconf=(
- $(qt_use freetds sql-tds plugin)
- $(qt_use mysql sql-mysql plugin)
- $(qt_use oci8 sql-oci plugin)
- $(qt_use odbc sql-odbc plugin)
- $(qt_use postgres sql-psql plugin)
- $(qt_use sqlite sql-sqlite plugin)
- $(usev sqlite -system-sqlite)
- )
-
- use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
-
- qt5-build_src_configure
-}