summaryrefslogtreecommitdiff
path: root/dev-qt/qtscxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-13 22:45:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-13 22:45:20 +0100
commitab7810b87f5bb33b3ed5edd0dbda7f4bcd0cf70d (patch)
treef102e6ba13816f35c909cda970653f5422ee1b0d /dev-qt/qtscxml
parent6d478a9cbbd774e9d2743701d0931416e3ab9371 (diff)
gentoo auto-resync : 13:09:2023 - 22:45:20
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.6.9999.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index e820c70c1165..090bb15c91b8 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -3,5 +3,6 @@ DIST qtscxml-everywhere-src-6.5.2.tar.xz 1163208 BLAKE2B 9e149a82f8f00a7f0c78beb
EBUILD qtscxml-5.15.10.ebuild 398 BLAKE2B 27b0f98657fad702cb2b14ad1c69bc80b9c42e5680ed3ba2db0e79bb9884c0f7e4960c3c4bea26a6e5577476030b52c172f327cb6b6ecd9ec72ec6b5d306725d SHA512 62f3dd6a55d8f8dc8af4d1e0f7ded88f8efd3fe1ada7a7f585bdd488c3599f160a9efbc52a014cb5016e11a13856dfabbc236cb4257bae8bbb18137bc02e22ce
EBUILD qtscxml-6.5.2-r1.ebuild 677 BLAKE2B 5b4a53a211c467cc30ca0220a4e949e6b869e71ce8351839f77b0846d6d001bbe780b225f19d9c93ac8bdda1a3ff4993d9c8f70e65aead9464d524d47508a33a SHA512 0c8cf8f2e6019062ac0e153ced62bfa7026b00d0aa4d021fff939bd2791a7fc4d57db22c83fa145dccaa7b09ea9303868c73cdfda8e163126a9bf1da154fc87f
EBUILD qtscxml-6.5.9999.ebuild 677 BLAKE2B 5b4a53a211c467cc30ca0220a4e949e6b869e71ce8351839f77b0846d6d001bbe780b225f19d9c93ac8bdda1a3ff4993d9c8f70e65aead9464d524d47508a33a SHA512 0c8cf8f2e6019062ac0e153ced62bfa7026b00d0aa4d021fff939bd2791a7fc4d57db22c83fa145dccaa7b09ea9303868c73cdfda8e163126a9bf1da154fc87f
+EBUILD qtscxml-6.6.9999.ebuild 677 BLAKE2B 5b4a53a211c467cc30ca0220a4e949e6b869e71ce8351839f77b0846d6d001bbe780b225f19d9c93ac8bdda1a3ff4993d9c8f70e65aead9464d524d47508a33a SHA512 0c8cf8f2e6019062ac0e153ced62bfa7026b00d0aa4d021fff939bd2791a7fc4d57db22c83fa145dccaa7b09ea9303868c73cdfda8e163126a9bf1da154fc87f
EBUILD qtscxml-6.9999.ebuild 677 BLAKE2B 5b4a53a211c467cc30ca0220a4e949e6b869e71ce8351839f77b0846d6d001bbe780b225f19d9c93ac8bdda1a3ff4993d9c8f70e65aead9464d524d47508a33a SHA512 0c8cf8f2e6019062ac0e153ced62bfa7026b00d0aa4d021fff939bd2791a7fc4d57db22c83fa145dccaa7b09ea9303868c73cdfda8e163126a9bf1da154fc87f
MISC metadata.xml 612 BLAKE2B 74120f98e194bd3776134a96e12add6f8b485464004a9b0bad910cd81ca00bb29d740dfbe8484067eaec788ea6d228a4148f2d9d0757ced2cba1ba0cc4cce0bd SHA512 42b0ed27db93385ca6734f2bf81a9d01b97b6658326c61f821d517a26451b27919e4c429641f7e4a27bcf26407b5c1e134e90651948064308075abd77f4fb942
diff --git a/dev-qt/qtscxml/qtscxml-6.6.9999.ebuild b/dev-qt/qtscxml/qtscxml-6.6.9999.ebuild
new file mode 100644
index 000000000000..3baf824212bc
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.6.9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}