summaryrefslogtreecommitdiff
path: root/dev-qt/qtopengl/qtopengl-5.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-qt/qtopengl/qtopengl-5.15.2.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-qt/qtopengl/qtopengl-5.15.2.ebuild')
-rw-r--r--dev-qt/qtopengl/qtopengl-5.15.2.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-qt/qtopengl/qtopengl-5.15.2.ebuild b/dev-qt/qtopengl/qtopengl-5.15.2.ebuild
index c9a50e5247cd..bae6df383265 100644
--- a/dev-qt/qtopengl/qtopengl-5.15.2.ebuild
+++ b/dev-qt/qtopengl/qtopengl-5.15.2.ebuild
@@ -2,11 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
QT5_MODULE="qtbase"
VIRTUALX_REQUIRED="test"
inherit qt5-build
DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
@@ -26,6 +28,8 @@ QT5_TARGET_SUBDIRS=(
src/opengl
)
+PATCHES=( "${WORKDIR}/qtbase-${PV}-gcc11.patch" ) # bug 752012
+
src_configure() {
local myconf=(
-opengl $(usex gles2-only es2 desktop)