summaryrefslogtreecommitdiff
path: root/dev-qt/qtopengl/qtopengl-5.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-qt/qtopengl/qtopengl-5.15.2.ebuild
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-qt/qtopengl/qtopengl-5.15.2.ebuild')
-rw-r--r--dev-qt/qtopengl/qtopengl-5.15.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtopengl/qtopengl-5.15.2.ebuild b/dev-qt/qtopengl/qtopengl-5.15.2.ebuild
new file mode 100644
index 000000000000..3aaab692c82d
--- /dev/null
+++ b/dev-qt/qtopengl/qtopengl-5.15.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtbase"
+VIRTUALX_REQUIRED="test"
+inherit qt5-build
+
+DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+IUSE="gles2-only"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}:5=
+ ~dev-qt/qtgui-${PV}[gles2-only=]
+ ~dev-qt/qtwidgets-${PV}[gles2-only=]
+ !gles2-only? ( virtual/opengl )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/opengl
+)
+
+src_configure() {
+ local myconf=(
+ -opengl $(usex gles2-only es2 desktop)
+ )
+ qt5-build_src_configure
+}