summaryrefslogtreecommitdiff
path: root/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild')
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild b/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
deleted file mode 100644
index 9b2d0f37d3bc..000000000000
--- a/dev-qt/qtlocation/qtlocation-5.15.2-r10.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-KDE_ORG_COMMIT=861e372b6ad81570d4f496e42fb25a6699b72f2f
-inherit qt5-build
-
-DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- MAPBOXGL_COMMIT=d3101bbc22edd41c9036ea487d4a71eabd97823d
- SRC_URI+=" https://invent.kde.org/qt/qt/${PN}-mapboxgl/-/archive/${MAPBOXGL_COMMIT}/${PN}-mapboxgl-${MAPBOXGL_COMMIT}.tar.gz -> ${PN}-mapboxgl-${PV}-${MAPBOXGL_COMMIT:0:8}.tar.gz"
- KEYWORDS="amd64 arm arm64 ~riscv x86"
-fi
-
-IUSE=""
-
-RDEPEND="
- dev-libs/icu:=
- =dev-qt/qtcore-${QT5_PV}*
- =dev-qt/qtdeclarative-${QT5_PV}*
- =dev-qt/qtgui-${QT5_PV}*
- =dev-qt/qtnetwork-${QT5_PV}*
- =dev-qt/qtpositioning-${QT5_PV}*[qml]
- =dev-qt/qtsql-${QT5_PV}*
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- =dev-qt/qtconcurrent-${QT5_PV}*
-"
-
-QT5_TARGET_SUBDIRS=(
- src/3rdparty/clipper
- src/3rdparty/poly2tri
- src/3rdparty/clip2tri
- src/3rdparty/mapbox-gl-native
- src/location
- src/imports/location
- src/imports/locationlabs
- src/plugins/geoservices
-)
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
-src_prepare() {
- mv "${WORKDIR}"/${PN}-mapboxgl-${MAPBOXGL_COMMIT}/* src/3rdparty/mapbox-gl-native || die
- qt5-build_src_prepare
-}
-fi
-
-src_configure() {
- # src/plugins/geoservices requires files that are only generated when
- # qmake is run in the root directory. Bug 633776.
- mkdir -p "${QT5_BUILD_DIR}"/src/location || die
- qt5_qmake "${QT5_BUILD_DIR}"
- cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
- qt5-build_src_configure
-}