summaryrefslogtreecommitdiff
path: root/dev-qt/qtimageformats
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 17:32:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 17:32:06 +0100
commit7138219e3c9446bf981ff17f5609f42130bec414 (patch)
treeb898b17778ed104dd89b2980386bae53594b001d /dev-qt/qtimageformats
parent1afe1c223c048ca2c33fa230c83d620c04fecb8f (diff)
gentoo auto-resync : 24:09:2022 - 17:32:06
Diffstat (limited to 'dev-qt/qtimageformats')
-rw-r--r--dev-qt/qtimageformats/Manifest2
-rw-r--r--dev-qt/qtimageformats/qtimageformats-6.3.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/Manifest b/dev-qt/qtimageformats/Manifest
index 80dfcc47a5a8..eaf3a70bdc28 100644
--- a/dev-qt/qtimageformats/Manifest
+++ b/dev-qt/qtimageformats/Manifest
@@ -1,4 +1,6 @@
DIST qtimageformats-5.15.5-gentoo-kde-3.tar.xz 3268 BLAKE2B 21ada34678a2b999190ac9e642065d654e8bbc30ebe7789d20b97a49f3cae2d5e6893325b0019af695460fec8cb1f25e15b9573752396034a7db8ff6d7e49431 SHA512 fb2324d73db23da1ca13d1e050b9f045f1fd0b09cf722b94dc39eaea457629a643adacac16471841d4204cea7becfae11354674b70a4edf272dddc8863a10b22
DIST qtimageformats-everywhere-opensource-src-5.15.5.tar.xz 1829872 BLAKE2B 7b240291e6076537daa9bc3b87f13f3285f19a4638de5b5db44a2b55275fbe843dc974226e999cd90e6bf902b43fbcd25f052619f291fa36807830a26c10cd52 SHA512 50a68bbe83fac710f21f05f3c0637beff17de00f9309aab2ceb27cfe7a178a1a56b0906f357584eef3188d7b89504591c924a9d4988a7321fb18a72271bb2dfd
+DIST qtimageformats-everywhere-src-6.3.2.tar.xz 1859996 BLAKE2B e6254fc0e60b445aaa89f25a12c0060e807ba2c825a384a79a7deb56cb46415b82a973c520e866c53db19263ac23039aa36e8c7ffd46390d7a64b7e44b85e67e SHA512 5964c1f0e5fc4032495641268881f2288f90f361cb5a7e4953e05005ea907033ef634192ef26e1b0343e09c1a0306f83bef88ad4a5dba4665387001290dccc77
EBUILD qtimageformats-5.15.5-r2.ebuild 710 BLAKE2B 8803bd43faa76d2cd2fd1c43667bef5187a88436deaad8bba80f006e7033db38ed7e79f296cdc51705e09e712f0e285cdbc2a20ad1a78c8fae5c5db1f0f72f32 SHA512 877cd68f208a170506e324a0ce9482d9c78f94e01cd4d079a67acd4fea303ff45cfad6ce0df08f34723147133f1bd6591f10217d78993b4ce1445f52a6dbae60
+EBUILD qtimageformats-6.3.2.ebuild 631 BLAKE2B ae1993a0a35341ec1e9573fedb84f4a57887f3479fb62f63aa93b00087cfdd13c0d6e7c1c69ccfee664129d699b018f305da4dca54fb98529e8b80146a10828f SHA512 e316edc6f699ce26e11e5036b32c04b49dda78d744cec47ca700d4db49a50a4f9fb3c90145e08a1ccc6cddfbf608c51d5ffb8bf6d3942fb61b4259815e76ea7f
MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/qtimageformats/qtimageformats-6.3.2.ebuild b/dev-qt/qtimageformats/qtimageformats-6.3.2.ebuild
new file mode 100644
index 000000000000..f1a8354ec61c
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-6.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="mng"
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui]
+ media-libs/libwebp:=
+ media-libs/tiff
+ mng? ( media-libs/libmng:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_FEATURE_jasper=OFF
+ $(qt_feature mng)
+ -DQT_FEATURE_tiff=ON
+ -DQT_FEATURE_webp=ON
+ -DQT_FEATURE_system-tiff=ON
+ -DQT_FEATURE_system-webp=ON
+ )
+
+ qt6-build_src_configure
+}