summaryrefslogtreecommitdiff
path: root/dev-qt/qtconnectivity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 16:23:54 +0100
commit44a22ab89258383202cae3037c3a5685aa903251 (patch)
tree76789a8fb67642ae7635df789a9bb83125ec127d /dev-qt/qtconnectivity
parent9aa62a2a35904a08cbf2e884d3abd89d893daf91 (diff)
gentoo auto-resync : 05:09:2023 - 16:23:54
Diffstat (limited to 'dev-qt/qtconnectivity')
-rw-r--r--dev-qt/qtconnectivity/Manifest5
-rw-r--r--dev-qt/qtconnectivity/metadata.xml21
-rw-r--r--dev-qt/qtconnectivity/qtconnectivity-6.5.2.ebuild66
-rw-r--r--dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild66
-rw-r--r--dev-qt/qtconnectivity/qtconnectivity-6.9999.ebuild66
5 files changed, 224 insertions, 0 deletions
diff --git a/dev-qt/qtconnectivity/Manifest b/dev-qt/qtconnectivity/Manifest
new file mode 100644
index 000000000000..89c70f1a3a58
--- /dev/null
+++ b/dev-qt/qtconnectivity/Manifest
@@ -0,0 +1,5 @@
+DIST qtconnectivity-everywhere-src-6.5.2.tar.xz 985972 BLAKE2B e7f3d8ad3580336d7eaff50e8ac2af3b291462544ebc5ca3d049d045a8388668d5e54a075375aaa9c99b3232ec07063dc4b7288bdc9fee83843fe57909e5e35b SHA512 76d9569ecfbbb4355587779a9aa0abf20f7d08484a2634e6c3b49a71b057451c54fd5fd344b4c376206384e5f1e9264a6bbbcd85ee44f15637c116f411d4aa30
+EBUILD qtconnectivity-6.5.2.ebuild 1411 BLAKE2B 147fd7843a6566d3f80018c04130a9018736482f38f7269cedb3eb4bb2201cd204621e9f5cb456db6d1838374aca8a66033181ff04b23c5ebe056b37d2dc4347 SHA512 46220e5e4349a18d494923b6550ba088b63c69b962c62afdae9eb60cf97c2cd48aec73b3b0d29667581d00143332ab2ec51059474ac2f4a1a1fd71e160727199
+EBUILD qtconnectivity-6.5.9999.ebuild 1411 BLAKE2B 147fd7843a6566d3f80018c04130a9018736482f38f7269cedb3eb4bb2201cd204621e9f5cb456db6d1838374aca8a66033181ff04b23c5ebe056b37d2dc4347 SHA512 46220e5e4349a18d494923b6550ba088b63c69b962c62afdae9eb60cf97c2cd48aec73b3b0d29667581d00143332ab2ec51059474ac2f4a1a1fd71e160727199
+EBUILD qtconnectivity-6.9999.ebuild 1411 BLAKE2B 147fd7843a6566d3f80018c04130a9018736482f38f7269cedb3eb4bb2201cd204621e9f5cb456db6d1838374aca8a66033181ff04b23c5ebe056b37d2dc4347 SHA512 46220e5e4349a18d494923b6550ba088b63c69b962c62afdae9eb60cf97c2cd48aec73b3b0d29667581d00143332ab2ec51059474ac2f4a1a1fd71e160727199
+MISC metadata.xml 637 BLAKE2B 5e9bcc7a56c93b58d09022effcbef407532e6248bda88bd0eb6a2d1c0094b9715b867025e464870bf9c6ee644c020538d8210ae742fcb55be1b795f50bfadbce SHA512 f9a9ebe77ba29217437d2afa9b05a13d421683feef94f1c64d861d9a1e081ed2ab1716453ddd66a0b93c6fecccfd11642ab69f297efbfe23baf3ad8f232197d5
diff --git a/dev-qt/qtconnectivity/metadata.xml b/dev-qt/qtconnectivity/metadata.xml
new file mode 100644
index 000000000000..84c08090ba58
--- /dev/null
+++ b/dev-qt/qtconnectivity/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <use>
+ <flag name="nfc">Enable support for the Near Field Communication protocol</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>https://doc.qt.io/</doc>
+ <remote-id type="github">qt/qtconnectivity</remote-id>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Qt API.
+ </subslots>
+ </slots>
+</pkgmetadata>
diff --git a/dev-qt/qtconnectivity/qtconnectivity-6.5.2.ebuild b/dev-qt/qtconnectivity/qtconnectivity-6.5.2.ebuild
new file mode 100644
index 000000000000..ed231522887f
--- /dev/null
+++ b/dev-qt/qtconnectivity/qtconnectivity-6.5.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Bluetooth and NFC support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+bluetooth nfc smartcard"
+REQUIRED_USE="|| ( bluetooth nfc )"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ bluetooth? (
+ ~dev-qt/qtbase-${PV}:6[dbus]
+ net-wireless/bluez:=
+ )
+ nfc? (
+ smartcard? ( sys-apps/pcsc-lite )
+ )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # most hardware tests are skipped, but seems(?) this one detects and fails
+ tst_qlowenergycontroller
+)
+
+src_prepare() {
+ qt6-build_src_prepare
+
+ use bluetooth ||
+ sed -i '/add_subdirectory(bluetooth)/d' src/CMakeLists.txt || die
+ use nfc ||
+ sed -i '/add_subdirectory(nfc)/d' src/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usev nfc $(qt_feature smartcard pcsclite))
+ )
+
+ qt6-build_src_configure
+}
+
+src_install() {
+ qt6-build_src_install
+
+ # broken (unnecessary) symlink due to add_app() being used over add_tool()
+ use !bluetooth || rm -- "${ED}"/usr/bin/sdpscanner6 || die
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_BINDIR}"/bluetoothtestdevice
+ "${D}${QT6_BINDIR}"/bttestui
+ "${D}${QT6_BINDIR}"/qlecontroller-server
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -f -- "${delete[@]}" || die
+ fi
+}
diff --git a/dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild b/dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild
new file mode 100644
index 000000000000..ed231522887f
--- /dev/null
+++ b/dev-qt/qtconnectivity/qtconnectivity-6.5.9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Bluetooth and NFC support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+bluetooth nfc smartcard"
+REQUIRED_USE="|| ( bluetooth nfc )"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ bluetooth? (
+ ~dev-qt/qtbase-${PV}:6[dbus]
+ net-wireless/bluez:=
+ )
+ nfc? (
+ smartcard? ( sys-apps/pcsc-lite )
+ )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # most hardware tests are skipped, but seems(?) this one detects and fails
+ tst_qlowenergycontroller
+)
+
+src_prepare() {
+ qt6-build_src_prepare
+
+ use bluetooth ||
+ sed -i '/add_subdirectory(bluetooth)/d' src/CMakeLists.txt || die
+ use nfc ||
+ sed -i '/add_subdirectory(nfc)/d' src/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usev nfc $(qt_feature smartcard pcsclite))
+ )
+
+ qt6-build_src_configure
+}
+
+src_install() {
+ qt6-build_src_install
+
+ # broken (unnecessary) symlink due to add_app() being used over add_tool()
+ use !bluetooth || rm -- "${ED}"/usr/bin/sdpscanner6 || die
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_BINDIR}"/bluetoothtestdevice
+ "${D}${QT6_BINDIR}"/bttestui
+ "${D}${QT6_BINDIR}"/qlecontroller-server
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -f -- "${delete[@]}" || die
+ fi
+}
diff --git a/dev-qt/qtconnectivity/qtconnectivity-6.9999.ebuild b/dev-qt/qtconnectivity/qtconnectivity-6.9999.ebuild
new file mode 100644
index 000000000000..ed231522887f
--- /dev/null
+++ b/dev-qt/qtconnectivity/qtconnectivity-6.9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Bluetooth and NFC support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="+bluetooth nfc smartcard"
+REQUIRED_USE="|| ( bluetooth nfc )"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[network]
+ bluetooth? (
+ ~dev-qt/qtbase-${PV}:6[dbus]
+ net-wireless/bluez:=
+ )
+ nfc? (
+ smartcard? ( sys-apps/pcsc-lite )
+ )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # most hardware tests are skipped, but seems(?) this one detects and fails
+ tst_qlowenergycontroller
+)
+
+src_prepare() {
+ qt6-build_src_prepare
+
+ use bluetooth ||
+ sed -i '/add_subdirectory(bluetooth)/d' src/CMakeLists.txt || die
+ use nfc ||
+ sed -i '/add_subdirectory(nfc)/d' src/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(usev nfc $(qt_feature smartcard pcsclite))
+ )
+
+ qt6-build_src_configure
+}
+
+src_install() {
+ qt6-build_src_install
+
+ # broken (unnecessary) symlink due to add_app() being used over add_tool()
+ use !bluetooth || rm -- "${ED}"/usr/bin/sdpscanner6 || die
+
+ if use test; then
+ local delete=( # sigh
+ "${D}${QT6_BINDIR}"/bluetoothtestdevice
+ "${D}${QT6_BINDIR}"/bttestui
+ "${D}${QT6_BINDIR}"/qlecontroller-server
+ )
+ # using -f given not tracking which tests may be skipped or not
+ rm -f -- "${delete[@]}" || die
+ fi
+}