summaryrefslogtreecommitdiff
path: root/dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-26 00:09:36 +0100
commitb1c81de4fadbd00897700a7321f03b390d952b2e (patch)
treee6cc812351d4f105c110cfc363ebb497e996f47a /dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild
parent7c59acba5699c9c58090a7a738669669a7307023 (diff)
gentoo resync : 26.08.2021
Diffstat (limited to 'dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild')
-rw-r--r--dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild b/dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..f0ecb6cd1f63
--- /dev/null
+++ b/dev-qt/qtconcurrent/qtconcurrent-5.15.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Multi-threading concurrence support library for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}:5=
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/concurrent
+)
+
+PATCHES=(
+ "${WORKDIR}"/qtbase-${PV}-gcc11.patch # bug 752012
+ "${FILESDIR}"/${P}-gcc11.patch # bug #764977
+)