summaryrefslogtreecommitdiff
path: root/dev-qt/qtchooser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-qt/qtchooser
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-qt/qtchooser')
-rw-r--r--dev-qt/qtchooser/Manifest2
-rw-r--r--dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch33
-rw-r--r--dev-qt/qtchooser/qtchooser-66-r2.ebuild73
3 files changed, 108 insertions, 0 deletions
diff --git a/dev-qt/qtchooser/Manifest b/dev-qt/qtchooser/Manifest
index f5b83bb7949b..7174d207d6a0 100644
--- a/dev-qt/qtchooser/Manifest
+++ b/dev-qt/qtchooser/Manifest
@@ -1,3 +1,5 @@
+AUX qtchooser-66-qt-5.15.3-compat.patch 470 BLAKE2B cba1de76db2f6399e51ac6face26056b43e15d6089a828a24eb7705715f590ba2860c09fff493066062ec39ef54e990e80af2c45512eef24e56106d807085fbf SHA512 a833d589a706800d136dc9491b795906a7a34e4cd50b0faac017d4d622408420087e1a9a5cc1ef4dbe69ae9c73571de0abaa5958a527b40b62b3de931571c08e
DIST qtchooser-66.tar.xz 32008 BLAKE2B 1faf4a44406655621e65132289af6a8b0d23f0c1027a3b99017c3951705378bebcfbc3cb32aa59975a101f21294ff701ca6eb6ec18ce977b714a426be0fbcd6d SHA512 0c7d3588ddd7b21e6e9d799204924e06e0b0950c898dfd23088f1e7657b7f821a35579aa062658499809f9d9757e82c3c592591aa2e5ec453463929bf2b33bac
EBUILD qtchooser-66-r1.ebuild 1469 BLAKE2B ed5257a4134828f864229b04020171fa471bbfa6b4e9ac874b59027df4dbc2e6ad794a80a758cb2a7031d8a3754f1c867138dcf7959eb7ef271bf43920c004df SHA512 9bc54b406129e04df48a2bff185024c559622d1c793c4842c4ce8d64ec0af210ea18f1e6d6ac730bbeb5c1e8968823dfb0aa7ec69da1bafeb667a5e4e034c95f
+EBUILD qtchooser-66-r2.ebuild 1528 BLAKE2B 6172f11d2672d4469d935def53af0654fefdf3dbcd5e4397cb37ab52d69d9ff07cafab44f3e2b862906fe85387d8ed3dfce1a82b597089adcb8b88662d4bcd78 SHA512 a2c34437e9d7ac8929932c3b113ba334f46a062858601f0f1b46ccdb3d264f2997e5391fc84630e693e8fdbca63abcf09e4c700390d605f79165d744f0c246b9
MISC metadata.xml 248 BLAKE2B 51adf67bdc3e6c30f18cb7c177694882c71c1207bf4e6b88aa0eb8d5f6fdbaea0c364777967125219ba8ea4be4a9ad3eb41269a7139cb211ce26f2985ac103ac SHA512 c2976d1256f14d4dcf6ea53ed248a43e9b76530c19eefb0e586d64b1080b75d1f4ac17171c6c27a491ce6623d34e9318fcba5ce3f78039f21ccaabbebf209345
diff --git a/dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch b/dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch
new file mode 100644
index 000000000000..0a8569ff90b8
--- /dev/null
+++ b/dev-qt/qtchooser/files/qtchooser-66-qt-5.15.3-compat.patch
@@ -0,0 +1,33 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,18 +1,13 @@
+ MKDIR = mkdir -p
+ prefix = /usr
+ bindir = $(prefix)/bin
+-TOOLS = assistant \
+- designer \
++TOOLS = designer \
+ lconvert \
+- linguist \
+ lrelease \
+ lupdate \
+ moc \
+- pixeltool \
+ qcollectiongenerator \
+- qdbus \
+ qdbuscpp2xml \
+- qdbusviewer \
+ qdbusxml2cpp \
+ qdoc \
+ qdoc3 \
+@@ -44,9 +39,7 @@
+ rcc \
+ repc \
+ uic \
+- uic3 \
+- xmlpatterns \
+- xmlpatternsvalidator \
++ uic3
+
+ # keep the above line empty
+
diff --git a/dev-qt/qtchooser/qtchooser-66-r2.ebuild b/dev-qt/qtchooser/qtchooser-66-r2.ebuild
new file mode 100644
index 000000000000..9d7f138515f6
--- /dev/null
+++ b/dev-qt/qtchooser/qtchooser-66-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils toolchain-funcs
+
+DESCRIPTION="Tool to quickly switch between multiple Qt installations"
+HOMEPAGE="https://code.qt.io/cgit/qtsdk/qtchooser.git/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://code.qt.io/qtsdk/qtchooser.git"
+ inherit git-r3
+else
+ SRC_URI="https://download.qt.io/official_releases/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+LICENSE="|| ( LGPL-2.1 GPL-3 )"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ dev-qt/qtcore:5
+ dev-qt/qttest:5
+ )"
+RDEPEND="!<dev-qt/qtcore-5.15.3:5"
+
+PATCHES=( "${FILESDIR}/${PN}-66-qt-5.15.3-compat.patch" )
+
+qtchooser_make() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ LFLAGS="${LDFLAGS}" \
+ prefix="${EPREFIX}/usr" \
+ "$@"
+}
+
+src_compile() {
+ qtchooser_make
+}
+
+src_test() {
+ pushd tests/auto >/dev/null || die
+ eqmake5
+ popd >/dev/null || die
+
+ qtchooser_make check
+}
+
+src_install() {
+ qtchooser_make INSTALL_ROOT="${D}" install
+
+ # install configuration file
+ cat > "${T}/qt5-${CHOST}.conf" <<-_EOF_ || die
+ $(qt5_get_bindir)
+ $(qt5_get_libdir)
+ _EOF_
+
+ (
+ insinto /etc/xdg/qtchooser
+ doins "${T}/qt5-${CHOST}.conf"
+ )
+
+ # convenience symlinks
+ dosym qt5-"${CHOST}".conf /etc/xdg/qtchooser/5.conf
+ dosym qt5-"${CHOST}".conf /etc/xdg/qtchooser/qt5.conf
+ dosym qt5.conf /etc/xdg/qtchooser/default.conf
+
+ # TODO: bash and zsh completion
+ # newbashcomp scripts/${PN}.bash ${PN}
+}