summaryrefslogtreecommitdiff
path: root/dev-qt/qtbluetooth/qtbluetooth-5.12.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
commitd00821e77f72d4af4ea30158c1c6e18ffff0875b (patch)
treeb28b6cb077ae6b2457e30d49028fc978d8e2b59b /dev-qt/qtbluetooth/qtbluetooth-5.12.5.ebuild
parent36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (diff)
parent6a339b4f9ec107438bb71a6f9ca72fd42fbfd436 (diff)
Merge branch 'next'
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.12.5.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.12.5.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.12.5.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.12.5.ebuild
new file mode 100644
index 000000000000..6f8451cd6b64
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.12.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtconcurrent-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdbus-${PV}
+ >=net-wireless/bluez-5:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtnetwork-${PV}
+"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}