summaryrefslogtreecommitdiff
path: root/dev-qt/qtbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:50:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:50:40 +0100
commita2c1a301b2ea85c230b30ef69ff667f230a1bf88 (patch)
tree72b20e59998ee19c32c86634c05e02790faaf20f /dev-qt/qtbase
parent24d75f43d3d4caf76f2448bb277e89a3b3ae0d99 (diff)
gentoo auto-resync : 03:08:2022 - 13:50:40
Diffstat (limited to 'dev-qt/qtbase')
-rw-r--r--dev-qt/qtbase/Manifest3
-rw-r--r--dev-qt/qtbase/metadata.xml38
-rw-r--r--dev-qt/qtbase/qtbase-6.3.1.ebuild178
3 files changed, 0 insertions, 219 deletions
diff --git a/dev-qt/qtbase/Manifest b/dev-qt/qtbase/Manifest
deleted file mode 100644
index 83d49d745874..000000000000
--- a/dev-qt/qtbase/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST qtbase-everywhere-src-6.3.1.tar.xz 47118260 BLAKE2B b8b819330011033275d9532219bf09cce3ef1e7d8e50945b1cdeceddf3742c1ee4a1bba9d4340f1f6b48fd59659920c3652abf21bbd8b4bbed0c635a3caafb0c SHA512 5c4304dc1f5fa80201b61c9c8dbf4c3449506a243ea1f87e336dc3641a37b9d40c2aa4a93190cc69ddde0f349c74e327c35de5f46de888ddfd49616903e8a7b5
-EBUILD qtbase-6.3.1.ebuild 4834 BLAKE2B 074241a6f61567daa85cd211f56e4839f34b67734bf6b90d030326eb3a324f688914e14165c30c8eeb8e6495fcd464da1281be980df1062a441cf57fd19ad8d6 SHA512 56db8e0c0a94aa1e8d6ab38a7535930f042ff5d882ffd20080418f25447e1744bd53e5713cd571f4fd953782ba18afdb13f5b0417103519d4b655939763fd158
-MISC metadata.xml 1817 BLAKE2B 8f5b89970837847b5a81326445309f706316943d65ab909c0f0407e95dd5770d9d02a16ad1380a8b1eaee3d251bdc79fba4fee49be688f6db84c1c598de959e0 SHA512 1e650288d6f9e53560163e911ac9f80017e35eaed6b77031f66996e7f7bc3811735e5d9fccd6cddead4c5aaa88ccc032277bb4db45df227ca3a34a643d41c918
diff --git a/dev-qt/qtbase/metadata.xml b/dev-qt/qtbase/metadata.xml
deleted file mode 100644
index ba54edfe722e..000000000000
--- a/dev-qt/qtbase/metadata.xml
+++ /dev/null
@@ -1,38 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>qt@gentoo.org</email>
- <name>Gentoo Qt Project</name>
- </maintainer>
- <use>
- <flag name="brotli">Enable support for Brotli decompression</flag>
- <flag name="concurrent">Build Qt6Concurrent module</flag>
- <flag name="dbus">Build Qt6DBus module</flag>
- <flag name="egl">Enable EGL integration</flag>
- <flag name="eglfs">Build the EGL Full Screen/Single Surface platform plugin</flag>
- <flag name="evdev">Enable support for input devices via evdev</flag>
- <flag name="gssapi">Enable support for GSSAPI (<pkg>virtual/krb5</pkg>)</flag>
- <flag name="gtk">Build the GTK platform theme plugin</flag>
- <flag name="gui">Build Qt6Gui module</flag>
- <flag name="libinput">Enable support for input devices via <pkg>dev-libs/libinput</pkg></flag>
- <flag name="libproxy">Use <pkg>net-libs/libproxy</pkg> for automatic HTTP/SOCKS proxy configuration</flag>
- <flag name="network">Build Qt6Network module</flag>
- <flag name="sql">Build Qt6Sql module</flag>
- <flag name="systemd">Enable native journald logging support</flag>
- <flag name="tslib">Enable support for touchscreen devices via <pkg>x11-libs/tslib</pkg></flag>
- <flag name="tuio">Build plugin to receive touch events over the TUIO protocol</flag>
- <flag name="vulkan">Enable support for Vulkan</flag>
- <flag name="widgets">Build Qt6Widgets module</flag>
- <flag name="X">Build the XCB platform plugin and enable X11 integration</flag>
- </use>
- <upstream>
- <bugs-to>https://bugreports.qt.io/</bugs-to>
- <doc>https://doc.qt.io/</doc>
- </upstream>
- <slots>
- <subslots>
- Must only be used by packages that are known to use private parts of the Qt API.
- </subslots>
- </slots>
-</pkgmetadata>
diff --git a/dev-qt/qtbase/qtbase-6.3.1.ebuild b/dev-qt/qtbase/qtbase-6.3.1.ebuild
deleted file mode 100644
index 36931e0ea933..000000000000
--- a/dev-qt/qtbase/qtbase-6.3.1.ebuild
+++ /dev/null
@@ -1,178 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Cross-platform application development framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64"
-fi
-
-# Qt Modules
-# TODO: Restore/patch xml flag support (seems fixed in 6.9999).
-IUSE="+concurrent +dbus +gui +network +sql opengl +widgets zstd"
-REQUIRED_USE="
- opengl? ( gui )
- widgets? ( gui )
- X? ( || ( evdev libinput ) )
-"
-
-QTGUI_IUSE="accessibility egl eglfs evdev gles2-only +jpeg +libinput tslib tuio vulkan +X"
-QTNETWORK_IUSE="brotli gssapi libproxy sctp +ssl vnc"
-QTSQL_IUSE="freetds mysql oci8 odbc postgres +sqlite"
-IUSE+=" ${QTGUI_IUSE} ${QTNETWORK_IUSE} ${QTSQL_IUSE} cups gtk icu systemd +udev"
-# QtPrintSupport = QtGui + QtWidgets enabled.
-# ibus = xkbcommon + dbus, and xkbcommon needs either libinput or X
-REQUIRED_USE+="
- $(printf '%s? ( gui ) ' ${QTGUI_IUSE//+/})
- $(printf '%s? ( network ) ' ${QTNETWORK_IUSE//+/})
- $(printf '%s? ( sql ) ' ${QTSQL_IUSE//+/})
- accessibility? ( dbus X )
- cups? ( gui widgets )
- eglfs? ( egl )
- gtk? ( widgets )
- gui? ( || ( eglfs X ) || ( libinput X ) )
- libinput? ( udev )
- sql? ( || ( freetds mysql oci8 odbc postgres sqlite ) )
- vnc? ( gui )
- X? ( gles2-only? ( egl ) )
-"
-
-# TODO:
-# qtimageformats: mng not done yet, qtimageformats.git upstream commit 9443239c
-# qtnetwork: connman, networkmanager
-DEPEND="
- app-crypt/libb2
- dev-libs/double-conversion:=
- dev-libs/glib:2
- dev-libs/libpcre2:=[pcre16,unicode]
- dev-util/gtk-update-icon-cache
- media-libs/fontconfig
- >=media-libs/freetype-2.6.1:2
- >=media-libs/harfbuzz-1.6.0:=
- media-libs/tiff:0
- >=sys-apps/dbus-1.4.20
- sys-libs/zlib:=
- brotli? ( app-arch/brotli:= )
- evdev? ( sys-libs/mtdev )
- freetds? ( dev-db/freetds )
- gles2-only? ( media-libs/libglvnd )
- !gles2-only? ( media-libs/libglvnd[X] )
- gssapi? ( virtual/krb5 )
- gtk? (
- x11-libs/gtk+:3
- x11-libs/libX11
- x11-libs/pango
- )
- gui? ( media-libs/libpng:0= )
- icu? ( dev-libs/icu:= )
- !icu? ( virtual/libiconv )
- jpeg? ( media-libs/libjpeg-turbo:= )
- libinput? (
- dev-libs/libinput:=
- >=x11-libs/libxkbcommon-0.5.0
- )
- libproxy? ( net-libs/libproxy )
- mysql? ( dev-db/mysql-connector-c:= )
- oci8? ( dev-db/oracle-instantclient:=[sdk] )
- odbc? ( dev-db/unixODBC )
- postgres? ( dev-db/postgresql:* )
- sctp? ( kernel_linux? ( net-misc/lksctp-tools ) )
- sqlite? ( dev-db/sqlite:3 )
- ssl? ( dev-libs/openssl:= )
- systemd? ( sys-apps/systemd:= )
- tslib? ( >=x11-libs/tslib-1.21 )
- udev? ( virtual/libudev:= )
- vulkan? ( dev-util/vulkan-headers )
- X? (
- x11-libs/libdrm
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- >=x11-libs/libxcb-1.12:=[xkb]
- >=x11-libs/libxkbcommon-0.5.0[X]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
- zstd? ( app-arch/zstd:= )
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- -DINSTALL_BINDIR=${QT6_BINDIR}
- -DINSTALL_INCLUDEDIR=${QT6_HEADERDIR}
- -DINSTALL_LIBDIR=${QT6_LIBDIR}
- -DINSTALL_ARCHDATADIR=${QT6_ARCHDATADIR}
- -DINSTALL_PLUGINSDIR=${QT6_PLUGINDIR}
- -DINSTALL_LIBEXECDIR=${QT6_LIBEXECDIR}
- -DINSTALL_QMLDIR=${QT6_QMLDIR}
- -DINSTALL_DATADIR=${QT6_DATADIR}
- -DINSTALL_DOCDIR=${QT6_DOCDIR}
- -DINSTALL_TRANSLATIONSDIR=${QT6_TRANSLATIONDIR}
- -DINSTALL_SYSCONFDIR=${QT6_SYSCONFDIR}
- -DINSTALL_MKSPECSDIR=${QT6_ARCHDATADIR}/mkspecs
- -DINSTALL_EXAMPLESDIR=${QT6_EXAMPLESDIR}
- -DQT_FEATURE_androiddeployqt=OFF
- $(qt_feature concurrent)
- $(qt_feature dbus)
- $(qt_feature gui)
- $(qt_feature gui testlib)
- $(qt_feature icu)
- $(qt_feature network)
- $(qt_feature sql)
- $(qt_feature systemd journald)
- $(qt_feature udev libudev)
- $(qt_feature zstd)
- )
- use gui && mycmakeargs+=(
- $(qt_feature accessibility accessibility_atspi_bridge)
- $(qt_feature egl)
- $(qt_feature eglfs eglfs_egldevice)
- $(qt_feature eglfs eglfs_gbm)
- $(qt_feature evdev)
- $(qt_feature evdev mtdev)
- -DQT_FEATURE_gif=ON
- $(qt_feature jpeg)
- $(qt_feature opengl)
- $(qt_feature gles2-only opengles2)
- $(qt_feature libinput)
- $(qt_feature tslib)
- $(qt_feature tuio tuiotouch)
- $(qt_feature vulkan)
- $(qt_feature widgets)
- $(qt_feature X xcb)
- $(qt_feature X xcb_xlib)
- )
- use widgets && mycmakeargs+=(
- $(qt_feature cups)
- $(qt_feature gtk gtk3)
- )
- if use libinput || use X; then
- mycmakeargs+=( -DQT_FEATURE_xkbcommon=ON )
- fi
- use network && mycmakeargs+=(
- $(qt_feature brotli)
- $(qt_feature gssapi)
- $(qt_feature libproxy)
- $(qt_feature sctp)
- $(qt_feature ssl openssl)
- $(qt_feature vnc)
- )
- use sql && mycmakeargs+=(
- $(qt_feature freetds sql_tds)
- $(qt_feature mysql sql_mysql)
- $(qt_feature oci8 sql_oci)
- $(qt_feature odbc sql_odbc)
- $(qt_feature postgres sql_psql)
- $(qt_feature sqlite sql_sqlite)
- $(qt_feature sqlite system_sqlite)
- )
-
- qt6-build_src_configure
-}