summaryrefslogtreecommitdiff
path: root/dev-qt/qt5compat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-03 13:48:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-03 13:48:30 +0100
commit24d75f43d3d4caf76f2448bb277e89a3b3ae0d99 (patch)
tree4f290d635d831599222130ba8ddbf1a726129426 /dev-qt/qt5compat
parent8d8735134b6bb6e159162e531cccb456691a4ed4 (diff)
gentoo auto-resync : 03.08.2022 - 13:48:05
Diffstat (limited to 'dev-qt/qt5compat')
-rw-r--r--dev-qt/qt5compat/Manifest3
-rw-r--r--dev-qt/qt5compat/metadata.xml17
-rw-r--r--dev-qt/qt5compat/qt5compat-6.3.1.ebuild18
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-qt/qt5compat/Manifest b/dev-qt/qt5compat/Manifest
new file mode 100644
index 000000000000..2fdc26f5b543
--- /dev/null
+++ b/dev-qt/qt5compat/Manifest
@@ -0,0 +1,3 @@
+DIST qt5compat-everywhere-src-6.3.1.tar.xz 8195804 BLAKE2B 782da113f35ecd231ed408337fef8e6c688c5a1dc1b2533490d7bc751fa9d2404d45e16a47017d8ae6d7b8e7f077b33e94e82cfcd35bd4c81690422a36e29e73 SHA512 66196a8d29a2789179904638fcd9ec162d5715e7dc28618b3ef78d07682a05578b6c2e7023144c628b94321a9c1332d39826c13adb1e5db5121406c530c9c35c
+EBUILD qt5compat-6.3.1.ebuild 353 BLAKE2B 24febf04b6210fa2890b6791196f7f8494e4ffeedb5b643371608241703f3656c0d2d202eff1fec8f72a3cebf59a8a19a985d7fcc534387a4a3975df76e4d7ee SHA512 56a7bab643f26a3c08c887412f9386410aef306f9060638459e8d51d30b498c4680ff076582ee948f9c9bae79d1d220e0e7f33aa20000a289e688f6d0dd5c81b
+MISC metadata.xml 482 BLAKE2B 651a49dc4a07f5e5a9c21990868e666d98acdea7d7b0b2c0e4c98eafc3da72c803d380e4abda30f33250f7bbd7654df713833ccdddcb975cbad6f92e488f643b SHA512 192c670abd7da29645513bf1d9297d942efdc49f5cf170861e7689fda47f51daa47f10c7c81c3b045366e0259179c6839ff7747197c9d792e8d0fd1a5818973e
diff --git a/dev-qt/qt5compat/metadata.xml b/dev-qt/qt5compat/metadata.xml
new file mode 100644
index 000000000000..ae8aa9597f20
--- /dev/null
+++ b/dev-qt/qt5compat/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>https://doc.qt.io/</doc>
+ </upstream>
+ <slots>
+ <subslots>
+ Must only be used by packages that are known to use private parts of the Qt API.
+ </subslots>
+ </slots>
+</pkgmetadata>
diff --git a/dev-qt/qt5compat/qt5compat-6.3.1.ebuild b/dev-qt/qt5compat/qt5compat-6.3.1.ebuild
new file mode 100644
index 000000000000..2bf0684e946d
--- /dev/null
+++ b/dev-qt/qt5compat/qt5compat-6.3.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Qt module containing the unsupported Qt 5 APIs"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui,network]
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="${DEPEND}"