summaryrefslogtreecommitdiff
path: root/dev-qt/qt-creator/qt-creator-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-05 20:45:13 +0000
commit8fcdcec5fbdd0e3a77391e4f354218014f59f358 (patch)
treeb6aaf9c103052f2ab4a948377142f4a4233caa60 /dev-qt/qt-creator/qt-creator-9999.ebuild
parent423d21dcfee183cc4b04d29c1621615e8c30f834 (diff)
gentoo resync : 05.01.2018
Diffstat (limited to 'dev-qt/qt-creator/qt-creator-9999.ebuild')
-rw-r--r--dev-qt/qt-creator/qt-creator-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-qt/qt-creator/qt-creator-9999.ebuild b/dev-qt/qt-creator/qt-creator-9999.ebuild
index 322f20850b87..38641edea7de 100644
--- a/dev-qt/qt-creator/qt-creator-9999.ebuild
+++ b/dev-qt/qt-creator/qt-creator-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PLOCALES="cs de fr ja pl ru sl uk zh_CN zh_TW"
+PLOCALES="cs de fr ja pl ru sl uk zh-CN zh-TW"
-inherit l10n llvm qmake-utils toolchain-funcs virtualx xdg
+inherit llvm qmake-utils toolchain-funcs virtualx xdg
DESCRIPTION="Lightweight IDE for C++/QML development centering around Qt"
HOMEPAGE="https://doc.qt.io/qtcreator/"
@@ -81,7 +81,8 @@ RDEPEND="${CDEPEND}
"
# qt translations must also be installed or qt-creator translations won't be loaded
for x in ${PLOCALES}; do
- RDEPEND+=" linguas_${x}? ( >=dev-qt/qttranslations-${QT_PV} )"
+ IUSE+=" l10n_${x}"
+ RDEPEND+=" l10n_${x}? ( >=dev-qt/qttranslations-${QT_PV} )"
done
unset x
@@ -145,7 +146,11 @@ src_prepare() {
sed -i -e "/^CLANG_RESOURCE_DIR\s*=/ s:\$\${LLVM_LIBDIR}:${EPREFIX}/usr/lib:" src/shared/clang/clang_defines.pri || die
# fix translations
- sed -i -e "/^LANGUAGES\s*=/ s:=.*:= $(l10n_get_locales):" share/qtcreator/translations/translations.pro || die
+ local lang languages=
+ for lang in ${PLOCALES}; do
+ use l10n_${lang} && languages+=" ${lang/-/_}"
+ done
+ sed -i -e "/^LANGUAGES\s*=/ s:=.*:=${languages}:" share/qtcreator/translations/translations.pro || die
# remove bundled qbs
rm -rf src/shared/qbs || die