summaryrefslogtreecommitdiff
path: root/dev-qt/qdoc/qdoc-5.15.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-08 18:03:40 +0100
commit418459f7de9eb29d6db8b61681f39c467d9600e1 (patch)
tree87b23e3d06e1b08b13c64e16503aa7ea88b38a8a /dev-qt/qdoc/qdoc-5.15.11.ebuild
parent522fa4e6f267ba688a264ceec8d6c79663b61219 (diff)
gentoo auto-resync : 08:10:2023 - 18:03:40
Diffstat (limited to 'dev-qt/qdoc/qdoc-5.15.11.ebuild')
-rw-r--r--dev-qt/qdoc/qdoc-5.15.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qdoc/qdoc-5.15.11.ebuild b/dev-qt/qdoc/qdoc-5.15.11.ebuild
new file mode 100644
index 000000000000..c84b2d272c02
--- /dev/null
+++ b/dev-qt/qdoc/qdoc-5.15.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} != *9999* ]]; then
+ QT5_KDEPATCHSET_REV=1
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt documentation generator"
+
+IUSE="qml"
+
+DEPEND="
+ =dev-qt/qtcore-${QT5_PV}*:5=
+ sys-devel/clang:=
+ qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qdoc
+)
+
+src_prepare() {
+ qt_use_disable_mod qml qmldevtools-private \
+ src/qdoc/qdoc.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ # qt5_tools_configure() not enough here, needs another fix, bug 676948
+ qt5_configure_oos_quirk qtqdoc-config.pri src/qdoc
+ qt5-build_src_configure
+}