summaryrefslogtreecommitdiff
path: root/dev-qt/qdoc/qdoc-5.12.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-14 18:52:15 +0100
commitd00821e77f72d4af4ea30158c1c6e18ffff0875b (patch)
treeb28b6cb077ae6b2457e30d49028fc978d8e2b59b /dev-qt/qdoc/qdoc-5.12.5.ebuild
parent36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (diff)
parent6a339b4f9ec107438bb71a6f9ca72fd42fbfd436 (diff)
Merge branch 'next'
Diffstat (limited to 'dev-qt/qdoc/qdoc-5.12.5.ebuild')
-rw-r--r--dev-qt/qdoc/qdoc-5.12.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qdoc/qdoc-5.12.5.ebuild b/dev-qt/qdoc/qdoc-5.12.5.ebuild
new file mode 100644
index 000000000000..b7f1696614f9
--- /dev/null
+++ b/dev-qt/qdoc/qdoc-5.12.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt documentation generator"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ sys-devel/clang:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/qdoc
+)
+
+src_prepare() {
+ qt_use_disable_mod qml qmldevtools-private \
+ src/qdoc/qdoc.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ # src/qdoc requires files that are only generated when qmake is
+ # run in the root directory. bug 676948; same fix as bug 633776
+ mkdir -p "${QT5_BUILD_DIR}"/src/qdoc || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ qt5-build_src_configure
+}