summaryrefslogtreecommitdiff
path: root/dev-qt/linguist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-qt/linguist
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-qt/linguist')
-rw-r--r--dev-qt/linguist/Manifest2
-rw-r--r--dev-qt/linguist/linguist-5.15.2.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-qt/linguist/Manifest b/dev-qt/linguist/Manifest
index 8c85db7bf668..d1542d348e40 100644
--- a/dev-qt/linguist/Manifest
+++ b/dev-qt/linguist/Manifest
@@ -1,3 +1,5 @@
DIST qttools-everywhere-src-5.15.1.tar.xz 8901096 BLAKE2B f8927993dfc6888a1143b6a8ce09f075636600f77891edb64dd5c39bee75e2c752d3da4443c7956297c65c5b7f1103b1c6bb53b607cd054473a96adc1350e2b9 SHA512 8c7851431de8686a01fc5f85de5dcfa61b6878bd65b53ed78a8a23e57de70f2dcc1a72b4eed9a7219cfd443215a32a59a25fb929d343afcfd498517d6bcfb951
+DIST qttools-everywhere-src-5.15.2.tar.xz 8894728 BLAKE2B bbc57c58a43f827cfa04031f12d46d4d660456e4a5feabe17fdbb42126da06ed7031807fe963883d452fd1916330e94fcc66b9e9bb69ee4455a38bf3cbd80f5a SHA512 3bd32a302af6e81cd5d4eb07d60c5ef233f1ca7af1aae180c933ac28fafffce28c6c868eb032108747937ea951d6d4f0df5516841bc65d22c529207147533a8b
EBUILD linguist-5.15.1.ebuild 977 BLAKE2B 973508eefdaabe38b4a3ac066436e131fb3a05e612ceb7c9e3fcd0f19a00fb98dce1834c8bae6a674ff792553c9fe7b0b5f953398933c2a5470d6d42d51bc43f SHA512 a22f07d151d81202bd051c5d5ef78aacf36b290a1ebc7571833f5cfe9c4d61434bf857268c7667df7c91571fe8dbb6da71aeb0066aafd04eaac964c3f1e7a520
+EBUILD linguist-5.15.2.ebuild 982 BLAKE2B 9dc3277cb3a136cabe463d349297718a6843f1b015a7752d14820f6ef0453d79a4cf6116de0647b17cf87ef5759f6c8929689ebf5bbfd36d9b96a530573ccf6b SHA512 45a53d68c2dff391677fc212f51ed9c478ec2fd00b3bb22a0d51b836d9fb67c90407ed52afc29841605a3c95d75930f5e08542295a395d654721b9da3f1cafda
MISC metadata.xml 481 BLAKE2B 210b94f2e7cdb09b2e07ec4a931ea47d5aed734be52e9dcb132ae174fc0707ebd82feff52e44490c7133274c4dd31b0898f9fa54ce700b635b6a45c2cbf2b5c6 SHA512 bc22732d392630b21ba3895b22a3b1835fe639f930bad0ebab511757df89ebbb30530f0c482ff0a7eb24c7ba844f0b2448040dc5252ac98b0ac01423f236829f
diff --git a/dev-qt/linguist/linguist-5.15.2.ebuild b/dev-qt/linguist/linguist-5.15.2.ebuild
new file mode 100644
index 000000000000..c1d8b0d83fd3
--- /dev/null
+++ b/dev-qt/linguist/linguist-5.15.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+QT5_MODULE="qttools"
+inherit desktop qt5-build xdg-utils
+
+DESCRIPTION="Graphical tool for translating Qt applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/designer-${PV}
+ ~dev-qt/qtcore-${PV}:5=
+ ~dev-qt/qtgui-${PV}:5=
+ ~dev-qt/qtprintsupport-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ ~dev-qt/qtxml-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/linguist/linguist
+)
+
+src_install() {
+ qt5-build_src_install
+
+ local size
+ for size in 16 32 48 64 128; do
+ newicon -s ${size} src/linguist/linguist/images/icons/linguist-${size}-32.png linguist.png
+ done
+ make_desktop_entry "${QT5_BINDIR}"/linguist 'Qt 5 Linguist' linguist 'Qt;Development;Translation'
+}
+
+pkg_postinst() {
+ qt5-build_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ qt5-build_pkg_postrm
+ xdg_icon_cache_update
+}