summaryrefslogtreecommitdiff
path: root/dev-qt/assistant/assistant-5.12.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-qt/assistant/assistant-5.12.5.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'dev-qt/assistant/assistant-5.12.5.ebuild')
-rw-r--r--dev-qt/assistant/assistant-5.12.5.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-qt/assistant/assistant-5.12.5.ebuild b/dev-qt/assistant/assistant-5.12.5.ebuild
deleted file mode 100644
index ad1fb3981efb..000000000000
--- a/dev-qt/assistant/assistant-5.12.5.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-QT5_MODULE="qttools"
-inherit desktop qt5-build xdg-utils
-
-DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
-fi
-
-IUSE="webkit"
-
-DEPEND="
- ~dev-qt/qtcore-${PV}
- ~dev-qt/qtgui-${PV}
- ~dev-qt/qthelp-${PV}
- ~dev-qt/qtnetwork-${PV}
- ~dev-qt/qtprintsupport-${PV}
- ~dev-qt/qtsql-${PV}[sqlite]
- ~dev-qt/qtwidgets-${PV}
- webkit? ( >=dev-qt/qtwebkit-5.9.1:5 )
-"
-RDEPEND="${DEPEND}"
-
-QT5_TARGET_SUBDIRS=(
- src/assistant/assistant
-)
-
-src_prepare() {
- qt_use_disable_mod webkit webkitwidgets \
- src/assistant/assistant/assistant.pro
-
- qt5-build_src_prepare
-}
-
-src_install() {
- qt5-build_src_install
-
- doicon -s 32 src/assistant/assistant/images/assistant.png
- newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
- make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
-}
-
-pkg_postinst() {
- qt5-build_pkg_postinst
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- qt5-build_pkg_postrm
- xdg_icon_cache_update
-}