summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-23 20:00:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-23 20:00:08 +0000
commitedb8ee6f86e56d25f82a4f088a4504c903aede08 (patch)
tree3670c3d3d18146edbe5ef22d5623329c49fe1806 /dev-python
parent1ffbeeb1643e9197d8a58c65a1d76bbaf3656292 (diff)
gentoo auto-resync : 23:12:2022 - 20:00:08
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin260413 -> 260406 bytes
-rw-r--r--dev-python/iniconfig/Manifest3
-rw-r--r--dev-python/iniconfig/files/iniconfig-1.1.1-py.patch41
-rw-r--r--dev-python/iniconfig/iniconfig-1.1.1-r1.ebuild4
-rw-r--r--dev-python/smbus2/Manifest2
-rw-r--r--dev-python/smbus2/smbus2-0.4.2.ebuild11
-rw-r--r--dev-python/xcffib/Manifest2
-rw-r--r--dev-python/xcffib/xcffib-1.1.2.ebuild39
8 files changed, 97 insertions, 5 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index af1a296277a9..96de0f8c2ea2 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/iniconfig/Manifest b/dev-python/iniconfig/Manifest
index 0606887c215a..5194c87a642c 100644
--- a/dev-python/iniconfig/Manifest
+++ b/dev-python/iniconfig/Manifest
@@ -1,3 +1,4 @@
+AUX iniconfig-1.1.1-py.patch 1152 BLAKE2B 34950c2d5330d2cd40d1bf1cbd5d70d05cd3e84e0803d14c24a060a127ed87ebeeadf7a3d6308ae5b6842a38c3476212d28eff08125f87b34f33e5d03bbc12f1 SHA512 040c41d1017463db7276fcf16293b11f05477e5f36e49838d6d8a2ae0baa0755d533a938dada4910f6c9216c9906433f11760dc4e972cc9632e5d0b4838f493e
DIST iniconfig-1.1.1.tar.gz 8104 BLAKE2B 31301484887018a6aa75c944e2f8643f85b2433534ae46a8da893a113f2376eca14cbee88095a3784d1c52f26d4c748260c1df59c46b8f94cd342038f93242e8 SHA512 c9341db7e3ec2204b6a674fca7824cbeb492e3576d5ac3f084b234c82842b28f2f6acbfdb812e183f4334a95b990551f942a4caf548f5ce7ef14885f931535ee
-EBUILD iniconfig-1.1.1-r1.ebuild 716 BLAKE2B 1c2c1d6d996a20ae52a1c0270bb4acd0bec9b655df5264907f8b3ec42526d64bd9035f68ea915b556a8e66eff31be8d1d0e901a993d9276ba76720d3e4f26ae0 SHA512 b305659d7f64f1fa1e7432b7b55608895dc8f592f1aca4137bee71c12406fa6c84c3e6bd1f8793e41b27c86eb19b706f16d38ce4534e3d237c5c2f5d1079324b
+EBUILD iniconfig-1.1.1-r1.ebuild 758 BLAKE2B 8842e2ef45004fe1b2dd5e1d8e24c1c3b58cfafaa525f8df983216de919a7fb1487e8afc34ccd36e7f5563a082f4cf9b802abf6df98df0f6aa3b6866b1a1ccc9 SHA512 a3766b0700a872c36fafec4ba4eb05e5ea64249aeaa8c8671cfe0403dfc493e1f7986773dbd2943e14f187fa236c059df146721f48284c12c28208433e8a642a
MISC metadata.xml 375 BLAKE2B 07a0e2560e140c553289626437b1fbc46653a33cf9937775d60e6324361387d8399dfa3298ed8702a9532e55e4383e7493e7530be6586abbd2c5804372206627 SHA512 24e5acfeedf11f59184106a7b09169222761ffcd960ef398bce23acc3e63291b4c30230804a7da6b96a9799dadea5032d7fda7e7705577e1c6e9f8728ed601d2
diff --git a/dev-python/iniconfig/files/iniconfig-1.1.1-py.patch b/dev-python/iniconfig/files/iniconfig-1.1.1-py.patch
new file mode 100644
index 000000000000..c1722bd3a466
--- /dev/null
+++ b/dev-python/iniconfig/files/iniconfig-1.1.1-py.patch
@@ -0,0 +1,41 @@
+From 6b714f558b6cfb9f25c58b70eeb134f3bfa1bebd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Lum=C3=ADr=20=27Frenzy=27=20Balhar?=
+ <frenzy.madness@gmail.com>
+Date: Wed, 30 Nov 2022 22:47:56 +0100
+Subject: [PATCH] Drop dependency on py
+
+pytest 7.2 and tox 4 no longer depend on py and it's not needed here as well.
+---
+ testing/test_iniconfig.py | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/testing/test_iniconfig.py b/testing/test_iniconfig.py
+index fe12421..027949d 100644
+--- a/testing/test_iniconfig.py
++++ b/testing/test_iniconfig.py
+@@ -1,4 +1,3 @@
+-import py
+ import pytest
+ from iniconfig import IniConfig, ParseError, __all__ as ALL
+ from iniconfig import iscommentline
+@@ -100,7 +99,7 @@ def parse(input):
+
+
+ def parse_a_error(input):
+- return py.test.raises(ParseError, parse, input)
++ return pytest.raises(ParseError, parse, input)
+
+
+ def test_tokenize(input, expected):
+@@ -135,7 +134,7 @@ def test_section_cant_be_empty():
+ assert excinfo.value.lineno == 0
+
+
+-@py.test.mark.parametrize('line', [
++@pytest.mark.parametrize('line', [
+ '!!',
+ ])
+ def test_error_on_weird_lines(line):
+--
+2.39.0
+
diff --git a/dev-python/iniconfig/iniconfig-1.1.1-r1.ebuild b/dev-python/iniconfig/iniconfig-1.1.1-r1.ebuild
index eed3a00ab16f..22ff44d24447 100644
--- a/dev-python/iniconfig/iniconfig-1.1.1-r1.ebuild
+++ b/dev-python/iniconfig/iniconfig-1.1.1-r1.ebuild
@@ -24,3 +24,7 @@ BDEPEND="
"
distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py.patch
+)
diff --git a/dev-python/smbus2/Manifest b/dev-python/smbus2/Manifest
index 2a56728f7c38..5e483c696da1 100644
--- a/dev-python/smbus2/Manifest
+++ b/dev-python/smbus2/Manifest
@@ -1,3 +1,3 @@
DIST smbus2-0.4.2.gh.tar.gz 17268 BLAKE2B 4a4728a06b14beb96a22cbfee98b3b5ea6bfb9bc7bfc106fa0438f4515b0306ae5eb008c9f5e3df9303788d5345fd1a5fcdb53ae57532b1226332a4535577b17 SHA512 a80c3554a62a5621ef1d3dc24cbf0e9d924865c216d79f146ea62d1448239bbeee3ffb7e4dab0bc7149ea4add7fb714765db12dc760222a1ef2505c8a4ed4477
-EBUILD smbus2-0.4.2.ebuild 548 BLAKE2B 6889a19fe1aac6629e1387a1c59eefd6ff1516b94493ac9e08287a16f0a757018cf116e95efa4f44a8227438a770df7aed2f289eadf71c9db5cbf026de3c869a SHA512 ae32bd31c95d98e0690abebc51294c6f2beaf209dd5bede69061143d3558bc78c623218683ae4086167aa7961e5c54fa15b5ab0ff679c3c86d866405faedb8af
+EBUILD smbus2-0.4.2.ebuild 583 BLAKE2B 4419aec5d8b4526f1cd9e245e3443c3bc6beb98d239dfba839b436a9c9e27cbaf087b7e5a6cd93d53762ac8936d2c341956a4ab660d2bd21b80676b51dbb70da SHA512 febd7dba89eb80e50b6a4cce6e7e453b8dc9bf576e7fce5510fb81e757495ba0a167fa6264136151ec85e68b03fea7e9d8fe154d2e2ad99d36c21aabd43bde2d
MISC metadata.xml 400 BLAKE2B 70d0f577103959706dbe8b99dc7912bc118e4b9b59aaf32650c9273a17dc2407e7b4b913b897d918c50e601070caf9ad4b0e8de8e3009da4a5f0d4f137acde35 SHA512 37162850521651a9cbc9d4717e78254750db7e00de4ca2cf40f28014dde73e03681b897e6a8f50afacf58f017c8353190756f621750ceb248b7b41a10d6ddfbd
diff --git a/dev-python/smbus2/smbus2-0.4.2.ebuild b/dev-python/smbus2/smbus2-0.4.2.ebuild
index f3346d580591..3f2e5a631669 100644
--- a/dev-python/smbus2/smbus2-0.4.2.ebuild
+++ b/dev-python/smbus2/smbus2-0.4.2.ebuild
@@ -4,13 +4,14 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
+
inherit distutils-r1
DESCRIPTION="A drop-in replacement for smbus-cffi/smbus-python in pure Python"
HOMEPAGE="
https://pypi.org/project/smbus2/
- https://github.com/kplindegaard/smbus2
+ https://github.com/kplindegaard/smbus2/
"
SRC_URI="
https://github.com/kplindegaard/smbus2/archive/refs/tags/${PV}.tar.gz
@@ -21,4 +22,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64"
-distutils_enable_tests nose
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -s
+}
diff --git a/dev-python/xcffib/Manifest b/dev-python/xcffib/Manifest
index 890b82983f3a..736828c66063 100644
--- a/dev-python/xcffib/Manifest
+++ b/dev-python/xcffib/Manifest
@@ -1,3 +1,5 @@
DIST xcffib-0.12.1.tar.gz 85272 BLAKE2B 6db2f19caf13d406297198c3829456cb45b5195e2d068b1f5ad01c25d4ed75e3187854da24156c3c5396a559b11c2d6949711b793c5bf5c83e18e9aa54307983 SHA512 6530fb53fa18a3905d7c9e8dd5d05ea084de4a5f392e32953a9786998dd194b2db55b54fa44dbc3e6b68e68ae00431de7432d6884f777734409d660dae325d6e
+DIST xcffib-1.1.2.tar.gz 87303 BLAKE2B 0727c1c4c49692d8daff79d77487cfd2780a4279fa2bd49b45d87f48186e9ba0ee3ea46841dc259e7a3b5e301caacdee764762efe96217e138e6f8cedb2a986f SHA512 21606034bd0be2e1cf87b20904b006f7eb6eecbd835eff778f064ecb2bc16d17f48a6acce0eb1a30ca9bd98d810b4b1674bdadc9f6e42c5effee777f7bd138aa
EBUILD xcffib-0.12.1.ebuild 796 BLAKE2B 655efd0cf5089c50e8c5a824ac1f7fef49bd58bf9977e038a81db9500d4001000aafa9b91818058f9681ba27d4887d1d58b5fe5d2ba962da1243e90f9a3812e9 SHA512 9f58148cd863f42038e2f5ef6e2cbd5695282a24bc349302d49ce71e7cdb2239c6df8538c15804b6384d4a847af7f1411e32120021cde874715c26b11e31bb5b
+EBUILD xcffib-1.1.2.ebuild 803 BLAKE2B 2baa8d6484979ce47c435e37e8c5def1f6acbba8837f0f38547f1aa3d26ae98d587a4f09512c44accec4f23cf74567bb545bc42957eb9602d8f218194d84982a SHA512 9ada9191e9ca92c7bcd3b295dd6083970334759877102983bbb094add3efec28ca6605c705aaa1a674e4192b91a24f38d5a9613c94063be3e8f509218219da62
MISC metadata.xml 374 BLAKE2B 7f2845d0839dff2568de08f86ce6b8387e76ff450467e14b5c291ad1f55256cb9eff1ff318973e54846ad394b56a3e1e6aa8574fcc0bc39a1c9f7d3b42a1109d SHA512 9403d3d706b5281d6abe2d2fca33b1a70983c7c205f8a5899ad0469fe9a1cd0ceb6c9b27916e1e152467d029d86fc9e6dc28f967bc108499ed901582ad1bbd00
diff --git a/dev-python/xcffib/xcffib-1.1.2.ebuild b/dev-python/xcffib/xcffib-1.1.2.ebuild
new file mode 100644
index 000000000000..da3d445c8a1d
--- /dev/null
+++ b/dev-python/xcffib/xcffib-1.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A drop in replacement for xpyb, an XCB python binding"
+HOMEPAGE="
+ https://github.com/tych0/xcffib/
+ https://pypi.org/project/xcffib/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ x11-libs/libxcb
+"
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.1:=[${PYTHON_USEDEP}]
+ ' 'python*')
+ dev-python/six[${PYTHON_USEDEP}]
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ x11-base/xorg-server[xvfb]
+ x11-apps/xeyes
+ )
+"
+
+distutils_enable_tests pytest