summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-07 15:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-07 15:59:05 +0000
commita704e825f55e39189114ffabe2634acee9ec0164 (patch)
tree0bf3153af10db1801744de1e3702e6201a8a0acf /dev-python
parentd21e32f3fcb95019b77ca3f1a6d710ea7f9f1e04 (diff)
gentoo auto-resync : 07:02:2024 - 15:59:05
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin269336 -> 269328 bytes
-rw-r--r--dev-python/pytest-forked/Manifest2
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.6.0.ebuild6
-rw-r--r--dev-python/pytest-order/Manifest2
-rw-r--r--dev-python/pytest-order/pytest-order-1.2.0.ebuild3
-rw-r--r--dev-python/qtawesome/Manifest2
-rw-r--r--dev-python/qtawesome/qtawesome-1.3.0.ebuild5
-rw-r--r--dev-python/spyder/Manifest3
-rw-r--r--dev-python/spyder/spyder-5.5.1.ebuild192
9 files changed, 206 insertions, 9 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 21ef130e0e18..bce19bc8c140 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index 004b59958208..8ed0ab1d4e46 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1,3 +1,3 @@
DIST pytest-forked-1.6.0.tar.gz 9977 BLAKE2B cfef0ce10c9690894de14ed503ba74244c99c235838039f800b2c26430258e62c98fcc49d9e59b240b2ceee79e467bfbf0da5c96bc4a2d59770ceadd5021a5a9 SHA512 28fedc56fd696a4e7cf528034056849eff14094d5e7f0e94c7c477a7e91e42c08988769cf6f40d25fe8823399e552253cde2198121dd6a9e475fb6a8ce358cad
-EBUILD pytest-forked-1.6.0.ebuild 1147 BLAKE2B 43db2bf522b196e0e022bc458503b8ce9303a937d11175784f3f2fc2baab454de59ccc29eaacc276c14db9b0e6fce014fab0216d990d1901d9ef638f9e8388c2 SHA512 d3b1e5a3c872ed091a3a950ccecbba49d6c27969d063d01893c60de4e294eeae719bcfd38ec2e62ac63ba0fed8e63c8d7a084879e4023e40dc0b53698149c0d5
+EBUILD pytest-forked-1.6.0.ebuild 1178 BLAKE2B befc1b7bda56877dcc71749ff56795830f0793673b4a02d63798e257025dda5d748f532fa0635704ebf1a9d4f2a200ba8e9dbb2856bd19a3f2faf274a47ac848 SHA512 e2f1dcd94fa744f64e58f0f176655d0c6b642a7460b988bbb63961ac0f35f6274235b26685897c476baa53d3112826ed006a114b156dba17bbdf060c0750fef4
MISC metadata.xml 405 BLAKE2B 8cb6b3e3b440bc53f5d02a9638b00356f64bc02a8d7444ec5e295fcf91507f94c2460acd02008e6b11ca3bc2dd3d2f96ffb61c583fade0ff4ca00a182c01f903 SHA512 4a1dda1d8ada98b57881884ec6e982c308b54ab29e2cfa104f398876a1bd8ee2015dc7de4891c305f65030e30259079667d42c7a80d14d5148feeb5b7cf5904f
diff --git a/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
index 3c55c44a4c2e..fd67db61e6e9 100644
--- a/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
+++ b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{9..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
@@ -42,5 +42,5 @@ python_test() {
)
fi
- epytest -p no:flaky
+ epytest -p no:flaky -o tmp_path_retention_count=1
}
diff --git a/dev-python/pytest-order/Manifest b/dev-python/pytest-order/Manifest
index 399b30bf438d..6988493fe7b2 100644
--- a/dev-python/pytest-order/Manifest
+++ b/dev-python/pytest-order/Manifest
@@ -1,3 +1,3 @@
DIST pytest-order-1.2.0.tar.gz 44307 BLAKE2B 82611b713c9ae064c41e966d503c649c130d5a1df520594f513e9ab3d1cf6890fba65afa860822aedcee1a95617d3cd9010f5189d158cd76b2a4b9d25dd7d916 SHA512 f615dd57546e90c614af35fd79e7e579d48a5e709af3324f476d347e191606b81698bde619a2d0c7181e6f3b1a3c41121c1b06b5de87e66ac2caa77b5ea11ad9
-EBUILD pytest-order-1.2.0.ebuild 1116 BLAKE2B 6a9f5ddfceb58c3f548c21df1e0da2a80a8aa0bdf0f039a8adcbb325cca7c78fc4d209a9df6237a6db355c5f3ee25812394b780f249a935e88c028eb323b1e07 SHA512 82aeea4c3f60818a05b8d0bb8a2d9ef8eb81835af39a15709120a9885d45608b7cac1882b0cb19417407207c8e0d79ba4441570efa67c56c9d5982732522eb33
+EBUILD pytest-order-1.2.0.ebuild 1160 BLAKE2B db1722901d104da9fab84b9080781d7c6f5ab1012fe2133aff29da216c077c9341b127b0efbc5e59e77f86f0ebcc15dc74c923d366a7c69ef6dd3a0678f1acb8 SHA512 0ce6c3547ee05801fbe987fe1f0c968caa479b99577eeb2f929ea521aa1b4fca0accc016ae76912b3b56051c9e57441837a1944a2b8b2ce8fa3d2228e8742936
MISC metadata.xml 421 BLAKE2B 6b76a2376d1a001a247a842a493da9b341c9c355f0319072adaa55b20fa93397ed49f6ea6e965cd19bf3681e2a45bd9b34a9dadfc6bd59417fc88f3e04d19f4d SHA512 057e59a4e3e4d47f0b777531b6900a60516b2c26baf2a260b4fe34693c4568f77be45da02eb5b78dae27891845b0e6a7fcf4f9a0cdb59ee45e8ed54537795e8a
diff --git a/dev-python/pytest-order/pytest-order-1.2.0.ebuild b/dev-python/pytest-order/pytest-order-1.2.0.ebuild
index 00d4947e86bc..f861ccc1aacd 100644
--- a/dev-python/pytest-order/pytest-order-1.2.0.ebuild
+++ b/dev-python/pytest-order/pytest-order-1.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -26,6 +26,7 @@ RDEPEND="
BDEPEND="
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"
diff --git a/dev-python/qtawesome/Manifest b/dev-python/qtawesome/Manifest
index 377c752a756b..d8bf81c92e6c 100644
--- a/dev-python/qtawesome/Manifest
+++ b/dev-python/qtawesome/Manifest
@@ -1,3 +1,3 @@
DIST QtAwesome-1.3.0.tar.gz 2375398 BLAKE2B ed4f33b7f1fe7c54b4794247032a65638f4b1527ac460274486c673d767332c5aab64bc27924738914147e674e17c23e0e23e728fa32af8925fce7f58b417d17 SHA512 536918a63a22555b52abd66302f020f91df8ee75e8e806b258780944e143275245a73a4f215e2626eaf1d844552426fc1b45eff4e5de05a268b8b9179492cd7e
-EBUILD qtawesome-1.3.0.ebuild 1042 BLAKE2B 4e4adceb6f7acdb5557b8920f7712f2592834b6c7cef5dfe32831e00896e864afbcbc16015b31d7801fc61c28137a617cc411be5389869799c4d12b14bfa5478 SHA512 3467a6e96a393af0c7c5725b2187ca0ec5f7121ac6d80879a76a10dfba8d1b4bd595c47d29d50b2e33706857a19df854d007b54ba4756361e78601914a752739
+EBUILD qtawesome-1.3.0.ebuild 1073 BLAKE2B dfed5f3b53f33fe16d29f84f05ad12804d705c2df03bce5c9673d29588e75155f911f0914b3f90c9f0c40f04b15a410f8917dafee5f6a855eb61f1315250746a SHA512 c679d5ad481c3aad78f556d947270aed21404e116d29d1d29ccf073e7365ab316bc6f3778cd683e3299fd76e3b8e1a3ffb4e4e374bc0b6e804d3329ff48cc689
MISC metadata.xml 810 BLAKE2B 7d9237109b80816eea90f955a2a7f4f989589b4b16aef6151017a68dc4808b5b13e524d0356f88ff57f05c40be268729f016ae3f9bd059eda6d06ba75ee03ef5 SHA512 9b15bd5c9e0486fc64d49c6a7a1ef2fafc4c7e9e25ac57ca5811e435cc49c24421ca695c7dbaaee7b317c4a90fd5e9f929c3f79d7e57ce8cac85c6267e103dab
diff --git a/dev-python/qtawesome/qtawesome-1.3.0.ebuild b/dev-python/qtawesome/qtawesome-1.3.0.ebuild
index d35e13bf887f..f2c0e6668930 100644
--- a/dev-python/qtawesome/qtawesome-1.3.0.ebuild
+++ b/dev-python/qtawesome/qtawesome-1.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,7 +38,8 @@ BDEPEND="
"
distutils_enable_tests pytest
-distutils_enable_sphinx docs/source
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme
src_test() {
virtx distutils-r1_src_test
diff --git a/dev-python/spyder/Manifest b/dev-python/spyder/Manifest
index a553243bb941..8ed0b8869936 100644
--- a/dev-python/spyder/Manifest
+++ b/dev-python/spyder/Manifest
@@ -1,8 +1,11 @@
AUX spyder-5.0.0-build.patch 1147 BLAKE2B 68e62f6bd7a021d82f1da8d86c16e2289faac7f760f9bb5dc975053c7f8bb409c79b90eeaf06c5121ca5833442b61929cc640e4f25e6cc27f6118f0fa8f27b5e SHA512 e88cbbeca42ac2720f4e0888df9432d912d3907af267d3fe6a5e658d18d1242c998a70dee88fa0efe9edfcf87a46a40cf75685037d75fce1d596b708acc32096
AUX spyder-5.2.0-doc-theme-renamed.patch 356 BLAKE2B 666ba289498026ab0679776b8af8f6efe7561a9a736ff19b32eaefcac87d142a55a055556c09f94373869711e81a35ef90832fbfe68acc6cee0f2023742de0be SHA512 396944e6f242bf3b6a27ac9d47f0cc07fd99a55c50f174dbee2fccd1f0b3edf355347bf6291943c3003f55996304d96ce2d2fe45ae7c4291e8425bff73a3a861
DIST spyder-5.5.0.gh.tar.gz 16251845 BLAKE2B 8a8ea4a7da30d79b91e9a20a904e88a21517d99d51b29535ba250c3d0a970a5e00eb8f43a3e9b00eeef457823baf553d0694c3ef57ca798fe002d1d0fdf2f4d7 SHA512 6be7b80a99996beae2542a0646b54a665a89d09929634b21ddcb67f61584fa7f53e9f921fc8d2a4edf6c8ee5e98db0d8423a52a8b93b8ed58b9f46d062ecfeac
+DIST spyder-5.5.1.gh.tar.gz 16254673 BLAKE2B 15c10994abb851048fd5386ef2ae776cc2a9ace6ca4efd4418c393ba2dd98d23ed842447e95cfce26ccac802ddfa8669839024cf6d9fdcd0ce63fead0d1e8246 SHA512 bb55cd29e0e5712152b44e3e11aa83c13396c9ff965239e86a07cc2ab20bdcc0aa23b202eb07839baa911e515917b7e3bf1ddc970ce446bff84655145751ee94
DIST spyder-6.0.0_alpha3.gh.tar.gz 15480385 BLAKE2B 5e41a7765ce7e4d0ac0148f07601b098a60e200c90d89aeda89272c9f29521abcca1fb152dec09bbf23261cfef302c5c504ba6733fa0a690163d3081a7c19216 SHA512 c8ed1caaf9ef2d8cbae351825463d6a7a549efd2b072a0bbb24ae85745132cae4fadfd92d8219dc031ba1b775dc413a596e0c5725604aee40757cac1096825e9
DIST spyder-docs-0aa81d44ec6490c155be1bb1acca0a27328b12e0.gh.tar.gz 94895731 BLAKE2B 468412372bf2f70f838fa89dc1b88997fa2d9d92e36d6a5abac736b6b5f2782f25121b18b876c7c6e2af9d7eda433aaccd017c2e8c8c06a223420f0ce9684fc1 SHA512 9ac0f930a1a864e81e4181f101449a6506728d0d89254409a58e68bc17a3de39f4d1bf329f11da433d8ee4f3122faf3b337654d011263a70b253459e9562e923
+DIST spyder-docs-678f4e94542e25c8c0bfc1cb6abca94126f24fa6.gh.tar.gz 94896707 BLAKE2B 6912279a38da0be7bb368daa740bb801d8d2f7a31062178b8416d42644fdb3c0ec6a019ec7657e6e1e8e4273d29cdc7b7e36d85293b4f860edb2059fe27dc028 SHA512 3b8201256fa555b3b85bdfcfcfa17f08a42b438f141f9870ba5c807def63ed1b4304791209bc063833537036a2ff68897a40d610de9b662897cca7601ec09a44
EBUILD spyder-5.5.0.ebuild 7323 BLAKE2B 6e063c2abf102c359f841672f95327831a3cfd0a4faec7465a64bbdcca524d806071b04ff2a40a4c2ee915475b9ad9cefa8cbda77fd5d0cb4af88bbb507931f9 SHA512 a8bf87f02365e4035395b7534fb961ca3ffece08679612707e7463ec605884b69c70459a9e3d5931e80e5f2cced6f653fe6bb85e88fb97a23c1a92b3c53f7df1
+EBUILD spyder-5.5.1.ebuild 7323 BLAKE2B 26c35e2a66ce0a4cc50efff7187c33738a808542403f70cb421231053da12265349af65914d8fd2bc87b7cef7aa23a7a6b491d7744bd978139a93886d71f54ab SHA512 40fc017d91b71b92d8ca44985c6da5531c1aeeb0d84e054b11a424a9f998321cb8122202e1543c6adcded9e6a540eb3913973783137b48a903f698d13c7e6c5a
EBUILD spyder-6.0.0_alpha3.ebuild 7274 BLAKE2B e9491e9d426f608cd710fa16883f9cf1697ca77445dcbc92068cca28fdb862b2bb60d4be7b0720f93f339c31786beeea6ee3424429bbca2516d735d454cec869 SHA512 6bac6b3430492eca0300d236c8235780b489aff06bebe1d81083f1077977297d03d6cb90dcc9798d4aa86bc892af0feb5a73ee144e292928334c9b7338129230
MISC metadata.xml 1251 BLAKE2B 81f007eda89ddc66841771a949f76da6f015b49bfbf27b47a7557ab70f1241087f06a5c6675ea8da6aa871937cd705aea888989b468ac11d33420cbe34a27f27 SHA512 24977ed6053ad254748ba4c368bed7f8428d1e5928b586f57e48c01733934894fb1f94df077a71fcd7a00e891e24b776b9e57279f90c2f94728f709a94a90121
diff --git a/dev-python/spyder/spyder-5.5.1.ebuild b/dev-python/spyder/spyder-5.5.1.ebuild
new file mode 100644
index 000000000000..366d83fe95cd
--- /dev/null
+++ b/dev-python/spyder/spyder-5.5.1.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature virtualx xdg
+
+# Commit of documentation to fetch
+DOCS_PV="678f4e94542e25c8c0bfc1cb6abca94126f24fa6"
+
+DESCRIPTION="The Scientific Python Development Environment"
+HOMEPAGE="
+ https://www.spyder-ide.org/
+ https://github.com/spyder-ide/spyder/
+ https://pypi.org/project/spyder/
+"
+SRC_URI="
+ https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ https://github.com/spyder-ide/${PN}-docs/archive/${DOCS_PV}.tar.gz -> ${PN}-docs-${DOCS_PV}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/atomicwrites-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.0.0[${PYTHON_USEDEP}]
+ >=dev-util/cookiecutter-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/diff-match-patch-20181111[${PYTHON_USEDEP}]
+ >=dev-python/intervaltree-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/jellyfish-0.7[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/keyring-17.0.0[${PYTHON_USEDEP}]
+ >=dev-python/nbconvert-4.0[${PYTHON_USEDEP}]
+ >=dev-python/numpydoc-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pexpect-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pickleshare-0.4[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.3[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-venv-3.0.2[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-black-2.0.0[${PYTHON_USEDEP}]
+ <dev-python/python-lsp-black-3[${PYTHON_USEDEP}]
+ >=dev-python/pyls-spyder-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-22.1.0[${PYTHON_USEDEP}]
+ >=dev-python/qdarkstyle-3.2[${PYTHON_USEDEP}]
+ <dev-python/qdarkstyle-3.3[${PYTHON_USEDEP}]
+ >=dev-python/qstylizer-0.2.2[${PYTHON_USEDEP}]
+ >=dev-python/qtawesome-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/qtconsole-5.5.1[${PYTHON_USEDEP}]
+ <dev-python/qtconsole-5.6.0[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.1.0[${PYTHON_USEDEP},svg,webengine]
+ >=sci-libs/rtree-0.9.7[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-0.6.6[${PYTHON_USEDEP}]
+ >=dev-python/spyder-kernels-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-kernels-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/textdistance-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/three-merge-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/watchdog-0.10.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/matplotlib[tk,${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-order[${PYTHON_USEDEP}]
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP},pyside2,pyqt5]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ )"
+
+# Based on the courtesy of Arfrever
+# This patch removes a call to update-desktop-database during build
+# This fails because access is denied to this command during build
+PATCHES=(
+ "${FILESDIR}/${PN}-5.0.0-build.patch"
+ "${FILESDIR}/${PN}-5.2.0-doc-theme-renamed.patch"
+)
+
+DOCS=(
+ "AUTHORS.txt"
+ "Announcements.md"
+ "CHANGELOG.md"
+ "CODE_OF_CONDUCT.md"
+ "CONTRIBUTING.md"
+ "NOTICE.txt"
+ "README.md"
+ "RELEASE.md"
+)
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/doc \
+ dev-python/sphinx-panels \
+ dev-python/pydata-sphinx-theme \
+ dev-python/sphinx-multiversion
+
+python_prepare_all() {
+ # move docs into workdir
+ mv ../spyder-docs-${DOCS_PV}* docs || die
+
+ # these dependencies are packaged separately:
+ # dev-python/spyder-kernels,
+ # dev-python/python-lsp-server,
+ # dev-python/qdarkstyle
+ rm -r external-deps/* || die
+ # runs against things packaged in external-deps dir
+ rm conftest.py || die
+
+ # Do not depend on pyqt5<5.16, this dependency is carried by QtPy[pyqt5]
+ # Do not depend on pyqtwebengine<5.16, this dependency is carried by QtPy[webengine]
+ # Do not depend on parso and jedi, this is dependency is carried in python-lsp-server
+ # Do not depend on python-lsp-server, this dependency is carried in pyls-spyder
+ # Do not depend on ipython, this dependency is carried in spyder-kernels
+ # The explicit version requirements only make things more complicated, if e.g.
+ # pyls-spyder gains compatibility with a newer version of python-lsp-server
+ # in a new release it will take time for this information to propagate into
+ # the next spyder release. So just remove the dependency and let the other
+ # ebuilds handle the version requirements to speed things up and prevent
+ # issues such as Bug 803269.
+ sed -i \
+ -e "/'pyqt5[ 0-9<=>.,]*',/d" \
+ -e "/'pyqtwebengine[ 0-9<=>.,]*',/d" \
+ -e "/'python-lsp-server\[all\][ 0-9<=>.,]*',/d" \
+ -e "/'parso[ 0-9<=>.,]*',/d" \
+ -e "/'jedi[ 0-9<=>.,]*',/d" \
+ -e "/'pylint[ 0-9<=>.,]*',/d" \
+ setup.py || die
+ # -e "/'ipython[ 0-9<=>.,]*',/d" \
+
+ sed -i \
+ -e "/^PYLS_REQVER/c\PYLS_REQVER = '>=0.0.1'" \
+ -e "/^PYLSP_REQVER/c\PYLSP_REQVER = '>=0.0.1'" \
+ -e "/^PARSO_REQVER/c\PARSO_REQVER = '>=0.0.1'" \
+ -e "/^JEDI_REQVER/c\JEDI_REQVER = '>=0.0.1'" \
+ -e "/^PYLINT_REQVER/c\PYLINT_REQVER = '>=0.0.1'" \
+ spyder/dependencies.py || die
+ # -e "/^IPYTHON_REQVER/c\IPYTHON_REQVER = '>=0.0.1'" \
+
+ # do not check deps, fails because we removed dependencies above
+ sed -i -e 's:test_dependencies_for_spyder_setup_install_requires_in_sync:_&:' \
+ spyder/tests/test_dependencies_in_sync.py || die
+
+ # can't check for update, need network
+ rm spyder/workers/tests/test_update.py || die
+
+ # skip online test
+ rm spyder/widgets/github/tests/test_github_backend.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+# Calling pytest directly somehow passes the pytest arguments to spyder
+# causing an invalid argument error
+python_test() {
+ virtx "${EPYTHON}" runtests.py
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "2D/3D plotting in the Python and IPython consoles" dev-python/matplotlib
+ optfeature "View and edit DataFrames and Series in the Variable Explorer" dev-python/pandas
+ optfeature "View and edit two or three dimensional arrays in the Variable Explorer" dev-python/numpy
+ optfeature "Symbolic mathematics in the IPython console" dev-python/sympy
+ optfeature "Import Matlab workspace files in the Variable Explorer" dev-python/scipy
+ optfeature "Run Cython files in the IPython console" dev-python/cython
+ optfeature "The hdf5/h5py plugin" dev-python/h5py
+ optfeature "The line profiler plugin" dev-python/spyder-line-profiler
+ optfeature "Vim key bindings" dev-python/spyder-vim
+ optfeature "Unittest support" dev-python/spyder-unittest
+ optfeature "System terminal inside spyder" dev-python/spyder-terminal
+ optfeature "Jupyter notebook support" dev-python/spyder-notebook
+ # spyder-memory-profiler is not compatible with spyder-5.2+ yet
+ # optfeature "The memory profiler plugin" dev-python/spyder-memory-profiler
+ # spyder-reports not yet updated to >=spyder-4.0.0
+ # optfeature "Markdown reports using Pweave" dev-python/spyder-reports
+ # Plugins with no release yet:
+ # optfeature "Manage virtual environments and packages" dev-python/spyder-env-manager
+ # optfeature "VCS (e.g. git) integration" dev-python/spyder-vcs
+}