summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 23:01:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 23:01:48 +0100
commit5017c48e54de7e3dcebd1db96598cf0a07b21f16 (patch)
tree5daf82c5678eb5c4cafc2f49503dfed11968e671 /dev-python
parent7b830374520118e805fdd214530a389653750f51 (diff)
gentoo auto-resync : 16:09:2023 - 23:01:48
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin267957 -> 267957 bytes
-rw-r--r--dev-python/cchardet/Manifest4
-rw-r--r--dev-python/cchardet/cchardet-2.1.19.ebuild28
-rw-r--r--dev-python/cchardet/metadata.xml8
-rw-r--r--dev-python/moto/Manifest2
-rw-r--r--dev-python/moto/moto-4.2.3.ebuild103
6 files changed, 142 insertions, 3 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index ca8fda81358e..a9d35949497a 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/cchardet/Manifest b/dev-python/cchardet/Manifest
index edb0027b1b6a..e15436a60505 100644
--- a/dev-python/cchardet/Manifest
+++ b/dev-python/cchardet/Manifest
@@ -1,4 +1,6 @@
AUX cchardet-2.1.7-pytest.patch 3529 BLAKE2B 2ce0bb1a7ee281477f471dad08b1e7819b9d47b96db2c4321b67185dd860de5f4e94150846e76ab8364bee079f823884af366256c8ad98ef0797987d2cab9a0c SHA512 0e7d126a49c3c1d2c810085aa1dd6fa1b1b38807876d168d3d459ea837bb8e146e0585c93a10599713a5511a76c328696ee0889d4c9a63ef8aee4d97b5df686a
DIST cchardet-2.1.7.tar.gz 653617 BLAKE2B 0ca9becac01c67da191290c7de0dc52d5c8e6c2715f660811c8e67d9a06e74ac155a081de81af96ade74ccc4065093fc226f232a26f66236fafe9fc1b48a9c9e SHA512 43e663e30ec079b2a954862de5e8136a2e40f69e300d65eb4ce9d7ffa5d8c496dc7c0937b3306b4096cfad12a1d0617628f8f0115534ab6faf9eb39d2b3935a2
+DIST faust-cchardet-2.1.19.tar.gz 678871 BLAKE2B e87389ef602bc5e69ae2037aff1000b9caacfd91a44c5eb8fb2084d4ac33772eb8e480b05109ff83ebfcb2b9a57e215b4bc9cc5558f4f7e1a19b58dd1dfca8b5 SHA512 bd75ddf8b2e9891fe6ecdfd687a6903342a24b93f35a3d9a1b20da9abc77684e73840db73da97689636e3412e33da25b68cfafad114186681d0dec98880ffe95
+EBUILD cchardet-2.1.19.ebuild 568 BLAKE2B c7234a4e3596c9bfb6121dba288a8cf83c7a56424381840685ef11168399211fafa6023f538a1483f1e5ab91a51f166fbf45c798a9c2a208853c9f416cdf06f2 SHA512 d956cc1ef66ab6a0a283007b5104996aec9e465ce9dddb3847fc08f386054deb0f3d7aa9a145d97acfb7ac32999c188d77a4e4d6aa3c1669ab6e30184c8fc7eb
EBUILD cchardet-2.1.7-r1.ebuild 601 BLAKE2B 9b32081169bcc78dad9a1b40ca7673acf67c20db089b3e2eb1730c02cc78c8016a27d8dca26ccebeb3c818791a4c28ebb769da9bb4dbe2571a814b0dc4eb8427 SHA512 79c8720f19a41ed1046f24ec74380c8ef0605272250755fab2f1961207dd02d0a95cf08a98f87fe4de2fd3b67a0a3eb2b18fc0dbc784ae810b94879df44456c1
-MISC metadata.xml 346 BLAKE2B 86fd035032c4a4223ca8b8b7db0b3593b60676376b17ebc0c2a02ccce6d4dd22f7bcc80350634378bfd9afb44640a4f8798dad5f479024510c90b0a2f9425eb9 SHA512 f33d9efa195ef267c11565d657fdbfdc6b11af571b812e7ce9885b41ab7e48c4e58422618ebf6809d7e1adab00977996d86ac7fe4f47b0db4267a34d16607805
+MISC metadata.xml 461 BLAKE2B 465041740ce32a894081ad2f533ca436b111a61b289b6e9047088e54cbda0462f9b44520ee2aab0dbf4922dc823001e3d00343a775d0e411b9af07055e574df9 SHA512 1b65345c4440af61bea35d6fa1e897ae12f1b50d440542f2e45270f58e21069819b4bcfe85f0fb11f329d74da8ec22fea2d660907a48974a85cf886c1fc782c8
diff --git a/dev-python/cchardet/cchardet-2.1.19.ebuild b/dev-python/cchardet/cchardet-2.1.19.ebuild
new file mode 100644
index 000000000000..040185bcc018
--- /dev/null
+++ b/dev-python/cchardet/cchardet-2.1.19.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=faust-cchardet
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="High speed universal character encoding detector"
+HOMEPAGE="
+ https://github.com/faust-streaming/cChardet/
+ https://pypi.org/project/faust-cchardet/
+"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/cchardet/metadata.xml b/dev-python/cchardet/metadata.xml
index 04994b4fd816..2cf31bd36ca7 100644
--- a/dev-python/cchardet/metadata.xml
+++ b/dev-python/cchardet/metadata.xml
@@ -4,8 +4,12 @@
<maintainer type="person">
<email>zmedico@gentoo.org</email>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
- <remote-id type="pypi">cchardet</remote-id>
- <remote-id type="github">PyYoshi/cChardet</remote-id>
+ <remote-id type="pypi">faust-cchardet</remote-id>
+ <remote-id type="github">faust-streaming/cChardet</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index 69e18a128fa3..d4088c539059 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -9,6 +9,7 @@ DIST moto-4.1.7.tar.gz 3506753 BLAKE2B 76e38629f1a772816bfa647b90e89e3c4533cd36f
DIST moto-4.1.8.tar.gz 3520127 BLAKE2B 623d97dbec357227ea401ac98f694eaaa129fcb47f6b160a22bf95f8d52facf9bb3917e00409990a7e447e70de5a94df9f234c3ed615081573169f3976169f3d SHA512 9c3e9825d1e8d09e278f8bbeb11719c4bee756f9e95b2edbe82b4ffbd3acb93008f6ffdc582eb46619104d0b839428b5e8078ef0e341a3b73f0bc61a7ebf806f
DIST moto-4.1.9.tar.gz 3537033 BLAKE2B fda091585fd331ff68127290426bb1f5418b118b9d60711ca54bcf57b1ff4375320bb3f3ae79321d105e815d856183b7f3c012f20c07f357831fb8260dcbd9f1 SHA512 1ce3aa3549b6320a8493f7018ccdc630f94cd324791e91c2ce28a994dff8da37058c47c84f480dfcad870ef63a0e1d35712348b120c112696b8d9cbce66186a9
DIST moto-4.2.2.tar.gz 3646677 BLAKE2B 142d66f069a8a461f26959be5ec63cbd8dac7c5f4e752be3f78a728ee262a50b9505c7e1631da3fe98ac7b7d0044bcf4dd31edeb936798722d3c5fac0f062908 SHA512 76d3b7f575f70a0ce51dfca0918c036f791ea74be2194a96210bf92ce628f873458f1eb5d2a04308d5b0805f4469f7cf0d50eef845830a0ee1fa85b96bfb4104
+DIST moto-4.2.3.tar.gz 4693815 BLAKE2B 3163376f5dd645af9fb9cd1a9af459ec76c6fd3c6f908d72429c2f72e5b4c2e8864afc0afbabe344524c403da0bf19477491b44bba2f29f422c38334595d0fc8 SHA512 a9a45fdb05722466f29e1a66b59637aa839960922b5992ad0aca6523edbe0c3b6c4e4724311d74d5b18cebdbf3fb26dd64887b2fea83ab5cc5487728f18a4c0e
EBUILD moto-4.1.10.ebuild 5240 BLAKE2B 317ff43cc57e60de11ddd9b3edd39ee68a4fe1baeff511fcdb5d2430bc8a76d7bee8f82564e3c444752fecf263ac77b95314062f9ed5895a8daca8f00da67511 SHA512 a7582f382f25b2529ab79f27c9874e5c9b46161bbea16729ec50e87c31c4b623bc2aba33a45cda6e2ce27b35ec945a6fc0f042e38b76fc1de63cc7bffea3fa30
EBUILD moto-4.1.11.ebuild 4248 BLAKE2B 230dd3baf21ff4bf2abbdaf43def8a585997a56af2f709008aa0c6b7ae1d45a0d1b5d375d6b5e110826e645bf3c67d8f8009108cdcedd4af4c1c1b1f0d8b23f9 SHA512 f616e811f8b6680b51382673f68b27c7423a9f8b6f69d64084346d5aa7cc0575abf5597246a5ca4819978d615d8f8174a313d78c5552e3fc76fce5032b5a18e4
EBUILD moto-4.1.12.ebuild 4247 BLAKE2B 4aa77bc7d49fd047b038eb3fbcd51ef00e8c87577f6990f4cac0ee1c139070b7d68b24827e5fe9a02a2ea89456e267a769bbfca62eed7877e755850414177377 SHA512 4a68c35572bebe7a81cbbb4e87f3bf37b80dca4fc07386745a431551c56d64a736eecb3f18359ecec41fa732071749796992ddc8db7d6b2e93420de69c21808f
@@ -20,4 +21,5 @@ EBUILD moto-4.1.7.ebuild 4651 BLAKE2B 021fffe6498724bc3d1898f43fa00ab796624791ae
EBUILD moto-4.1.8.ebuild 4750 BLAKE2B 60ccc43db711e3e00966b3a0390839e3d973abea103636bfac30b35365a648fe3431a205aa6840b63253dc07dd7125cb20d20385b913aed2339bb10e545ef86a SHA512 0bbfea191ba3b29f96d678e972f82ae03438a3781d7240c3d0d8ff41b2ffa10ea1b7270ae86e0803ae593b7f25bc9fb054ae637c3f7b93df897e19ea88299600
EBUILD moto-4.1.9.ebuild 4751 BLAKE2B 92991b43987e18fa779f1951dc984ac38508df1cd14565bfb555fc08c4d0526fa05aba6573e6de202547b77961e7ccb4481fa57ad6b362dfccf4e3e6f2883c0c SHA512 65fe914959e04b660f403a755467d8678146f184a1890464ad9a23b429090644a1b84ec0f0c123e9d3f927682ba7b1caa90a46de4a295bb91c1cd1a01d09ef01
EBUILD moto-4.2.2.ebuild 4248 BLAKE2B 230dd3baf21ff4bf2abbdaf43def8a585997a56af2f709008aa0c6b7ae1d45a0d1b5d375d6b5e110826e645bf3c67d8f8009108cdcedd4af4c1c1b1f0d8b23f9 SHA512 f616e811f8b6680b51382673f68b27c7423a9f8b6f69d64084346d5aa7cc0575abf5597246a5ca4819978d615d8f8174a313d78c5552e3fc76fce5032b5a18e4
+EBUILD moto-4.2.3.ebuild 4334 BLAKE2B 04ef612d1f1559b7700064d961e082bc54d06f3b9740b474115b63a68b639187ce878d5051ed26add8ea2f1441f7e241dac631b16faff12fc13a129b4f10d159 SHA512 f44a10264972f27153377fe940a4c0b2e60272a4c999e0f8065a74c0c2dbbb7edb79cec1df5724c2ec6d96c4b146be68a01c6a541c9da5527af0f81f609cd3d1
MISC metadata.xml 553 BLAKE2B 1669d17d3e655aa3fb41a489229a5fbfa6a9cfb23c667e98fbbef931992c7e9645581b9ea12011601093586cba491a5557d68e5256edb9f387c4db362346edf9 SHA512 48ae3bd9be8c3bfb68f7022d0e7bb422c2a06157967809be302067facf91db825023859d18ccea89109931538b0e93181d54a31fcc967628df61a9a3112edd3d
diff --git a/dev-python/moto/moto-4.2.3.ebuild b/dev-python/moto/moto-4.2.3.ebuild
new file mode 100644
index 000000000000..41ae63f02903
--- /dev/null
+++ b/dev-python/moto/moto-4.2.3.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="
+ https://github.com/getmoto/moto/
+ https://pypi.org/project/moto/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/aws-xray-sdk-0.93[${PYTHON_USEDEP}]
+ >=dev-python/cfn-lint-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ >=dev-python/docker-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.5[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.10.1[${PYTHON_USEDEP}]
+ >=dev-python/jsondiff-1.1.2[${PYTHON_USEDEP}]
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-cors[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3.0.7[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.2.8[${PYTHON_USEDEP}]
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-jose[${PYTHON_USEDEP}]
+ dev-python/python-sshpubkeys[${PYTHON_USEDEP}]
+ >=dev-python/responses-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zipp[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/sure-1.4.11[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/test_firehose/test_firehose_put.py::test_put_record_http_destination
+ tests/test_firehose/test_firehose_put.py::test_put_record_batch_http_destination
+ # broken code (local variable used referenced before definition)
+ tests/test_appsync/test_appsync_schema.py
+ # Needs network (or docker?) but not marked as such, bug #807031
+ # TODO: report upstream
+ tests/test_awslambda/test_lambda_layers_invoked.py::test_invoke_local_lambda_layers
+ tests/test_batch/test_batch_jobs.py::test_cancel_pending_job
+ tests/test_batch/test_batch_jobs.py::test_cancel_running_job
+ tests/test_batch/test_batch_jobs.py::test_container_overrides
+ tests/test_batch/test_batch_jobs.py::test_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_dependencies
+ tests/test_batch/test_batch_jobs.py::test_failed_job
+ tests/test_batch/test_batch_jobs.py::test_terminate_job
+ tests/test_cloudformation/test_cloudformation_custom_resources.py::test_create_custom_lambda_resource__verify_cfnresponse_failed
+
+ tests/test_cloudformation/test_cloudformation_stack_integration.py::test_lambda_function
+ tests/test_core/test_docker.py::test_docker_is_running_and_available
+ tests/test_events/test_events_lambdatriggers_integration.py::test_creating_bucket__invokes_lambda
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events0-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events1-ObjectCreated:Put]"
+ "tests/test_s3/test_s3_lambda_integration.py::test_objectcreated_put__invokes_lambda[match_events3-ObjectCreated:Put]"
+ # TODO
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_queue
+ tests/test_sqs/test_sqs_integration.py::test_invoke_function_from_sqs_fifo_queue
+ # require py_partiql_parser
+ tests/test_s3/test_s3_select.py
+ tests/test_dynamodb/test_dynamodb_statements.py
+ # broken by new urllib3
+ tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_data
+ tests/test_moto_api/recorder/test_recorder.py::TestRecorder::test_s3_upload_file_using_requests
+ tests/test_s3/test_s3.py::test_upload_from_file_to_presigned_url
+ tests/test_s3/test_s3.py::test_put_chunked_with_v4_signature_in_body
+ tests/test_s3/test_s3.py::test_presigned_put_url_with_approved_headers
+ tests/test_s3/test_s3.py::test_presigned_put_url_with_custom_headers
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ # note: pytest-xdist causes random test failures
+ epytest -m 'not network'
+}