summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-01 08:13:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-01 08:13:46 +0100
commit48e7f15d37baf7167041b2ab0e2a19a703e5c99f (patch)
treea4ae631f4b109859ab021cfc9d048e9a81a252ce /dev-python
parentde6c40224da664deb650b25efd11f41044602c76 (diff)
gentoo auto-resync : 01:04:2024 - 08:13:46
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/GitPython/GitPython-3.1.43.ebuild79
-rw-r--r--dev-python/GitPython/Manifest3
-rw-r--r--dev-python/Manifest.gzbin271245 -> 271253 bytes
-rw-r--r--dev-python/hypothesis/Manifest2
-rw-r--r--dev-python/hypothesis/hypothesis-6.100.0.ebuild91
-rw-r--r--dev-python/trimesh/Manifest2
-rw-r--r--dev-python/trimesh/trimesh-4.2.4.ebuild69
7 files changed, 246 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.43.ebuild b/dev-python/GitPython/GitPython-3.1.43.ebuild
new file mode 100644
index 000000000000..68edb93079a7
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.43.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.11
+SMMAP_P=smmap-5.0.1
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="
+ https://github.com/gitpython-developers/GitPython/
+ https://pypi.org/project/GitPython/
+"
+SRC_URI+="
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ git rev-parse HEAD > .git/refs/remotes/origin/master || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # performance tests are unreliable by design
+ test/performance
+ # unimportant and problematic
+ test/test_installation.py
+ # Internet
+ test/test_quick_doc.py::QuickDoc::test_cloned_repo_object
+ # TODO
+ test/test_submodule.py::TestSubmodule::test_base_rw
+ test/test_submodule.py::TestSubmodule::test_root_module
+ )
+
+ epytest -o addopts= test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index 666d5b391fa3..bfd82c4c360f 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,6 +1,9 @@
DIST GitPython-3.1.42.gitbundle 10271846 BLAKE2B 72023a523c0bf888d1fa356a303feff19e142018d7d21722510b7fff69174794feed8fdda84c6fc4c8738c551634924331e48eb82dac71d8c5ebcf145296f6bd SHA512 c7b5ce6bf4500f6350bd1b260317e235fb16d4b8d3dfce9849a845a96d466f61eba9d40f18a0c7d302718f856d08f9c50bde811cadedb78d1dd2ebddaf9cfe48
DIST GitPython-3.1.42.tar.gz 203449 BLAKE2B 7c18cb6cf0cc10b3269889bd7f4b0c3b61fd0ed765b3723c5bdf331a6e030bdc76587ce1c8e3d8ca5d7cb003968b74c6079b466a6afd3326c418f16e81ed9291 SHA512 f83d5fadc5fbd4d7837d42bc78bc07a9609bb0a10f5938de8d6c88da91de5638fafd6df23e468f7c23c19e11b4fbf273c19858336791ff199997dbe4e1aec91e
+DIST GitPython-3.1.43.gitbundle 10674326 BLAKE2B c430e6fec138077502dce16a1a100459c30134af7865a2e228646791465a7176ee3ef4db5cc83081f56b5e9877aeb4ba7e54b0526d6c2f594520335db4b48e9e SHA512 8c4b2fdf2e382393420bee1cb19929171d72e72669ac3ef96ff112119d803775aae92a14908b9bd51873f102ab85dfadd940b0789da6179b0f99354ae4b6d469
+DIST GitPython-3.1.43.tar.gz 214149 BLAKE2B bc95520b839a43b88571678d7dadd3998a613a4e4f5b0e59f8740add7794767db2820e2d68a98940976ed27fa57b6e487895b1f3d2894b55f1d7f4e06757a461 SHA512 c193418bbb6ebb4f202c4f6aa95b731acf319d6560db176aa7126cf848a1f11eea9f432c4ff6812e8ddb5f8386b1fa5e10335fbf170f3ec3ac5fd2dcde783415
DIST gitdb-4.0.11.gitbundle 1620355 BLAKE2B 8095193318d4262b8ebb04f35a0500eda8757057ed472dbaaece53e6afa6227e2b2c02a2be5daa5e4c0cc43dcbb5046555407d3d7c8dbed0bc5c415515032b8d SHA512 17e404b335a3c081f4058aeba5c57e5697a580f8ad7a280fde868968cf48f5a0852bfa45019eab730279582c0c536f8204e973d93af09da05908477329d73360
DIST smmap-5.0.1.gitbundle 362567 BLAKE2B 72c8b48ad3250a33b94218c145c02033dee84c1da5f1eea57983a58699262d51844be675330d95c7d64924b6aeaacd4b0a57e9a5acad3be184aaad62102202e7 SHA512 9ca8386bfec25d1562cdf1c2ee85f7edb15fd3f44ecd1abbef738979f12b82f0b0f39a06589203a39f89518d981d7129e35f64f2d855cd162cd964bdd87c8d18
EBUILD GitPython-3.1.42.ebuild 1982 BLAKE2B ed254e162832216e053463ce2098ab9f293b38cd8889842f06b75a3805728971dac5c878b83be6d0d48084f44fbf5eedc76cd764be5b76db4f8e0a52c55c8260 SHA512 f54bfaa505c67018a456192ffc594e27f3d4f38339af028c2746a95c254d594ca1199194238711651d45c6d8afa2f1225d79964135d4c6dcf6f068726d6589ff
+EBUILD GitPython-3.1.43.ebuild 1990 BLAKE2B 28e779bd4479ece31e983d54cfd26e4a214d8cb1490c73592306e530254aaabdba02588954b5ba8baf34c3fb3776c06799f82eb9c002de5ca8d4a0fa39c8f219 SHA512 327e67ba9088ed470a35e17f7d8c7cf988a1623d789101fee0d437155f4d9886e4e5f169e55e8dcf895615475c1619845d980906d1217a04e787de60d2db8648
MISC metadata.xml 407 BLAKE2B 49fd8d520d575be1489c299f22595120fad882f055b9cf2d02b87382c6d8f0ff38af694e5584b4da579aa84b82c2f1032e4afb64cafd9f4fe9212a6d67b4a752 SHA512 1bebe1e134eb86a4745cf7e297d45118a2bdd3d8a71d0034294b5c799a9cee763c63b61b34c6707c52f61058f727f4b827dd020d285fc297712b29eb7c1129ef
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 821638f6c744..6066efdc5f06 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 1688f4e30210..f2b941b2a5f7 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,5 +1,7 @@
+DIST hypothesis-6.100.0.gh.tar.gz 9450559 BLAKE2B c26324339dfc770feb51de103227b58ea1be3deb0dc6c54a7ba6a7be6a719ab33503358978da2cc040a93af7c169238e7401ec9567d08c6b51889e42f29b7c7b SHA512 697ff894d1e1033f3f6f8d9d7a301d8874c61d340cac2746ede4a4c8a6b77d7b95044edc3a467c39e5d570f554f07eb7321eb5cfb9de4b648ce31b914ec491c4
DIST hypothesis-6.98.18.gh.tar.gz 9434436 BLAKE2B 45861775caa1657d06469fc8cd0062aee1b408c3b02a58ff4d50b9de9ce62d8fd351c6b8f4b1b7f543fe70d6b8f2c663ad8e9252b833d5c567d3c28449fc3eaf SHA512 cff5cad9308e7b030e38f09a9544ed84f468bc4bd6391a2347777bb7781b116bd64f41338ad32535d427ebda507ce3f0f5bafc0af5a8179976c17d36762679e9
DIST hypothesis-6.99.13.gh.tar.gz 9450425 BLAKE2B cb8d559d95c60a931640c978ad3ed4c9898cc048254f105f9cb79cd8e36c8b28712d48304b17f5a837a1fd69b88102461a057d5d9ea3786a846d61362137d426 SHA512 0d74dcb6c5d8015c8c660b66298a3053fce1ad04191f81b216a05b08f24fdaaccc7470937459614b95810dad4e37c4712da67eeff414ca50af1d1e5fa81b4d64
+EBUILD hypothesis-6.100.0.ebuild 2511 BLAKE2B ddc6dc2ecc80c134566b183ff0d4082338c658a96207732a22ea7a7bfa5bcd1d45d652688248896a8ee028e04350282f361423103e44202e36097d0fedab18fb SHA512 94bc6c8e3f80d6e2b6c8d89f124ac1ded58de4e18bd1dd405c9ca419e0a894b7684615fcbb645e430f44772588e12bebac012224a03df2bd2ab081dbc4eba936
EBUILD hypothesis-6.98.18.ebuild 2735 BLAKE2B 6e20ed69d463f380603138fe5aa189f11e44a4891a1b4a8284b8af6f77c01e9b575ec9637c0696ceecef6e7d088709eb9a2bf8b627de3ca6767669673fc0eb69 SHA512 7fcbd5263774922c918f0d9778ab1cf702f4d5ddd6009237a73926c57aeed35fcef06eaf6775922a6119cb524343179350d5a5df6d1436faff8e8c5ac4d4cd20
EBUILD hypothesis-6.99.13.ebuild 2511 BLAKE2B ddc6dc2ecc80c134566b183ff0d4082338c658a96207732a22ea7a7bfa5bcd1d45d652688248896a8ee028e04350282f361423103e44202e36097d0fedab18fb SHA512 94bc6c8e3f80d6e2b6c8d89f124ac1ded58de4e18bd1dd405c9ca419e0a894b7684615fcbb645e430f44772588e12bebac012224a03df2bd2ab081dbc4eba936
MISC metadata.xml 492 BLAKE2B c9e9bbd59af55d1f47e5b7a86933c02b47f832122d03eaca56bd3ec9476cf260d91d4fd2da5068845d4525b7cc9f702b515e8d6a0dffa7923f5898cfd44e12a1 SHA512 166b33d6ac887f52d54fb9d556102038c00650a597d2de1c3aad3f8b5e136e9b6b7db31f05f3379435e4c5f943156d5839d78fc95461af411037a3162ea6705e
diff --git a/dev-python/hypothesis/hypothesis-6.100.0.ebuild b/dev-python/hypothesis/hypothesis-6.100.0.ebuild
new file mode 100644
index 000000000000..13d62b8d6bd1
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.100.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}
diff --git a/dev-python/trimesh/Manifest b/dev-python/trimesh/Manifest
index 16d9308873a7..80a557038733 100644
--- a/dev-python/trimesh/Manifest
+++ b/dev-python/trimesh/Manifest
@@ -2,8 +2,10 @@ DIST trimesh-4.1.8.gh.tar.gz 13440336 BLAKE2B aa4bddc3d613144a0e304ec320a2b38df2
DIST trimesh-4.2.0.gh.tar.gz 13553809 BLAKE2B 141aec46cb8bf2342251a72e5e4c1fbee1e33e4ff63d420cfa4db1758fc324d572d54932ce1526ba2df75d9770f001d9dbe41a79835837931c4c46221fbb6871 SHA512 75efd00ef5ff8f9c25bdfb06ab92fa09db154771356b18ebcf457cba4c2f366645084eb078e5e324cfb41fe101797694aa6b00005f7ccd1290ba4d2d6c088ebd
DIST trimesh-4.2.1.gh.tar.gz 13554447 BLAKE2B 02b75d8768963c250bbc1ebb75815567736a74b288da2a781b83fc3d31934059ebb85115c2e556a29da6c0e3034714226addba062d776acca4953414d1ed3492 SHA512 bdcd8436869849e8e8897732e0b9f8390d0771ea8dcadabb108ee8245d75c4d0ac915456473b6b0ed4f2f27fad48e123511e0bcfc79d485119376290c6f6d311
DIST trimesh-4.2.3.gh.tar.gz 13554586 BLAKE2B 2c82690a17d8c62c80c99e87d9347ab85c14b2170fbdccc7967f893f6d83bed9aa2e38ef3f024567893d926511b34b20109bb94c8e976ced9d7a77190a653f14 SHA512 541438e5f5bd577af693bb238b308c7094b334530d7a962881e05db81331e1c896c82f76b0dcd4bfa17abcfec9eadf869bb0cad01e1402e99852c3ff2d184e5f
+DIST trimesh-4.2.4.gh.tar.gz 13554819 BLAKE2B 233f4d5404793ed1b5dc475da2dd371ca3a792239ae9ffea95ef3609a19b2701f66ad7aeb72b7b078b7a58d812ebe59b3bc12fedc6b9c34213c60378a2959d1c SHA512 3d37a429a21250a26f0a46c29c432b97158849bc0fbba7dec441bdd2453c4ef6a917483604f1c7ecb0e2415b9a270a80e36225cb951e59af1db54d20ebf60902
EBUILD trimesh-4.1.8.ebuild 1950 BLAKE2B 3a3263575955b65379e291313fda8e2cf49086d52db45133bea9f23a1294a486230331577776cd88205d131c745db82b20a8426b7bae94c4bc28fc2cb2bf1fd4 SHA512 223dcdb5a6b9bd2cbeeafb6d4dcfdcb8edce16ddd08406f194799772427340fc167a227649ea9c6c28e5a72097a7d1bf7d8013d3bc4cb80abebdd13a55898de3
EBUILD trimesh-4.2.0.ebuild 1952 BLAKE2B dfc4f8a737b468861e4a18b4d28a91a299b869bb2f236c1214230543b4f4f83ad773494a808eb63b2aca57bd82ec28a6ed7241c22bdca1b0ddf0ed5f8f4d0a4c SHA512 2c0531123d157cd0f3ddf4ee4da438ad06677d9549291ef0af0b08ff21819239ee152ee77651f8d770adca1f8dcf03b2070d63a6e844649ebe44c93b930abe13
EBUILD trimesh-4.2.1.ebuild 1959 BLAKE2B b78d508c3f0691e454c7e93b6d7413f2ef9ebf86d2dc224cd1b1ecfeb710da08dfb2ade3f008ed0f11efc6e1e80e191239ea1ef2dd5a855155a5ecf65a995c2c SHA512 ceb7a80f34c3320198559c8d0637e5d38e56bb565a5a08fce6b2f267de558c23861a78ed54adfa5021f467e124ea759396b3a5317187379b8c1786793732b5ea
EBUILD trimesh-4.2.3.ebuild 1959 BLAKE2B b78d508c3f0691e454c7e93b6d7413f2ef9ebf86d2dc224cd1b1ecfeb710da08dfb2ade3f008ed0f11efc6e1e80e191239ea1ef2dd5a855155a5ecf65a995c2c SHA512 ceb7a80f34c3320198559c8d0637e5d38e56bb565a5a08fce6b2f267de558c23861a78ed54adfa5021f467e124ea759396b3a5317187379b8c1786793732b5ea
+EBUILD trimesh-4.2.4.ebuild 1959 BLAKE2B b78d508c3f0691e454c7e93b6d7413f2ef9ebf86d2dc224cd1b1ecfeb710da08dfb2ade3f008ed0f11efc6e1e80e191239ea1ef2dd5a855155a5ecf65a995c2c SHA512 ceb7a80f34c3320198559c8d0637e5d38e56bb565a5a08fce6b2f267de558c23861a78ed54adfa5021f467e124ea759396b3a5317187379b8c1786793732b5ea
MISC metadata.xml 495 BLAKE2B b8b403f7bfbac53ed234c2ba50324041502a28465d70e9406867f05741e0313845307491fcfd85f05e2993b21daf14117a4b6863b45422fd4c62c6e28902e3ff SHA512 3deec8ab4b513536a7fe182be8f1b96e06fd06b2480d3e516c2b3462cc26fcbdeb1d165b4d0297465e93c0cce584ab40a8f905b81a59dcb4040a39655028783d
diff --git a/dev-python/trimesh/trimesh-4.2.4.ebuild b/dev-python/trimesh/trimesh-4.2.4.ebuild
new file mode 100644
index 000000000000..1efbb5f219c0
--- /dev/null
+++ b/dev-python/trimesh/trimesh-4.2.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for loading and using triangular meshes"
+HOMEPAGE="
+ https://trimesh.org/
+ https://github.com/mikedh/trimesh/
+ https://pypi.org/project/trimesh/
+"
+SRC_URI="
+ https://github.com/mikedh/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ dev-python/colorlog[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycollada[${PYTHON_USEDEP}]
+ dev-python/pyglet[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/shapely-1.8.2[${PYTHON_USEDEP}]
+ dev-python/svg-path[${PYTHON_USEDEP}]
+ dev-python/sympy[${PYTHON_USEDEP}]
+ dev-python/xxhash[${PYTHON_USEDEP}]
+ sci-libs/rtree[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mapbox_earcut[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=1800
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+pkg_postinst() {
+ optfeature_header "${PN} functionality can be extended by installing the following packages:"
+ optfeature "making GUI applications with 3D stuff" dev-python/glooey
+ optfeature "2D triangulations of polygons" dev-python/mapbox_earcut
+ optfeature "loading a number of additional mesh formats" dev-python/meshio
+ optfeature "figuring out how much memory we have" dev-python/psutil
+ optfeature "marching cubes and other nice stuff" dev-python/scikit-image
+}