summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 01:35:27 +0000
commit3cba520665a0461aa7b0ada016f4a0df717e37a2 (patch)
tree2a653051c7ea63b16724a5da9d583994530ab97b /dev-python
parent8c39538f1e5cf37f42c409a6c742f96abef56f3b (diff)
gentoo auto-resync : 25:12:2023 - 01:35:27
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin268970 -> 269132 bytes
-rw-r--r--dev-python/apprise/Manifest3
-rw-r--r--dev-python/apprise/apprise-1.6.0.ebuild35
-rw-r--r--dev-python/apprise/metadata.xml17
-rw-r--r--dev-python/dominate/Manifest2
-rw-r--r--dev-python/dominate/dominate-2.9.1.ebuild21
-rw-r--r--dev-python/paho-mqtt/Manifest2
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.6.1-r1.ebuild2
8 files changed, 80 insertions, 2 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 4c6c53ab65aa..dd74f93c02f8 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
new file mode 100644
index 000000000000..e48489c902ed
--- /dev/null
+++ b/dev-python/apprise/Manifest
@@ -0,0 +1,3 @@
+DIST apprise-1.6.0.tar.gz 1582966 BLAKE2B aec28c82a2e1b45341f1e67a0778be2a9149ff591172122abb7d30eeed27c7b49171556993c0f1c0d33fe12a5dcdeb4ad0ade8b9e68a8f9950a3f8b6f0638156 SHA512 572d0cb9e3464ea2bc65a101e520dd0b15ada08c158a21d1ac698adbcd454ecf5af7ad30dca6495b4d7e38b92128774c43864c011f1af26ad917699e1d50c59b
+EBUILD apprise-1.6.0.ebuild 884 BLAKE2B 42b346cda094d67ac99425cb65efd2e2a79f0e20f3141de18d054162542290d1bbca2913c77409871338934c936b779e6b2bd16a71836b25581aae413e660429 SHA512 5226be185bbde7fd87a65363980ea782e5053b24c32d75ebfbc1f01d93d517168f554a9a8e1858f71cb3ae4ad156d20dc840ffc78ee053758d08af848c00b2a7
+MISC metadata.xml 559 BLAKE2B 1a8270085b43930488155404867d26c354c5feee8baaf934eb83bd5ff52d7f08cb787fe5063323ebcd8fc85d630c6b79c5f0be9c7653baa298981fe9140bad35 SHA512 838e1ad03125406937967899ce418725ef5cf09b92fcf2953efc3b0636a387922f0152da82f3394067a062cbcfa849b3eb9be0cba776732f6e5c8af74c3a041e
diff --git a/dev-python/apprise/apprise-1.6.0.ebuild b/dev-python/apprise/apprise-1.6.0.ebuild
new file mode 100644
index 000000000000..17d45d5fc40b
--- /dev/null
+++ b/dev-python/apprise/apprise-1.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+#FIXME
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="dev-python/Babel[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest-mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/apprise/metadata.xml b/dev-python/apprise/metadata.xml
new file mode 100644
index 000000000000..fd8dbf3c5236
--- /dev/null
+++ b/dev-python/apprise/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">apprise</remote-id>
+ <remote-id type="github">caronc/apprise</remote-id>
+ </upstream>
+ <use>
+ <flag name="dbus">Support sending notifications to the desktop over D-Bus</flag>
+ <flag name="mqtt">Support sending notifications over MQTT</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-python/dominate/Manifest b/dev-python/dominate/Manifest
index 15cef85d8d5d..9bc4d6b09a63 100644
--- a/dev-python/dominate/Manifest
+++ b/dev-python/dominate/Manifest
@@ -1,3 +1,5 @@
DIST dominate-2.9.0.tar.gz 36289 BLAKE2B 8cc2ee67b027d4f1466ace7d39b47a330c87f5f0396b3bfe6a4b7ec3baff8e4e89d3f2cb7c6aa036aacd67743966508e50cdc289412781830f27878a614914ba SHA512 aec4f67bdc1ee0df9f0ed3fec5e41fca044d930d69bd7c508420d8b06d4f21f5d5fc9ec867cea68bd82723cac7b4df645748592dc4ded9213ec60f5bb6a6f421
+DIST dominate-2.9.1.tar.gz 37715 BLAKE2B df0271537916e57d50b0d1918f34cdbcd2b1f2bde1e50995593b242e75758f184515dd33518fec0c57c959f5a504dfebf4210814213b159bed2546af7369d915 SHA512 690f7228957cfc3c673bb1863f4e7d15c5e717c4bde24eb8280efc1be07cd50fae514a10b3208ee1b37e4d19d513622c7768b9efb61f11c286430832e873e8e5
EBUILD dominate-2.9.0.ebuild 475 BLAKE2B 488de8e88e9ab951231b84f0257e1e7b1e42e34f46dc18c5e03b656f089fbb51d67c30ffc212650d89b7a9aae9e8d84ae17ff4c54d9d2d6d3c06482c8c37d7a0 SHA512 a91920a5fbc3d3283274a3ed8ea49f0343254d9d4f207c5c68b619f98db40e5e6ec5927a46f7d5e292baca5a6f53a45eece17e5b69e610c9c83d3bbdd5566132
+EBUILD dominate-2.9.1.ebuild 478 BLAKE2B 1164992606d3711e8e5fce12ae65784c9134e75fdaf683ae30bc1d146c8c85538ce0e4b9bbfad85f371e7cfdc9b206f724b1d767f2e7e600fd88f20bfef02400 SHA512 a71d3ecc27d6f87a13f9080ae93cfad798abe87612e10eb623f60fabe0896fe2537a4a4879ccec158b2d149cec62d9b6417ce94318c803813607611f935657ee
MISC metadata.xml 796 BLAKE2B a6b8a73d12e14552aed0f4b4f2a4b5ff282829d44da6a3e283a04575bc31069d5e83a0f475d184896c586b416882507fa22ccfb346aec90692a47f28ea54646c SHA512 9a018dd4858f7a89ac7cfd8b1814df9bb24ebe9e811f0f98e2fe52f047b14bf742648de9c0e4ce55ff69434755d8b365297bd41a5909c63697eed925e1a30b03
diff --git a/dev-python/dominate/dominate-2.9.1.ebuild b/dev-python/dominate/dominate-2.9.1.ebuild
new file mode 100644
index 000000000000..576830e8c74f
--- /dev/null
+++ b/dev-python/dominate/dominate-2.9.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for creating and manipulating HTML documents using an elegant DOM API"
+HOMEPAGE="
+ https://github.com/Knio/dominate/
+ https://pypi.org/project/dominate/
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
index c73d1572b6e9..ab17e08b057b 100644
--- a/dev-python/paho-mqtt/Manifest
+++ b/dev-python/paho-mqtt/Manifest
@@ -1,3 +1,3 @@
DIST paho-mqtt-1.6.1.gh.tar.gz 145673 BLAKE2B fb583a2505892370737edfc9ad06b195c0feda4fd87794f3aa40fb30679b5710e04483e610a6be9c0e0978084f3ca96c0d285cf8cacb2bf67aca605f1d53ed7c SHA512 8a13c1f6f97138728d5cab6f7bcd6474942fdf9dfc18d1fad723d50de81f4e062953b5bef2ebbde27b08e480eed305ecbfeae467d70eb10f07ec0adca11750ec
-EBUILD paho-mqtt-1.6.1-r1.ebuild 674 BLAKE2B cd7c5b8e8434d4c0ceb3110fdff835b5a1f40cb63772d93553306359ee58f14e1b17b4d2a12a12edd0bacf440615853189d36b29c5b9530f84645dfd5c5de36b SHA512 26577a7aa798e915d5b88f0fe8b13c9e10c614d4e18207f2af416449cccefd8b5e5cb599078b74e7644339c46cc05f80678bed7ddda2f420e40005fb2c7ad3b7
+EBUILD paho-mqtt-1.6.1-r1.ebuild 681 BLAKE2B c51f65da8e09098374d46ad40c259619dce5e921801d3c11acc4b028165d86b2073c282b6b97241cd08552d51027e62fe3bd0e5a1adbc02c498f2c2dffcff5fd SHA512 a6a96c4b13de3930fc40945cbd909989fe1d4dcb2f00644dbe43f4339f171d2142f341076f9cb285c76f0915620717c36c76eab76debd7c5a4789c9673480fa6
MISC metadata.xml 508 BLAKE2B 92c37e962fa7af68e121e95a9c850c2d8bb4f087a7aac06740564dd10a4d52d3ff6861c52dab295a5dc343681e25055a9e69c1f7e32820816049fa6501b9e3fa SHA512 e9010f6f4256f611dcc07a080472bf78c55c0dc94bddd4c8b544944f4e1d780d8e36425442ecf97c2992831b9cbb9f55cfe2bd540dfb723029a984e7d5f12561
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.6.1-r1.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.6.1-r1.ebuild
index e005e4f5bf51..68f979a900b7 100644
--- a/dev-python/paho-mqtt/paho-mqtt-1.6.1-r1.ebuild
+++ b/dev-python/paho-mqtt/paho-mqtt-1.6.1-r1.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/paho.mqtt.python-${PV}"
LICENSE="EPL-2.0"
SLOT="0"
-KEYWORDS="amd64 arm64 x86"
+KEYWORDS="amd64 arm64 ~riscv x86"
BDEPEND="
test? (