summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-17 17:55:18 +0000
commit0bc41c955151f7b962f67f03e18e580620f91bd6 (patch)
tree834073a4e0c66ae35e5b891a763832075aad475f /dev-python
parente54e6bf2ec8cc0fb912bffefee5b3d22cd3fcd9c (diff)
gentoo auto-resync : 17:01:2023 - 17:55:17
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Manifest.gzbin260586 -> 260923 bytes
-rw-r--r--dev-python/beartype/Manifest2
-rw-r--r--dev-python/beartype/beartype-0.12.0.ebuild37
-rw-r--r--dev-python/caldav/Manifest1
-rw-r--r--dev-python/caldav/caldav-1.0.1-r1.ebuild41
-rw-r--r--dev-python/python-recurring-ical-events/Manifest3
-rw-r--r--dev-python/python-recurring-ical-events/metadata.xml13
-rw-r--r--dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild43
-rw-r--r--dev-python/translate-toolkit/Manifest2
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.8.2.ebuild98
-rw-r--r--dev-python/x-wr-timezone/Manifest3
-rw-r--r--dev-python/x-wr-timezone/metadata.xml13
-rw-r--r--dev-python/x-wr-timezone/x-wr-timezone-0.0.5.ebuild34
13 files changed, 290 insertions, 0 deletions
diff --git a/dev-python/Manifest.gz b/dev-python/Manifest.gz
index 7183277284f6..cad07ab28926 100644
--- a/dev-python/Manifest.gz
+++ b/dev-python/Manifest.gz
Binary files differ
diff --git a/dev-python/beartype/Manifest b/dev-python/beartype/Manifest
index c4c5ee928f9d..0bba07c5ba8e 100644
--- a/dev-python/beartype/Manifest
+++ b/dev-python/beartype/Manifest
@@ -1,3 +1,5 @@
DIST beartype-0.11.0.gh.tar.gz 806671 BLAKE2B 757764885fb99d82ecd2d7e205329a4f66898e0552e29216ca943ebc79661d0f43454dd43b0a7529cb148c0a50c9241eef56f7d5f1534290496d9811b3b9dac6 SHA512 23aff4208f6e41a8f3366c161576e6a6ff30f8d702926a52c266da4d169d683341ca6e728f5882ea2dbe91be23e64314b43343db4fab795d08a2983015398d9d
+DIST beartype-0.12.0.gh.tar.gz 874431 BLAKE2B 0ad2a6c852b32427f8f9c5a8915e580601b24551e956d458a64cda4127bffe91a94ff676e2284daed6671e2c94515a234fd74dcb3d8a78616665490d1a780910 SHA512 2724f080a0f423a8b79b080843db696ee607f2e27ef52d726928086b643ebb31abe4e3ae24cae12075e222a21291d301601606640ca281ff98272578d5bf752e
EBUILD beartype-0.11.0.ebuild 618 BLAKE2B 38c738a253ff65a4e1e9c6718447f50db9a99afec8a04df462ed4199ec0cc35651ea54cfa35c3809f6b9cd9fb741ca95fba43e3e4de8efd8d3d63e05884ea13d SHA512 55fdfbddffa87e31112dd85f38899486ad0d37772c5bd64d52762ba030b56b393b92492be52ffe97c07486ae2a3d86add23738c35d969986eb620a1545442de1
+EBUILD beartype-0.12.0.ebuild 753 BLAKE2B b2f4ca3721d8abc9b94fc93d7b113d4930523ded1780c25ce0530f560f8088ad29853d167b6e32afb21fd924da4bade6de5d91c77b1bff2a369a9d7d1f5944d8 SHA512 8ac18e7cdbf776906e64912733a62b412e0660cbfd14de71e141ea5481474229816848fe4ce855b7aa901f52f8d65e853b9b4ea2794ba441534175700e4a9b5a
MISC metadata.xml 393 BLAKE2B f22040a947a67160c9b4c2d41db713ea69ae7a272aba75c04b1620e3f813d62718425acbc8c18716981e4176ebeabc5b60e9376d9927552ea5a36b51b7baccdd SHA512 dea8caeb6e9091672994cee213be075819d593d1034cbc7e2b076f3fc32bd2afde13b6af094956885c9ddaa72f272c6a198f4f92e7b095606fdf900a4cec47ec
diff --git a/dev-python/beartype/beartype-0.12.0.ebuild b/dev-python/beartype/beartype-0.12.0.ebuild
new file mode 100644
index 000000000000..b5b5c8c7f555
--- /dev/null
+++ b/dev-python/beartype/beartype-0.12.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype
+"
+SRC_URI="
+ https://github.com/beartype/beartype/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a90_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+)
diff --git a/dev-python/caldav/Manifest b/dev-python/caldav/Manifest
index 6f8d6fd9ab9b..e94e362d17eb 100644
--- a/dev-python/caldav/Manifest
+++ b/dev-python/caldav/Manifest
@@ -1,5 +1,6 @@
DIST caldav-0.11.0.gh.tar.gz 126186 BLAKE2B 0d818ea5e76b88b3ea18f1fd878a297fa88ad9921d994a61d05c02aa80b73ac40bd8cb36810a050d8f6a87009911655b64a8a4ef09133cb751a225adacdd5575 SHA512 761753fa86e2ba9788030df1af482177bd01ee266a7fe8da744ac85eee95a74d1450e1afa0f64109b9c12aaedba0354d76da2ee9b27dec2771141fc453727d4f
DIST caldav-1.0.1.gh.tar.gz 133071 BLAKE2B d7b9eb8015782bed5d32b7c34508cfcc1334d33cdfed99003cf45893b0a894d5a3187a2c98f886f97ffe8a64140a5a3826e1b3f57b58228a61d1ad4f9bf9f72a SHA512 ac816afd74f6fe34d82345a8b3a934fbe2c37af6a75cc8ef91cd87c8b8d147962ff05e701cd91480c1963d57967898129f923655d366820b689959b00f55659f
EBUILD caldav-0.11.0.ebuild 1295 BLAKE2B 2ec17dd0724849ccb44ffbf34389c6503db72f8b4c059781e8dea14dd6affd4f6eeb56aadd795e720fb2537ef6489e6da1d17570ae2259acaa8046a44788d446 SHA512 7506ba748635ea11b80182adb6ed2c5c10693baf49fa7294cab2836f1b9c4c76565a45ffbd14b7d903e938d0b03cacd26c8f0055336660d758698234a79d3779
+EBUILD caldav-1.0.1-r1.ebuild 933 BLAKE2B c25ebe5632d99e4e329936e3750394570aee4f1fd86d9427cba51ab51f1c0d057dbaed5fa56ad0051a3c07e586c2064b17261a0542c5f722d1aba402830c6762 SHA512 f92bea41fc72ff352bd21c8a30d7f895722bb61d425711da6e612f6313b33ded63eaf18a70d08428142366ba0a986eb076cc103b7ee01998c32dbe7ebe197d4c
EBUILD caldav-1.0.1.ebuild 1345 BLAKE2B 1fb820c1cb3691d568ff6e272cbd18c9e31dd3267b21ac4f695a0cee78d83a4da2e4e44b987408668a7100765e90a63d13e8f7eceddfcee232fc061cfe80a7f5 SHA512 1a3d4db29a029593e3bf6cd24c7441bbd0c72870c6433f5052c8697f9ab984bd651ed718b0531f46583182418f2d244c253823d955cd8821d4ac75dc763ea29b
MISC metadata.xml 394 BLAKE2B f0b9c600418cbbc4c935d53b63f4e6c1235500984ed388ceb26c6e02fdb7200eec1464d8c4af17e6afdf3688479f0a0763e6e710f916c1c71dab2ca84df9509f SHA512 4f94039805c6cbfb97a667d555af39bcce7f10db8a7c61f3b8b48a903fcd52d3e30467c91c9ec13195be6dc3c4ccbfa088aeac390d5e1c64e9267527a8b77b6b
diff --git a/dev-python/caldav/caldav-1.0.1-r1.ebuild b/dev-python/caldav/caldav-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..295a2c82945a
--- /dev/null
+++ b/dev-python/caldav/caldav-1.0.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="CalDAV (RFC4791) client library for Python"
+HOMEPAGE="
+ https://github.com/python-caldav/caldav/
+ https://pypi.org/project/caldav/
+"
+SRC_URI="
+ https://github.com/python-caldav/caldav/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="|| ( GPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/vobject[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/python-recurring-ical-events[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ www-apps/radicale[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/python-recurring-ical-events/Manifest b/dev-python/python-recurring-ical-events/Manifest
new file mode 100644
index 000000000000..e16bd5c065b3
--- /dev/null
+++ b/dev-python/python-recurring-ical-events/Manifest
@@ -0,0 +1,3 @@
+DIST python-recurring-ical-events-2.0.0.gh.tar.gz 325608 BLAKE2B 386ab8a54343fb02c15938801c15b31c8c8ba6bd0888a677268625fcba5571724d53c42f9d093ea8590d6e3557c151b73f9fb532a1bea194bc6d7032e04946e9 SHA512 676bc074a4d9ddb2bf0aefe8e118eab6e80479bb0d585b9f4c50f4bd49c7adf03e484b34bdf01596bb012c903a8017644ff74026d333f13f5c7df2c4326ab18c
+EBUILD python-recurring-ical-events-2.0.0.ebuild 1085 BLAKE2B 8ddeaed90db3c979a2c3160bc6b1aa459816212775817ebd36ff1612a8fa5cf79e0369bbb41a964de7d5dae5bad0aabd11f360de2892f85cd3611946ac70eadf SHA512 9a447108732624a6af89d6e4632d2aac7fd9ba117689d9c5aeeecb073dc7dcc8c83e3e80eb69a0cdec606fef1ccebeca6793ad404109005d406dab3b2e742ac7
+MISC metadata.xml 431 BLAKE2B 19ac0f0a385fb9b0524bf641831fbe3c02f35f3ada35922b297563f871cb8e745404e04d18d9f7428ef5b3cca27f5205f4a7f99e85e2a3da18542a19574f04de SHA512 35283cfbd447b3ec9d0d97ec7c11580db012ee60076b12ba733962d58896203a162ece04a9015eca8cc556f28fac307fc9ddeb27c3ea9cb9c8b2d6df0cf93a50
diff --git a/dev-python/python-recurring-ical-events/metadata.xml b/dev-python/python-recurring-ical-events/metadata.xml
new file mode 100644
index 000000000000..3c5c8d8ba58d
--- /dev/null
+++ b/dev-python/python-recurring-ical-events/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">niccokunzmann/python-recurring-ical-events</remote-id>
+ <remote-id type="pypi">recurring-ical-events</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild b/dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild
new file mode 100644
index 000000000000..0787572abca4
--- /dev/null
+++ b/dev-python/python-recurring-ical-events/python-recurring-ical-events-2.0.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Repeat ICalendar events by RRULE, RDATE and EXDATE"
+HOMEPAGE="
+ https://github.com/niccokunzmann/python-recurring-ical-events/
+ https://pypi.org/project/recurring-ical-events/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/python-recurring-ical-events/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ <dev-python/x-wr-timezone-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/x-wr-timezone-0.0.5[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)
+
+EPYTEST_DESELECT=(
+ # a test checking if tzdata package is installed that is apparently
+ # needed for other tests, except it isn't
+ test/test_zoneinfo_issue_57.py::test_zoneinfo_must_be_installed_if_it_is_possible
+)
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 452d0c9a9d0e..188a8856bca3 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,7 +1,9 @@
DIST translate-3.7.4.gh.tar.gz 1153973 BLAKE2B 55fd5d8f8d9c53d3aabaaece54272650fc412c778cbbc86d83b391946aebb627c7ad3dd8e10d5bc0bd6380f8396fd5c373a47d9323365886a50299f392238b4c SHA512 0eb93712de9fd7324e0e99cd31996694356452df51ac9f081f27f7bf15391e9630d4b042e2af4ca5b06d43d92f35cfd8806f18ad936c293bd08bdd465b09789e
DIST translate-3.8.0.gh.tar.gz 1155430 BLAKE2B 53b9964373c49d2eaaa11f13c0a80aefef8572077561fbc2666b5c4f2f7b7731cda9ef665b0f077a84237bb7ccc6251b23308c18672d6397b08a6a64e91426bb SHA512 9ebacfa76e16e179cb000e9f60b1f91ddacf70644764d215df43c55876bc684c6e4c2c1d52e2c1aa00c6e757f87167f04ee7dac7ce996c5b9d3d39aff4bb7484
DIST translate-3.8.1.gh.tar.gz 1157283 BLAKE2B fffe95aa8d874a98cb6bc45a37ae03752ba9903b151ba894ca4bcaff48fbec524fadef4133b2bdf0c65b0d834c094bd6897d7ecca33ce00ef89840d1eb4fcf81 SHA512 a7739f0ddd64677e8a5236f017b9a36b7c4c2ea7b3710ffcae5dea5e738049b12f77a1b7cb6755712bdc55184258fb80e48ffa082abce886322614049d68dca9
+DIST translate-3.8.2.gh.tar.gz 1157429 BLAKE2B 3e611d2f1843fefd0d335a1f9a307b4239ab634499324631dd678a79c28ee17d909be621a0e0e00950ab97ea1dd2a46682f45f713895db85f62feacee8cbeef6 SHA512 3875a711dc7d070d4d857304848bd454fab0c5f78bc6722da4a905c21fa7a95d8b9f165397ea3c0e82216f312ecdd9ee0763da8a58338c51853d526b5956895b
EBUILD translate-toolkit-3.7.4.ebuild 2436 BLAKE2B 8fd08eb23c92d158095c64aa147083428393b9633126cd2b512f1679ff5a25476571b7f123b3b208982852dda689879f9269a1f74589f02518589118ce47db18 SHA512 24d68f30806aa4bebe852239b2ac261e054cf282f93125299da85268e8a57f2d6b7a9ebc2e1a855102efbf8bbaf48ad7842086d35513cd3a5a59d672403170bb
EBUILD translate-toolkit-3.8.0.ebuild 2439 BLAKE2B 76a7b69c12540271aaa50ee950a971c40dd6db7f9dd48b286d8ed17a133adffca050a77e16a2021bd0f5bf4de1fbc43576b12d54d19d4e1f6e6b8eed89387abb SHA512 48a037441d0f33e5f019dd406a13bf5da32dbc3ea25ce2e10bacbe2a422bd6b35feea56c684cfe9d747e6f711a94b8b00298763dbd8ba37b452c43ef5d529ab3
EBUILD translate-toolkit-3.8.1.ebuild 2439 BLAKE2B 76a7b69c12540271aaa50ee950a971c40dd6db7f9dd48b286d8ed17a133adffca050a77e16a2021bd0f5bf4de1fbc43576b12d54d19d4e1f6e6b8eed89387abb SHA512 48a037441d0f33e5f019dd406a13bf5da32dbc3ea25ce2e10bacbe2a422bd6b35feea56c684cfe9d747e6f711a94b8b00298763dbd8ba37b452c43ef5d529ab3
+EBUILD translate-toolkit-3.8.2.ebuild 2439 BLAKE2B 76a7b69c12540271aaa50ee950a971c40dd6db7f9dd48b286d8ed17a133adffca050a77e16a2021bd0f5bf4de1fbc43576b12d54d19d4e1f6e6b8eed89387abb SHA512 48a037441d0f33e5f019dd406a13bf5da32dbc3ea25ce2e10bacbe2a422bd6b35feea56c684cfe9d747e6f711a94b8b00298763dbd8ba37b452c43ef5d529ab3
MISC metadata.xml 756 BLAKE2B 06f64f258d362954f99f7e9eee241eb3dddc6b00b9069df2ad977d28b5cf06f9c8ee2246ee5958600b5ac86297968d7aaced6b6420dca4ed507c441c58c61ca9 SHA512 80374c40513ca450f97e3930929c1450e7438ea15830e60937952a6fccfd999675f2ca2056c5aa4e287ba256c6ec08a09d8f7adb8b2c5af8ca0cd595f34acd85
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.8.2.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.8.2.ebuild
new file mode 100644
index 000000000000..5628bcd1f693
--- /dev/null
+++ b/dev-python/translate-toolkit/translate-toolkit-3.8.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_P=translate-${PV}
+DESCRIPTION="Toolkit to convert between many translation formats"
+HOMEPAGE="
+ https://github.com/translate/translate/
+ https://pypi.org/project/translate-toolkit/
+"
+SRC_URI="
+ https://github.com/translate/translate/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+html +ical +ini +subtitles +yaml"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
+ dev-python/cheroot[${PYTHON_USEDEP}]
+ >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ sys-devel/gettext
+ html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
+ ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
+ ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
+ subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
+ yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/phply[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Fails with network-sandbox (and even with it off but w/ softer fail)
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
+ 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
+ # Apparently a change in line wrapping x_x
+ translate/storage/test_cpo.py::TestCPOFile::test_wrap_gettext
+ )
+ local EPYTEST_IGNORE=(
+ # unpackaged fluent.*
+ translate/storage/test_fluent.py
+ )
+
+ if ! use ini; then
+ EPYTEST_IGNORE+=(
+ translate/convert/test_ini2po.py
+ translate/convert/test_po2ini.py
+ )
+ fi
+
+ if ! use subtitles; then
+ EPYTEST_IGNORE+=(
+ translate/storage/test_subtitles.py
+ )
+ fi
+
+ # translate/storage/test_mo.py needs 'pocompile'
+ distutils_install_for_testing
+ epytest
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if ! use html; then
+ rm "${ED}"/usr/bin/{html2po,po2html} || die
+ fi
+ if ! use ical; then
+ rm "${ED}"/usr/bin/{ical2po,po2ical} || die
+ fi
+ if ! use ini; then
+ rm "${ED}"/usr/bin/{ini2po,po2ini} || die
+ fi
+ if ! use subtitles; then
+ rm "${ED}"/usr/bin/{sub2po,po2sub} || die
+ fi
+
+ python_optimize
+}
diff --git a/dev-python/x-wr-timezone/Manifest b/dev-python/x-wr-timezone/Manifest
new file mode 100644
index 000000000000..5c757b1726fd
--- /dev/null
+++ b/dev-python/x-wr-timezone/Manifest
@@ -0,0 +1,3 @@
+DIST x-wr-timezone-0.0.5.gh.tar.gz 19728 BLAKE2B d3b098da4ff358e19cb70c2f59bb95de55fc27f058359e6d8eca8595bc375e83c05d139491b8e06f07ab1a5ca9e0b9a2dc1fa87cb1aea83e722f494da2ebbc88 SHA512 b530e96e2e32febf82a4aac9fe1067431c7396a029ca785ade8a8c5e2fe04b1d95e60ecf7ecc9862057bffd3e9dd6a773d14c385cb431d1b22858091f3bd7892
+EBUILD x-wr-timezone-0.0.5.ebuild 677 BLAKE2B 4cda2eccbd5f2b269061fba8831f658115e6216819f21189bf41b61b06dcdf4aa5dd29780c43d5e38ed26d4bc8cb9944d172ccb219ecd1e8b6dc52f5d4be8e5b SHA512 dfba9f08cfb580d3979595e6c0a8b8602e8df59bd2ac14a6da45dbfe16329610d47b9be73bc5e08fcdfb1abd4aa8137d9d545c66a66f56c1216e8f0eed56928d
+MISC metadata.xml 408 BLAKE2B 9ebff9e35e34aa0db0fef0f13adff59a19f830403d467344b654649fecc102a1bcc18acbbce3194ea77946eb097181ef27b0010b03a9b28b24cb01c014daaf7f SHA512 53620e9fece9c7bf49101828bfc7625d1c9c329113716af89804a560e38b08ecf6528a60b06081cb731aaed85fa4ea219ebcacba143eb52313fe8b98e1aca565
diff --git a/dev-python/x-wr-timezone/metadata.xml b/dev-python/x-wr-timezone/metadata.xml
new file mode 100644
index 000000000000..62a860ccbf79
--- /dev/null
+++ b/dev-python/x-wr-timezone/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">niccokunzmann/x-wr-timezone</remote-id>
+ <remote-id type="pypi">x-wr-timezone</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/x-wr-timezone/x-wr-timezone-0.0.5.ebuild b/dev-python/x-wr-timezone/x-wr-timezone-0.0.5.ebuild
new file mode 100644
index 000000000000..39d605d10fe4
--- /dev/null
+++ b/dev-python/x-wr-timezone/x-wr-timezone-0.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert calendars using X-WR-TIMEZONE to standard ones"
+HOMEPAGE="
+ https://github.com/niccokunzmann/x-wr-timezone/
+ https://pypi.org/project/x-wr-timezone/
+"
+SRC_URI="
+ https://github.com/niccokunzmann/x-wr-timezone/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ test/test_readme.py
+)