summaryrefslogtreecommitdiff
path: root/dev-python/zstandard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/zstandard
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/zstandard')
-rw-r--r--dev-python/zstandard/Manifest4
-rw-r--r--dev-python/zstandard/zstandard-0.17.0-r1.ebuild (renamed from dev-python/zstandard/zstandard-0.17.0.ebuild)30
-rw-r--r--dev-python/zstandard/zstandard-0.18.0.ebuild67
3 files changed, 93 insertions, 8 deletions
diff --git a/dev-python/zstandard/Manifest b/dev-python/zstandard/Manifest
index 48c881c62c7a..dce816b1dea7 100644
--- a/dev-python/zstandard/Manifest
+++ b/dev-python/zstandard/Manifest
@@ -1,3 +1,5 @@
+DIST python-zstandard-0.18.0.gh.tar.gz 678765 BLAKE2B 7a297e76d65c6f5adbb87cc615f474d58c66bc9ee4050eb10277b596f7efda9109de815188b6efe55beb7aa637ec4779359a573c87094661ae28a080c9619576 SHA512 d573da893e3a372143271c7d9dec15cd4e9dd7355d2069e283df8b3feadbf999dddcc0aa37a2831a370526b2b045497f46326dcf13d3680dd8ee624bca1e7666
DIST zstandard-0.17.0.tar.gz 629456 BLAKE2B 2b19c017b6255eaa22037e633f1f1dea1322c21dda3f1129e9593c5782b6cf3dbba12003711f6192bfa474a918cbf1eae2b5dd21fbf78731b8dfc62e69a27048 SHA512 312aa02c7309fac64cf70ca901942118d4b3f12f27d20cc18dcaba5ce155ad81ea8d7657501a33a5fb6cdc8bcca11f91141ea9d6c3fc09c28a84d698b9050391
-EBUILD zstandard-0.17.0.ebuild 1177 BLAKE2B e4fa6fb7020231148ecc9f5b01a24c00b72320b1c53adba141365ecc92388d877c473f7812d155db637c3049481f99e9f93cdf9b7bcc7bc99a907f4164be3f9e SHA512 a455965caadd81b368f1c3cad8827e01b0cc323c18fda910c02eec5c41844fd0a0ea9a96635a95a13cb4088d21614a2dd203860fcb716a5cedc9fa38dc4cb68e
+EBUILD zstandard-0.17.0-r1.ebuild 1289 BLAKE2B 87e499d2f68d68d1a849fc68141b7d668e06fede1e08274fece25fde25cf5d432080e5fab45b8691e6757aad5107aa0bbc351673f74b59b0a7e3859610027c95 SHA512 71bfd3942fc904e2818b8614588cf891f4735cec1942a239d2ca64be48a42263eee8b06cf80a8cebd0a766495f266701b8aaf1ffb08da685e5ef453fccff0c80
+EBUILD zstandard-0.18.0.ebuild 1616 BLAKE2B 6d1f0fb63b3aa7a66feacd5f53a9935f6c6af57e1b1179aa222a9cc990081cb53d3f74b0e35ab9553100af423f438ba675f42b2fabab6c1a4f03d41d4f57d2ee SHA512 84c3c467577767193da1fd6f952a9b58f4fc713e8976ad2814be0abbd9e66fa2d0f1f488500c79da0e2f964e858cf723d78a125267776af029f545dd7e98221e
MISC metadata.xml 378 BLAKE2B dd5834c84bb375812b3a3cfcc00d29aa43ac8954b044e188e8f38bdca93fdf1ce98fe78b78dbeccd935c83ca10f3ce18f893e5720dd8991118b6c69149a4ac61 SHA512 06554d973b525d53c680c3e43041f33125dad222339e645294fbc22670a7eadb0e9bf8a3b0771d2b2fb8f136d958eadb32c295179d1547c50ae26754360609f3
diff --git a/dev-python/zstandard/zstandard-0.17.0.ebuild b/dev-python/zstandard/zstandard-0.17.0-r1.ebuild
index 17b3938e7fb1..a0df0997b930 100644
--- a/dev-python/zstandard/zstandard-0.17.0.ebuild
+++ b/dev-python/zstandard/zstandard-0.17.0-r1.ebuild
@@ -3,12 +3,16 @@
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="Zstandard Bindings for Python"
-HOMEPAGE="https://pypi.org/project/zstandard/ https://github.com/indygreg/python-zstandard"
+HOMEPAGE="
+ https://github.com/indygreg/python-zstandard/
+ https://pypi.org/project/zstandard/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
@@ -16,14 +20,21 @@ LICENSE="BSD"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
DEPEND="
- app-arch/zstd:="
-RDEPEND="${DEPEND}
- $(python_gen_cond_dep '>=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]' 'python*')
+ app-arch/zstd:=
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]
+ ' 'python*')
"
BDEPEND="
- test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
-distutils_enable_tests setup.py
+distutils_enable_tests unittest
src_prepare() {
# the C backend is repeatedly broken, so force CFFI instead
@@ -40,3 +51,8 @@ src_prepare() {
--system-zstd
)
}
+
+src_test() {
+ rm -r zstandard || die
+ distutils-r1_src_test
+}
diff --git a/dev-python/zstandard/zstandard-0.18.0.ebuild b/dev-python/zstandard/zstandard-0.18.0.ebuild
new file mode 100644
index 000000000000..24b3d7e8d9f0
--- /dev/null
+++ b/dev-python/zstandard/zstandard-0.18.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-zstandard-${PV}
+DESCRIPTION="Zstandard Bindings for Python"
+HOMEPAGE="
+ https://github.com/indygreg/python-zstandard/
+ https://pypi.org/project/zstandard/
+"
+SRC_URI="
+ https://github.com/indygreg/python-zstandard/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="
+ app-arch/zstd:=
+"
+RDEPEND="
+ ${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/cffi-1.14.0-r2:=[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # the C backend is repeatedly broken, so force CFFI instead
+ sed -e '/PYTHON_ZSTANDARD_IMPORT_POLICY/s:default:cffi:' \
+ -i zstandard/__init__.py || die
+ # unreliable, fails on x86
+ sed -e 's:test_estimated_compression_context_size:_&:' \
+ -i tests/test_data_structures.py || die
+ # unbundle zstd
+ : > zstd/zstdlib.c || die
+ # it does random preprocessing on that, so we can't use #include
+ cp "${ESYSROOT}/usr/include/zstd.h" zstd/zstd.h || die
+ sed -i -e '/include_dirs/a libraries=["zstd"],' make_cffi.py || die
+
+ distutils-r1_src_prepare
+
+ DISTUTILS_ARGS=(
+ --no-c-backend
+ )
+}
+
+src_test() {
+ rm -r zstandard || die
+ distutils-r1_src_test
+}