summaryrefslogtreecommitdiff
path: root/dev-python/zope-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 02:06:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 02:06:14 +0000
commit5987fa693ef880163ebde423615a177cb5bda20e (patch)
tree643ae0ed032ef417c538f8d04da516b9c2fa2a7d /dev-python/zope-testing
parent41e056b08e4c5c8d6e78407a5586afa52867fd5f (diff)
gentoo auto-resync : 17:02:2023 - 02:06:14
Diffstat (limited to 'dev-python/zope-testing')
-rw-r--r--dev-python/zope-testing/Manifest2
-rw-r--r--dev-python/zope-testing/zope-testing-4.10-r2.ebuild47
2 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/zope-testing/Manifest b/dev-python/zope-testing/Manifest
index 3d41b6f90462..ed3d81eb12b5 100644
--- a/dev-python/zope-testing/Manifest
+++ b/dev-python/zope-testing/Manifest
@@ -1,5 +1,3 @@
-DIST zope.testing-4.10.tar.gz 45359 BLAKE2B 477d28a7d1a76c0a5111f16859d9e3b9b9ac9cc953b0e2c7dd9ba0a39b498d71442d1b5aaf485455c919ad618efb1f9f9b8e1587fd4905c4a823b04ef09ef8b2 SHA512 35fd5114b6de3cb47336185feb8bf8f444b53ef2c32f165e57756a017ec9caba9a29f2ec01844ebcf156fff1c2b7424b3ac126b3e8d4daefe73e1a640d21589a
DIST zope.testing-5.0.1.tar.gz 41745 BLAKE2B c3ab3ba7a15a050a29e41c26df3426dc3dd48d98b60e55015680c6aa86fccbbf44718d17643189a1978c51605eb774c108e0056a1e21023b99ca633a2abd7788 SHA512 357d1c0eb761dba4e0e964a51dbc4368c00c9133a011467a2bb3629a2c5c28ccb3886caad215288b99cda1de25fd7ead674068f275649d94a32dc42d19d78caf
-EBUILD zope-testing-4.10-r2.ebuild 1105 BLAKE2B a616ea8462fff9a61f03bf39e2654d82adcedd9518146900fdf24926b6fe705fdcf1fc7d2abc5d5ef00367b60dad638b3efa75c36ddbe9daf583395250f6ae57 SHA512 3d6819f0f3b73d011654a84887ab705bdbf91431e78ab90b740daefe1f78ceeda7a4a4acff0d2628b8d413329f80f2fa8901251b30918eacbbc63c4d505e6ef0
EBUILD zope-testing-5.0.1.ebuild 1337 BLAKE2B b33974e7b118e08dbd53bcbe0424ec3da46967553a6fa49f02e55c1d9a4d8b2d570a53d97950f83a9ad48d6b2869e7eef93bd0ed323a5a5ac29971a7de5065cd SHA512 c2dd9a0f7b4cea08a08ad03b8a53f6ea6c1db06ced30e8378965e9ca46eb7a7f2bfef5d4e2da04412781e807ea2535a7dd9c4e0a2dd99b6ad9248b570752c149
MISC metadata.xml 407 BLAKE2B a3792d048bb4472d3d22458ced65e08f25a2a0314858ae86a7dc6573989b3f49139f4452d19c073890443fbc5b09c681bc612057637aa548d88e1f0f7501182d SHA512 a61142f2fe381939bd26c4cbd66512df42b42374331fd56c36a4dc9640b634c8c21d5680ed9c621b05b401446415ea145100b2334cffd3f579916a95f3857f47
diff --git a/dev-python/zope-testing/zope-testing-4.10-r2.ebuild b/dev-python/zope-testing/zope-testing-4.10-r2.ebuild
deleted file mode 100644
index 48c852836463..000000000000
--- a/dev-python/zope-testing/zope-testing-4.10-r2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope testing helpers"
-HOMEPAGE="
- https://pypi.org/project/zope.testing/
- https://github.com/zopefoundation/zope.testing/
-"
-SRC_URI="mirror://pypi/${P::1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="
- !dev-python/namespace-zope
-"
-
-distutils_enable_tests unittest
-
-src_prepare() {
- # strip rdep specific to namespaces
- sed -i -e "/'setuptools'/d" setup.py || die
- distutils-r1_src_prepare
-}
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-python_test() {
- cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
- distutils_write_namespace zope
- eunittest
-}