summaryrefslogtreecommitdiff
path: root/dev-python/zope-testing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/zope-testing
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/zope-testing')
-rw-r--r--dev-python/zope-testing/Manifest5
-rw-r--r--dev-python/zope-testing/zope-testing-4.10-r1.ebuild43
-rw-r--r--dev-python/zope-testing/zope-testing-4.10.ebuild2
-rw-r--r--dev-python/zope-testing/zope-testing-4.9.ebuild31
4 files changed, 46 insertions, 35 deletions
diff --git a/dev-python/zope-testing/Manifest b/dev-python/zope-testing/Manifest
index f629eaad65a0..574585427fd2 100644
--- a/dev-python/zope-testing/Manifest
+++ b/dev-python/zope-testing/Manifest
@@ -1,5 +1,4 @@
DIST zope.testing-4.10.tar.gz 45359 BLAKE2B 477d28a7d1a76c0a5111f16859d9e3b9b9ac9cc953b0e2c7dd9ba0a39b498d71442d1b5aaf485455c919ad618efb1f9f9b8e1587fd4905c4a823b04ef09ef8b2 SHA512 35fd5114b6de3cb47336185feb8bf8f444b53ef2c32f165e57756a017ec9caba9a29f2ec01844ebcf156fff1c2b7424b3ac126b3e8d4daefe73e1a640d21589a
-DIST zope.testing-4.9.tar.gz 62294 BLAKE2B 34b2fc10e7220d88451b655d0e43f513d004779c496c824fa3e58b17c883a401f4707d5dbe7a547f1f97fe7db73b25cdf16997f2733b832ceabc37f1d5265397 SHA512 04b660aa93e120ae7e57bf637d99302d26912800ea3995a24c6d252ee4bd8e06fd8d4a24d980f591846d9bca93523373a92528ef492ff4d6990887ab6cf527d0
-EBUILD zope-testing-4.10.ebuild 940 BLAKE2B 576abbe82da4b5c2257b33ed456b507d3e91494d823b814bf765c348f25464f75f9716f2760f9784447f931d9f5f75017be1862ee71a095a4ca3a1115d028fdd SHA512 90edc6b1219d861281ce253ecb67489e10a09107c68e108424cefddb48759bcb70c1cb4c937ebade93cbf3a1716029d3ac906bb43cf918f99f1ae38d5ea13c4c
-EBUILD zope-testing-4.9.ebuild 936 BLAKE2B 1ee316f1c41e37cf97902792aaf65a715f87b48e86bd5fb9dd6c57958350da3484334c50c296c2f542bb677060a236d722460e150e79a8a4a2b3024a7c3d7461 SHA512 8090f80b5827a7a3b98fceae5fe67815fe4ddf4983951eee921b8653f0a8a88e1b8004c0769092e213da51325822de009b659debbcd4d288ca190d9b9879c06b
+EBUILD zope-testing-4.10-r1.ebuild 1065 BLAKE2B da121d4ecf8216ea1e22e644ab8ad2e4c19d5866713e571f179c5d445ba93e36caca48bddd0aeadae56ecabba5e7b1bc53753f5f56389a2b9b76bd612db94090 SHA512 4e36bb1daf03f0c71329f52e2bce4edd254f168a480332feeb72f70991186356648a13e613c776ee1d8171939cc0b20c7a73d77a03652ee70f86cac92bdba240
+EBUILD zope-testing-4.10.ebuild 932 BLAKE2B fbdb2bc3630aff343bc9f1cedb72bd4a3810ad8d2311469b82aed8b27c09e2de4eab9ccd1f8300cd33ddc36afbb84f044db38338bb240963124782657b930636 SHA512 d3ae2760ff04d3b097639352957f7053275f488c8e6704b3c6475b83881c358f0e62b9497492f58c41e49866de76ff874f2a169475f6c9c6833bda92686e45df
MISC metadata.xml 407 BLAKE2B a3792d048bb4472d3d22458ced65e08f25a2a0314858ae86a7dc6573989b3f49139f4452d19c073890443fbc5b09c681bc612057637aa548d88e1f0f7501182d SHA512 a61142f2fe381939bd26c4cbd66512df42b42374331fd56c36a4dc9640b634c8c21d5680ed9c621b05b401446415ea145100b2334cffd3f579916a95f3857f47
diff --git a/dev-python/zope-testing/zope-testing-4.10-r1.ebuild b/dev-python/zope-testing/zope-testing-4.10-r1.ebuild
new file mode 100644
index 000000000000..8f8245db3264
--- /dev/null
+++ b/dev-python/zope-testing/zope-testing-4.10-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope testing helpers"
+HOMEPAGE="
+ https://pypi.org/project/zope.testing/
+ https://github.com/zopefoundation/zope.testing/
+"
+SRC_URI="mirror://pypi/${P::1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}
diff --git a/dev-python/zope-testing/zope-testing-4.10.ebuild b/dev-python/zope-testing/zope-testing-4.10.ebuild
index 145ffda764aa..7150662e05d2 100644
--- a/dev-python/zope-testing/zope-testing-4.10.ebuild
+++ b/dev-python/zope-testing/zope-testing-4.10.ebuild
@@ -18,7 +18,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="ZPL"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
diff --git a/dev-python/zope-testing/zope-testing-4.9.ebuild b/dev-python/zope-testing/zope-testing-4.9.ebuild
deleted file mode 100644
index 4da58c831cae..000000000000
--- a/dev-python/zope-testing/zope-testing-4.9.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Zope testing helpers"
-HOMEPAGE="https://pypi.org/project/zope.testing/ https://github.com/zopefoundation/zope.testing"
-SRC_URI="mirror://pypi/${MY_PN::1}/${MY_PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="dev-python/namespace-zope[${PYTHON_USEDEP}]"
-
-distutils_enable_tests setup.py
-
-python_install_all() {
- distutils-r1_python_install_all
-
- # remove .pth files since dev-python/namespace-zope handles the ns
- find "${D}" -name '*.pth' -delete || die
-}