summaryrefslogtreecommitdiff
path: root/dev-python/zope-i18nmessageid/zope-i18nmessageid-4.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /dev-python/zope-i18nmessageid/zope-i18nmessageid-4.1.0.ebuild
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'dev-python/zope-i18nmessageid/zope-i18nmessageid-4.1.0.ebuild')
-rw-r--r--dev-python/zope-i18nmessageid/zope-i18nmessageid-4.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/zope-i18nmessageid/zope-i18nmessageid-4.1.0.ebuild b/dev-python/zope-i18nmessageid/zope-i18nmessageid-4.1.0.ebuild
new file mode 100644
index 000000000000..5fbf4d32c54c
--- /dev/null
+++ b/dev-python/zope-i18nmessageid/zope-i18nmessageid-4.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+MY_PN=zope.i18nmessageid
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Zope i18nmessageid Architecture"
+HOMEPAGE="https://github.com/zopefoundation/zope.i18nmessageid http://docs.zope.org/zope.i18nmessageid/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # remove .pth files since dev-python/namespace-zope handles the ns
+ find "${D}" -name '*.pth' -delete || die
+}