summaryrefslogtreecommitdiff
path: root/dev-python/zipstream-ng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-11 11:06:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-11 11:06:02 +0100
commite93a38d535f2c29b55a5756d2de99425986b0bf3 (patch)
treec0fa85c173d211181d0093e7dc031623e7b8a9a3 /dev-python/zipstream-ng
parentfbbf0ee3d56a6fd27adf182c6907dc745623aeaa (diff)
gentoo auto-resync : 11:08:2024 - 11:06:01
Diffstat (limited to 'dev-python/zipstream-ng')
-rw-r--r--dev-python/zipstream-ng/Manifest3
-rw-r--r--dev-python/zipstream-ng/metadata.xml12
-rw-r--r--dev-python/zipstream-ng/zipstream-ng-1.7.1.ebuild22
3 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/zipstream-ng/Manifest b/dev-python/zipstream-ng/Manifest
new file mode 100644
index 000000000000..b55cb2ff4e66
--- /dev/null
+++ b/dev-python/zipstream-ng/Manifest
@@ -0,0 +1,3 @@
+DIST zipstream-ng-1.7.1.tar.gz 35488 BLAKE2B e255f01945eb654d2cac9e90bb7e06e5b93d6098ff7d79de765c2c6e69dc29932c909ed9b5b3737b6fbd2050165596d78e4e4602e9f63c032e6bc087596638c8 SHA512 4e39aeb47222a7e790ee8d7281f6f41f54568eef92e26467ff249c3dec9987b766943290f6b1554cd0d5d5e7908e06a2b862e5555694c6a4a433c80264a22c9a
+EBUILD zipstream-ng-1.7.1.ebuild 472 BLAKE2B 8a694982298f7298e450b191ede84a311e55057ebbf9eb3e86f6972ccbdedc00aa1a9981a5e90e4e86372a02620549a98d630962fdbb4e80575b3dd20255b776 SHA512 6c21632d590818cf239aab721881f7a5b9b1938fe6c2bacaafb8decdb1f7fed6956decddaa5f66643d46ab8086780a385c558f0fc0e813c8e77aa258bd9b23ac
+MISC metadata.xml 376 BLAKE2B 82beaacf30d7978e8ae28dcdb01a502672e110b1e14953b17262cbed9d5d7e96886df06647a62076bd03e5e00d0b35c9f32f068064aec2c91300f19491336972 SHA512 2ca1e5420b7c1060f4484cc699f693df85d48ac61de0ee8cc9e0c2204a1ca3eaa026934a0630b6ed8a3bcb917c7fada02d543c81c55afec52d93afc907486cdc
diff --git a/dev-python/zipstream-ng/metadata.xml b/dev-python/zipstream-ng/metadata.xml
new file mode 100644
index 000000000000..a66ca8f5b9d9
--- /dev/null
+++ b/dev-python/zipstream-ng/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">pR0Ps/zipstream-ng</remote-id>
+ <remote-id type="pypi">zipstream-ng</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zipstream-ng/zipstream-ng-1.7.1.ebuild b/dev-python/zipstream-ng/zipstream-ng-1.7.1.ebuild
new file mode 100644
index 000000000000..1c5700daef64
--- /dev/null
+++ b/dev-python/zipstream-ng/zipstream-ng-1.7.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A modern and easy to use streamable zip file generator"
+HOMEPAGE="
+ https://github.com/pR0Ps/zipstream-ng/
+ https://pypi.org/project/zipstream-ng/
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest