summaryrefslogtreecommitdiff
path: root/dev-python/zipp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-12 19:33:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-12 19:33:50 +0100
commitad4a5451f677f33e2de05548b45fb92a8b3d04da (patch)
tree807636cd1996ad3cbc1c745670820af086688978 /dev-python/zipp
parente4b9f141e31db1e069e3bcf5b1fb81af77b0cace (diff)
gentoo auto-resync : 12:07:2022 - 19:33:50
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest2
-rw-r--r--dev-python/zipp/zipp-3.8.1.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index d0268512955d..1a3f9f0b7d52 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,3 +1,5 @@
DIST zipp-3.8.0.tar.gz 13344 BLAKE2B 0da3ca4ff683ac840759030b6ee5125bb1a1b1b8737f0ff0499f3193d13dc3163c6c1fd29c5f1667f347728c991930e3d9e3a325ffb89b6fecb9f6590887bcaa SHA512 d677f941dc92a784b8bd197ca2e1f6f3a570dc236c9eeddcb6108d6f55ad3d35a82462abeeb4bac6ea434442737aea960d941c2a7d0bd416da9abee153c99bb8
+DIST zipp-3.8.1.tar.gz 14189 BLAKE2B 768d25dab70ee1ddbb3adb829b68515631772e2e25a7617d58bf863c01d1900e22cd4001bf31b9eae3829a63cba77df070132e7932b9b4242bb8be3579a1546d SHA512 05639feb20c7e8d3480ce17a52115a85bb2f0706ee0c1b15589b7556bb914ef30a1a34fa743217694b753bb5e72095c90fab7dfee85f2dbf461347322acb4d2e
EBUILD zipp-3.8.0.ebuild 1438 BLAKE2B d6857903252a23d0d802fc48c13dc5392feaaebf46f754ef1ce8ab608c3ad999feddce0338bc03aacfe9f19598f22062efb2e43ccaf50cb1e6554f59b37998f3 SHA512 a078ba1974f2339ca3e79f879bfd641f4b09a07fb83dea1a10bd24a63d51d9861d03a2d53d4c516dfb421d9dbecd82edfeccd0f900088dabfe6000e29195d8ad
+EBUILD zipp-3.8.1.ebuild 1446 BLAKE2B 4889596531fa751c83d303568f0e059e96d3fbb21f00e3ffd6ab8feaafcb42e07b27bcd21cf845475e4569168e16dfe542e57b5b7fe7bff231c9b542eb5d06e0 SHA512 b2f00b80ae3c69bab83da79f58de955105745222b919f474d2e252f56ccab2e3d3bb17dac453ba743da7a5f1beba273d272c3e98845d41c813ad039ea39a3a28
MISC metadata.xml 548 BLAKE2B 0bcd7b95c50e9e14ada6f3f02145bec64ee365beacf3447659276c1a5454355714f83fd2dc81a035a56d11ba1eb989f32bc0209a540b28fb72c3126d4d45a5fa SHA512 f214f6711b3197a44ec5c03b418aab3c9b907e0b3a297cb1c4e2ac3a499acefeb4de411443495db9678cbfd75460f89c9c40a57fc1bc404acbab844223a129d2
diff --git a/dev-python/zipp/zipp-3.8.1.ebuild b/dev-python/zipp/zipp-3.8.1.ebuild
new file mode 100644
index 000000000000..a11534941ce4
--- /dev/null
+++ b/dev-python/zipp/zipp-3.8.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+src_prepare() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' test_zipp.py || die
+ distutils-r1_src_prepare
+}
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}