summaryrefslogtreecommitdiff
path: root/dev-python/zipp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/zipp
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest4
-rw-r--r--dev-python/zipp/zipp-3.5.1.ebuild43
-rw-r--r--dev-python/zipp/zipp-3.6.0.ebuild43
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 568ef1ecdaab..9952869bea07 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,3 +1,7 @@
DIST zipp-3.5.0.tar.gz 13270 BLAKE2B ba3b6f82ed0f1a902050ee8a89b6876a839d180dc048dd19cd31ddbaf89ec0494b9444f2ac082ed347e3183ccaf2e8342748737c2a29e1a2bbc492a0bc34767c SHA512 676d7e9a7fde386b57a213975121aba015461453f0809a97d39d030b06918a4c54ba1cad21877ddf007560941ae285883098d81d5e6f17eb4636379345b4513d
+DIST zipp-3.5.1.tar.gz 13005 BLAKE2B fe50ce8467dcb62a3685a56d3feab0b227832320f4d97ba7eb12a07a66065c1acee8ecb391812e2c772e7c55bbd4966743891f9fd80adf1138b289ed0bc06cd6 SHA512 7043d491a7f5588416973c4ea9d1fb5e47ee7febe423d01ee131662867ed1d616e2df4d2c87ad327ff1b8b297a8b10c6584cfce5de27d09a81d7a7ce4fcc4815
+DIST zipp-3.6.0.tar.gz 13047 BLAKE2B 2e3f5fd0acf9f931f5a74957e9ae29f12a42bc824eb36d769720282ec0413d90b0b45f0524f3b319ce614f43c061ae324fb29f7f2a83e7aeb393283827bca5d1 SHA512 8e21b0a757ed9ebddeca43d3e4b64549dc4e59f781704626b0b2b0a117752b84798a0484cceedd4684ee0459643df4d0f479e64a143c8d9337d2b66951a7b227
EBUILD zipp-3.5.0.ebuild 1171 BLAKE2B f2c342697838816f4cf123b4c70fd3efde81224ea68b805f0982098ea67d5b7a4c65fa3fab0b16a9793bae3d874a778c4c21d3d3b3317c45bc64d66359e9119c SHA512 25cb668ae1061224a1b4e619c7467cbea67268f4f514e2cf37123dabec733ea5e8bba8b9e442fe6203bc7838256647077fa9606cb0c42e353bac2320a9d94b6d
+EBUILD zipp-3.5.1.ebuild 1165 BLAKE2B fa429305db0085ad1ab8ea82aba683edd5f1946298a6c3de23a1e4a5dd6f92fcbddcbfd87a2fb1b41b7f1a791ab68658cd7fea3264653367f5885a1bdb9eb790 SHA512 9fcd9bf08b339069773ddfb758d3e71863bd686647740888c26ee7912228490e6854b86818f59779c8f7df509fc44d09d1a320d7ace8c85e3f3adc90ea4a2407
+EBUILD zipp-3.6.0.ebuild 1165 BLAKE2B fa429305db0085ad1ab8ea82aba683edd5f1946298a6c3de23a1e4a5dd6f92fcbddcbfd87a2fb1b41b7f1a791ab68658cd7fea3264653367f5885a1bdb9eb790 SHA512 9fcd9bf08b339069773ddfb758d3e71863bd686647740888c26ee7912228490e6854b86818f59779c8f7df509fc44d09d1a320d7ace8c85e3f3adc90ea4a2407
MISC metadata.xml 548 BLAKE2B 0bcd7b95c50e9e14ada6f3f02145bec64ee365beacf3447659276c1a5454355714f83fd2dc81a035a56d11ba1eb989f32bc0209a540b28fb72c3126d4d45a5fa SHA512 f214f6711b3197a44ec5c03b418aab3c9b907e0b3a297cb1c4e2ac3a499acefeb4de411443495db9678cbfd75460f89c9c40a57fc1bc404acbab844223a129d2
diff --git a/dev-python/zipp/zipp-3.5.1.ebuild b/dev-python/zipp/zipp-3.5.1.ebuild
new file mode 100644
index 000000000000..bef59282ca20
--- /dev/null
+++ b/dev-python/zipp/zipp-3.5.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+EPYTEST_IGNORE=(
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ zipp.py
+)
+
+python_prepare_all() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/zipp/zipp-3.6.0.ebuild b/dev-python/zipp/zipp-3.6.0.ebuild
new file mode 100644
index 000000000000..bef59282ca20
--- /dev/null
+++ b/dev-python/zipp/zipp-3.6.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+EPYTEST_IGNORE=(
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ zipp.py
+)
+
+python_prepare_all() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}