summaryrefslogtreecommitdiff
path: root/dev-python/zict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/zict
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/zict')
-rw-r--r--dev-python/zict/Manifest3
-rw-r--r--dev-python/zict/metadata.xml12
-rw-r--r--dev-python/zict/zict-0.1.2.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/zict/Manifest b/dev-python/zict/Manifest
new file mode 100644
index 000000000000..4d3d0bea9306
--- /dev/null
+++ b/dev-python/zict/Manifest
@@ -0,0 +1,3 @@
+DIST zict-0.1.2.tar.gz 10839 BLAKE2B 6256e6202f6cca1db025d21c42b98163ad897ceda6a1b878e75165b358ec0a4b9150f04ecdc05f5408dd74c97212b8301d1f45d91f92dad138789570ffcfa562 SHA512 13fc6647bc1506bc5e8f69d39a07851a06634949ce917f294762ff3143c8a539117f8731b103df2663708fa1e8c968359985d9c4273aa952f500a89019c176e3
+EBUILD zict-0.1.2.ebuild 662 BLAKE2B 8f6947aa5b36e1854ed3517e5755d1ca978a91259545388b25e0e1e7b8155dc62c2eef7e356534500c38d17c1543a36c85fc19bb2894a89b6bcf1a099b3c95e6 SHA512 85642116ae855fa325bdb0f3a4cc8c5cd890fdafbc35b3333efd8855312dc7f0c4944963f9b69a79f16f8eef30649dd01909ffcbe2ab1abec1163067270db986
+MISC metadata.xml 372 BLAKE2B e0704ea4318d17b85ab75fb9818e2ec6993173823f2b0d8fb92413e9ea83095a5ad95c05e69c4f6ae447c9cc2fe7a2735355b311e84b6036780a6b48ae5e7ff4 SHA512 02db2dbf57dc6d87318e8b79fc845f7aff7c6b98d80ea897bf24dca8f762f80581d69fd8990bca0e0d736997a93f2fd5a24fdad481b352e6a907c4b37a983eb0
diff --git a/dev-python/zict/metadata.xml b/dev-python/zict/metadata.xml
new file mode 100644
index 000000000000..e6987c16f383
--- /dev/null
+++ b/dev-python/zict/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">zict</remote-id>
+ <remote-id type="github">dask/zict</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zict/zict-0.1.2.ebuild b/dev-python/zict/zict-0.1.2.ebuild
new file mode 100644
index 000000000000..436b56ee9a9f
--- /dev/null
+++ b/dev-python/zict/zict-0.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mutable mapping tools"
+HOMEPAGE="https://github.com/dask/zict/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="dev-python/HeapDict[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/HeapDict[${PYTHON_USEDEP}]
+ dev-python/lmdb[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die
+}