summaryrefslogtreecommitdiff
path: root/dev-python/zeroconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-python/zeroconf
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest4
-rw-r--r--dev-python/zeroconf/zeroconf-0.29.0.ebuild2
-rw-r--r--dev-python/zeroconf/zeroconf-0.30.0.ebuild38
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index e68b2a5f1038..2a9df29835e6 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,3 +1,5 @@
DIST python-zeroconf-0.29.0.gh.tar.gz 62466 BLAKE2B 430a9f4d4460d66166a2484862a8dd3af65f3cfad0e25557648abf26ebe88a7ae581934273db270ff30fa4d714b32a822448b22fd7a95e9e382b68ffae9b66b4 SHA512 a084da17cda264b531e7f58975d30ae0b5adb98f33ca78d1e865e1450dc42ad2bca69bc319c268f7977e70e082ae713142a57f97a9f050486c47b50698002590
-EBUILD zeroconf-0.29.0.ebuild 1019 BLAKE2B eeeb5849ad7f77232763ad4c7ef6509750e1b0ba7991f95b54d4aef6b94b6cf0a553d6136a0167434276193ccb7a9c34d7989033361563da0b659d28b91bb6a5 SHA512 6a57f4032849d4dab334d5f2e4f09a61a67bbefea2f70a116bbfb3f8bd219bd08c9ed0b9e76bd91d9665afaaedc31ed8f968fcec0a49b881b1928eb740652974
+DIST python-zeroconf-0.30.0.gh.tar.gz 64301 BLAKE2B ea0d5e36f3f012f217cbd4eeff0a9cd366496e2f64b06112ee3629ad016c8e28877f62358d5b5fd27387cfe474e488e99a9ad8ca1802f6d23612f99310243c57 SHA512 1f3165500a07525ef182bb60c1804fe2002a33a9f800470bdb32bdfd44a1b8f466a818a4390537674952159e5c0e257cf9e4ca570b1a9936e1cf8be294be6311
+EBUILD zeroconf-0.29.0.ebuild 1020 BLAKE2B 96682217021cc24e84c8002bfaea5f5e5a4aa23990c68a3ab8cfea1ae0a7725cbabb5b153c07142a8298812992c833080b2fd65c0d1c4c20bf823c8010fdfc80 SHA512 d448b0d72a8078a50e5297de3f2d9626aa17368b75fb74d73b590d9244162fce010c43f5be198519851cf27969270f6ee324fc42bc4b66ca04d091ee3e34dad1
+EBUILD zeroconf-0.30.0.ebuild 1091 BLAKE2B 22b5020085a1c2c29e9469fb81d77388367d6df91cc3c7e080949c9873a5094f1539a5a0d4584e1d2c586c47327ba816bf680022a68f62971985607168e317a2 SHA512 fce0041c3b9d40de22e5e42e923604cc794b4c4ecf231c985feed2cd2c29a2b7d22d88e4290805e4a4c0f4908f6d5729e62a87356f24b52ee5ee56363c13ae63
MISC metadata.xml 412 BLAKE2B 70dd13f9065885850c7c24da7e1a0825a1537e452213847e00d8af9977818d6bfcfda9c8f9e0d0b2241550a95d186432e0072762a1b77e65b66441812b29651a SHA512 28bafc2919fa66c0f1e532798ac40c537a53c18e781590881116440886d09f5511425f2cddee912e3fc63ef92ee1a9c4da0f7f79cb44dab6e5f51d62202de844
diff --git a/dev-python/zeroconf/zeroconf-0.29.0.ebuild b/dev-python/zeroconf/zeroconf-0.29.0.ebuild
index 7a446550f3e8..83912114f7e2 100644
--- a/dev-python/zeroconf/zeroconf-0.29.0.ebuild
+++ b/dev-python/zeroconf/zeroconf-0.29.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
MY_P=python-zeroconf-${PV}
diff --git a/dev-python/zeroconf/zeroconf-0.30.0.ebuild b/dev-python/zeroconf/zeroconf-0.30.0.ebuild
new file mode 100644
index 000000000000..7468e3466c5c
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.30.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # network
+ zeroconf/test.py::Framework::test_close_multiple_times
+ zeroconf/test.py::Framework::test_launch_and_close
+ zeroconf/test.py::Framework::test_launch_and_close_v4_v6
+ zeroconf/test.py::Framework::test_launch_and_close_v6_only
+ zeroconf/test.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+ )
+
+ epytest ${excludes[@]/#/--deselect } zeroconf/test.py
+}